ESET blocking internal network connections even though set to trusted...

Discussion in 'ESET Smart Security' started by andyd2k, May 1, 2009.

Thread Status:
Not open for further replies.
  1. andyd2k

    andyd2k Registered Member

    Joined:
    May 1, 2009
    Posts:
    4
    I have a nmt device on my network that accesses my PC for media. If I turn off firewall, it can connect. But if I turn on the firewall, the device doesn't connect to my pc.

    1. Allow sharing is on
    2. Network is in trusted zone
     
  2. andyd2k

    andyd2k Registered Member

    Joined:
    May 1, 2009
    Posts:
    4
    If I put it in interactive mode, I get a pop up to allow. What's the point of having active sharing on and a trusted network if I'm going to get rule pop ups? And blocks if I have it on auto?
     
  3. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hi,

    The Automatic mode in ESS is the same as having "Block all inbound without exception"
    To allow unsolicited inbound, then you will need to have rules in place to allow that inbound. Once rules are in place you can set the firewall to "Automatic with exception"(i think that is the policy name).


    - Stem
     
  4. andyd2k

    andyd2k Registered Member

    Joined:
    May 1, 2009
    Posts:
    4
    ah ok. just weird that it would also block my trusted network

    thanks for the help
     
  5. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hi,

    There is certainly room for improvement on how the firewall treats trusted networks as currently it is not user friendly.

    Currently a trusted network is only allowed to see the PC with ESS 4 installed, not allowed direct access.


    - Stem
     
  6. andyd2k

    andyd2k Registered Member

    Joined:
    May 1, 2009
    Posts:
    4
    When you say room for improvement, do you mean it doesn't work? Because I'm unable to stream any video to my TV even though...

    1. Trusted Network
    2. File sharing enabled
    3. Explicit rules set up so that both inbound / outbound directions are allowed.

    The only way it works is if I disable the firewall. And setting it on interactive doesn't pop any rules for setting up
     
  7. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    That sounds more like outbound being blocked than inbound.


    Go into the IDS settings and set to log all blocked packets. Attempt to stream the video, Then post the log.


    - Stem

    edit; What OS are you using?
     
Thread Status:
Not open for further replies.