Error Downloading Updates

Discussion in 'SpywareBlaster & Other Forum' started by teeezur, Jan 8, 2006.

Thread Status:
Not open for further replies.
  1. teeezur

    teeezur Registered Member

    Joined:
    Mar 11, 2005
    Posts:
    5
    If I configure Updates to "Use Alternative Download Method", I get the error message...

    Error Downloading Updates

    There was an error downloading the database files.

    Please make sure SpywareBlaster has access to the internet,
    and that you have disabled any proxies or other filtering programs.

    If I remove the setting to use alternative download method I have no problem downloading the updates. Any reason why the alternative download method no longer works? I have SpywareBlaster 3.51 loaded on many computers and they all get this same error message unless I remove the alternative download setting.
     
  2. dallasjaguar

    dallasjaguar Guest

    CLEARLY THERE IS A FLAW IN THE NEW 3.5.1 version. I have downloaded and reinstalled twice, turning off norton, and prior making sure firewall permissions were set to allow Spywareblaster to access internet. Nevertheless, as numerous others report, manual updates do not connect to internet. I have used prior versions of product for past couple of years with no problems or complaints. STOP PASSING THE BUCK BACK TO NORTON OR USER AND FIX THIS ISSUE PLEASE--RECOGNIZE THAT YOU HAVE A FLAW IN 3.5.1. Yuur product heretofore has been excellent and appreciated. Get it right again this time. Thanks
     
  3. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    Hi,

    What version of Windows are you using? And what language is your version of Windows?

    The Alternative Download Method is only recommended for a very few cases (hence why it isn't enabled by default ;)), and usually only when the program sets the option itself.

    Best regards,

    -Javacool
     
    Last edited: Jan 9, 2006
  4. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    The few reports of updating problems have had one of three things in common:

    1.) They were using a proxy and/or other filtering program, and simply had to add spywareblaster.net to an exclude list or set SpywareBlaster itself to connect directly to the Internet (bypassing the proxy/filtering software).

    2.) They were from users with Norton Internet Security. In some of these cases, there were multiple rules for spywareblaster.exe in the firewall configuration options (deleting all rules and creating a new one usually fixes this). In other cases, a reinstall of NIS fixed the issue. And in a few others, disabling NIS fixed the issue temporarily.

    3.) As mentioned above, you should not set the "Use Alternative Download method" option unless the program sets it for you, or unless recommended by an expert.

    What version of Windows are you using? And what language is your version of Windows?

    Best regards,

    -Javacool
     
  5. moverweel

    moverweel Guest

    Same here. We connect to the Internet through a Microsoft ISA Server 2000 proxy with integrated authentication. Up to the previous version of SpywareBlaster, this was working fine as long as the "Use Alternative Download Method" option was checked. The new version, however, refuses to download the database files. It does detect that there is an update available, starts to download it (using 'Safe' download method) and then fails saying "There was an error downloading the database files. At least one of the files is corrupted". After that, both sbdatabase.dtb and sbdatabaseinf.dtb are 0 kB in size.

    Disabling the alternative download method doesn't help; in that case the program can't connect to the update site at all. We can't connect to the Internet directly, and our network administrators won't allow us to bypass authentication. As I said, the previous version was working fine, and since nothing else was changed I guess the problem must lie with the new version. I hope it can/will be fixed soon!
     
  6. teeezur

    teeezur Registered Member

    Joined:
    Mar 11, 2005
    Posts:
    5
    I'm running an English version of Windows XP.

    As the others above have stated, which I'm also experiencing...Direct Connection works great as long as you aren't behind a proxy. Since I'm occasionally on networks using proxies, I have always setup SpywareBlaster to connect using "Use system connection/proxy settings." and "Use Alternative Download Method." This configuration covers pretty much any type of network that I would be connected to. This has always worked up until the most recent version. Hopefully, you'll find a quick and speedy solution to allow this to work in the next version of your product.

    Thanks
     
  7. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    Hi,

    SpywareBlaster has never directly supported proxies that require authentication, and unfortunately anything that may have worked in the past may not currently work because of necessary updating changes.

    However, there is another tweak that might help.

    If you are running Windows XP, copy and paste the following into notepad, and save it as "OtherDownloadMethod.reg":

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\SpywareBlaster\Settings]
    "DownloadMethod3"=hex:ff,ff
    Make sure SpywareBlaster is closed, and then double-click the file you just saved. And then try SpywareBlaster again (just make sure you've set it to use the system proxy settings).

    Best regards,

    -Javacool
     
  8. moverweel

    moverweel Guest

    Thanks for your quick reply! Unfortunately we are running Windows 2000 SP4. We'll probably have to resign to updating manually...
     
  9. teeezur

    teeezur Registered Member

    Joined:
    Mar 11, 2005
    Posts:
    5
    Playing around with the Update Options I was able to get SpywareBlaster to update thru a proxy without using your fix.

    But that leads me to another question...

    Why am I able to update if I specifically select "Use the proxy below (address:port)" and enter the correct proxy address and port number but if I select "Use system connection/proxy settings.", it doesn't work?

    Under Internet Explorer...Properties...Connections...Lan Settings, I have the correct proxy address and port number entered yet SpywareBlaster is obviously not reading that info if I use the setting "Use the proxy below (address:port)"

    Is this a bug?
     
  10. moverweel

    moverweel Guest

    Well, what do you know... The same solution works for us as well! Just specified the "Use the proxy below (address:port)" option, switched off the alternative download method and bingo! Thanks to teezur for the suggestion!
     
  11. ljcjrl

    ljcjrl Registered Member

    Joined:
    Sep 5, 2004
    Posts:
    1
    I run norton nis and was having the same problem with the manual download of Spywareblaster 3.5.1. The way to fix it for me was that when the alert flashed about high risk I used the roll down menu and picked manually set up. Norton pops up with a screen to set up. The first screen says permit on the top radio button. it should already be set. after that just hit next till you get to the screen that says home, away, etc. my mistake was i didn't make sure all were checked. make sure they all are checked. I went back to spywareblaster and another screen from norton showed up to tell me that now spywareblaster wanted to get to the internet. So I just did what I did the first time with the norton manual setup and my manual updates started working. I hope this helps cause I'm not to good at explaining things.
     
  12. teeezur

    teeezur Registered Member

    Joined:
    Mar 11, 2005
    Posts:
    5
    So, whats the verdict on whether there is a bug in the "Use system connection/proxy settings." in Options?
     
Loading...
Thread Status:
Not open for further replies.