error 1314 (Privilege not held)

Discussion in 'Acronis True Image Product Line' started by mprezgot, Jan 2, 2009.

Thread Status:
Not open for further replies.
  1. mprezgot

    mprezgot Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    31
    Location:
    Kingston, ON CANADA
    I still haven't received any answers (not even directly from Acronis) regardnig inability to execute backup task when logged in as Standard User (running ATI 2009 as ADMIN). I can select or edit task but it won't go any further. Log shows this: <log build="271" product="Acronis Scheduler" uuid="79A65F45-EB52-48AF-8BC8-3CF186E8A392" version="1.0">
    <event code="1314" id="1" level="4" message="Scheduler unable to run the task &quot;Vista&quot; with GUID 307A839C-92DE-4B17-9BA5-7DD20614F3B6 because of the error 1314 (Privilege not held)" module="9" time="1230931762"

    Any ideas before I dump the software and request refund?
     
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello mprezgot,

    Thank you for your interesting in Acronis True Image

    Contact Acronis support and submit technical request using this link or contact us via Live Chat

    And ask for the link to renew Acronis scheduler, it should solve the issue.

    Best regards,
    --
    Dmitry Nikolaev
     
  3. mprezgot

    mprezgot Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    31
    Location:
    Kingston, ON CANADA
    Acronis technical support was not much of a help in this regard. Here is a snapshot of my extensive research of this problem and a temporary solution:
    ATI Home 2009 has a split functionality/modules: you create and schedule a task in one module, then you execute a previously created task in another module. Unfortunatelly with ATI 2009 task execution doesn't inherit privilleges from main module, what it means is when you start program from within Windows Standard User UAC asks for Administrator's password and runs the program as Administrator. All perfect so far. Then after you setup backup task but in Scheduling you chose "Do not schedule - Run this task manually", the task will not execute because it doesn't inherit elevated Administrator's privilleges but tries to run as current (Standard) user and it is a "no go"! Still more - this task's owner in Unscheduled Tasks is shown as Unknown!
    Workaround to this problem would be:
    1. Run ATI Home 2009 backup while logged as Administrator - not desirable for many reasons, or
    2. Run ATI Home 2009 backup from within Standard User account, provide Administrator's password at the start of the program, setup backup task and then instead of using in Scheduling an option "Do not schedule" - "Run this task manually" change scheduling to "Once only" - "Run this task once only". Schedule it to run in 2 or 3 min. later and at the bottom under "Run with credentials", enter Administrator's User name and Password. This way in few minutes such setup task would execute without problems.
     
Thread Status:
Not open for further replies.