ERA and MySQL 4.0.24

Discussion in 'Other ESET Home Products' started by baxlash, Apr 5, 2009.

Thread Status:
Not open for further replies.
  1. baxlash

    baxlash Registered Member

    Joined:
    Apr 5, 2009
    Posts:
    2
    Dear forum,

    I go crazy with collecting informations about ERA and MySQL server.
    I've some installations at other clients servers with MS-SQL server, with out
    problems.
    Now I tried to install it on my server with a MySQL database.
    The installation process failed with the following error:

    <2009-04-05 15:00:12> Cannot connect to database
    <2009-04-05 15:00:12> Cannot update database flags
    <2009-04-05 15:00:12> Last DB error: Operation: {Execute} Native: {0x4A9} State: {S1000} [MySQL][ODBC 3.51 Driver][mysqld-4.0.24-nt-max]Unknown system variable 'sql_mode' QUERY: Can't alter db session!
    <2009-04-05 15:00:12> InstallAbort: Entered

    I can connect to the database, but something is wrong with the MySQL variable "SQL_MODE"

    Is ERA only working with upper or lower versions of MySQL?

    thanks in advance

    Martin
     
  2. baxlash

    baxlash Registered Member

    Joined:
    Apr 5, 2009
    Posts:
    2
    SUCESS!!!

    OK, after reading the MySQL users manual probably, I got the error fixed.
    You need at least MySQL 4.1 to install ERAS with a MySQL database.
    That's it, hope to help some of you with my experiences.

    The system varible sql_mode is only available in upper versions of MySQL.

    Martin
     
Thread Status:
Not open for further replies.