Encrypted (TrueCrypt) external drive corrupted & formatted

Discussion in 'encryption problems' started by Milan2, Oct 4, 2012.

Thread Status:
Not open for further replies.
  1. Milan2

    Milan2 Registered Member

    Oct 4, 2012
    Hello all

    I would like to ask you for some help as I was searching for a solution for my problem and nothing helped. I will really appreciate any help that can solve my problem.

    I am running Windows 7 Professional.

    I have been using TrueCrypt for a long time, without any problems. Few days ago, when I have mounted my WD 1 TB external HDD connected via USB (with one partition) encrypted as an entire device:

    a) it was suddenly dismounted and disconnected;
    b) after reconnecting the USB cable, it showed up as "RAW" and so I couldn't open it;
    c) then I tried mounting it again, which said "corrupt volume header";
    d) TrueCrypt offered restoration of header which I accpted. However, it still lists my drive as a RAW partition;
    e) after trying to mount it, it shows "incorrect password or not a TC volume" message despite I have repeatedly entered the correct password.

    I can not exclude that in panic at one moment I have accidentially clicked on format button in Windows dialogue noticing that "volume si not formatted" (as I was not used to such a dialogue since I set Windows to not show this dialogue for my external HDD).

    Then I have tried chkdsk (and I know - now - that it was not so good idea as it can write to the disk).

    As I thought that any important data was actually stored on that drive, I decided to format and reencrypt the whole drive again. After few minutes of formatting (only several % of progress) I have remembered that some important data was stored on that external drive so I have stopped formatting drive with TrueCrypt (I know again - it was my fault complicating data rescue).

    Now the content of external HDD looks like a blank drive.

    I am not sure what caused the problem. I have no external backup file with any header. Currently I will do sector-by-sector (raw) backup of my drive before attempting to restore any data from it.

    I suspect the USB interface of my PC that do not hold firmly the USB cable from my external drive. That means that USB cable from the external HDD was not plugged in correctly on the PC. Maybe this issue may be connected with issue posted originally at https://www.wilderssecurity.com/showthread.php?t=327959&page=2 where user Rakoen mentions that "it seems like the half-plugged-in cable caused bad sectors to that drive".

    By the way, the problem arisen just at the moment in which I was not able to log to Windows with my usual profile - Windows showed a message saying local profile cannot be loaded. I am not sure if it is only an accident, but it is certainly an interesting coincidence.
Thread Status:
Not open for further replies.