Enabling 'Multiple Active Result Sets' with SQL Server 2005

Discussion in 'Other ESET Home Products' started by jreiter, Sep 22, 2009.

Thread Status:
Not open for further replies.
  1. jreiter

    jreiter Registered Member

    Joined:
    Sep 22, 2009
    Posts:
    28
    I'm running ESET RAS 3.1.11 and using MS SQL Server 2005 for its database. These are running on a Windows 2008 Server.

    When I start up the RAS service, I get the following error in the RAS logs:

    [2009-09-22 11:21:13.702] V1 [4ab915990000] [00000f50] <INIT_WARNING> Database connection problem. It is strongly recommended to use odbc driver that supports multiple active result sets (MARS). The server will continue to run but the database communication may be slower. See the documentation or contact ESET support for more information.

    I have tried modifying the db connection string to include the attributes needed to enable the Multiple Active Result Sets (MARS) feature, but nothing seems to be working. I continue to get that error. I've tried the following to connection strings to no avail:

    Driver={SQL Server};Server=dugway\esetras:Database=esetradb;MARS_Connection=yes

    Driver={SQL Server};Server=dugway\esetras:Database=esetradb;MarsConn=true

    Driver={SQL Server};Server=dugway\esetras:Database=esetradb;MultipleActiveResultSets=true

    Am I just not using the correct string, or is there something more to it? From what I've been reading, SQL Server 2005 support MARS by default, so you just need to enable it in the connection string. So I'm guessing I either don't have the correct string, or perhaps the SQL Server driver that comes with the RAS doesn't support it?

    Can anyone shed some light on this for me?
    Thanks!
    -joe
     
  2. jreiter

    jreiter Registered Member

    Joined:
    Sep 22, 2009
    Posts:
    28
    I think I may have figured it out. The connection string I was using was referencing the basic SQL Server driver. Note that this connection string is the one that gets autogenerated by the Eset RAS installer. However, the MARS feature requires the SQL 2005 Native Client driver, which is more advanced and provides more functionality. I downloaded and installed that driver (freely available on Microsoft's website), then modified the db connection string used by RAS to the following:

    Driver={SQL Native Client};Server=dugway\esetras:Database=esetradb;MultipleActiveResultSets=true

    That did the trick. The RAS server log now shows it using the new DLL (sqlncli.dll, for the Native Client Driver) rather than the old one (sqlsvr32.dll), and it's no longer complaining about the lack of MARS functionality. So, hopefully this will help with some of the performance issues we've been seeing on the RAS.
     
Thread Status:
Not open for further replies.