EAV4 Ignores cfg.xml settings made with eRAS

Discussion in 'Other ESET Home Products' started by gjdb, May 14, 2009.

Thread Status:
Not open for further replies.
  1. gjdb

    gjdb Registered Member

    Joined:
    Dec 9, 2008
    Posts:
    3
    In our company (1000+ workstations) we use a modified NOD32 AV with the use of a custom cfg.xml, configured with eRAS3.
    When installing NOD32 AV4 all settings from the custom cfg.xml are imported except the Userinterface settings (ShowSplash, ShowBalloon, warning messages etc.), you have to define them manualy after the install.

    With version 3 those settings where applied just fine, but they are ignored at setup with version 4, how come?
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Since these are per-user settings, make sure to mark the option "Supress user settings" and set it to Yes.
     
  3. RCK64

    RCK64 Registered Member

    Joined:
    Jul 21, 2009
    Posts:
    8
    Hello Marcos,

    I got the same problem than gjdb.
    I confirm that the latest antivirus "NOD32 - 4.0.437 - Fra" does not take care of the following xml values when importing conf settings:
    Code:
           <NODE NAME="ShowSplash" VALUE="0" TYPE="DWORD" />
    even with
    Code:
           <NODE NAME="IgnoreUserSettings" VALUE="1" TYPE="DWORD" />
    The ShowSplash value was correctly applied with "3.0.684 - Fra" version.
    Tell us if something can be added to xml file in order to fix this problem in v4.

    Best regards,
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Could you confirm or deny that changing these settings does not take effect even after restarting egui.exe?
     
  5. RCK64

    RCK64 Registered Member

    Joined:
    Jul 21, 2009
    Posts:
    8
    You were right ! This is the main difference between 3.x and 4.x version.
    What I did:
    1. Reset default parameters to all options
    2. Reboot computer
    3. Splash screen appears
    4. Import my settings with xml file
    5. Reboot computer
    6. Splash screen hidden and other options applied :)
     
Thread Status:
Not open for further replies.