EAV3 Delays When Copying Any Files

Discussion in 'ESET NOD32 Antivirus' started by J-Mac, Aug 15, 2008.

Thread Status:
Not open for further replies.
  1. J-Mac

    J-Mac Registered Member

    Joined:
    Jun 21, 2006
    Posts:
    99
    I searched the forums but cannot find anything specific to file copying issues. (I did read the entire 100% CPU thread but that does not appear to be my problem).

    What I see is that whenever I copy any files at all on my XP Pro machine, ekrn.exe cranks up and slows down the works. These are not unscanned files or downloaded junk; they are regular files that have been on my PC - a lot of them created by me in various applications. Doesn't seem to matter if they are MS Office files, PDF files, various database files: they are all being scanned.

    Maybe I am not sensitive enough to my computer's security, but I feel comfortable that these files are not threats to me of any kind. They can sit on the PC and make it through dozens of full scans without a peep from NOD32. But as soon as I try to copy them ekrn.exe starts scanning each and it just slows down my machine.

    This is especially a problem when I use Super Flexible File Synchronizer (SFFS), an application that copies files en masse, to copy entire directories of files. I use SFFS as another redundant backup method, copying directories with important data to external drives, and often via FTP to a server online. When NOD32 scans each and every file within these directories being copied it can increase the length of time for the operation from several minutes to well over an hour - and even more, depending on the file types contained within the directories.

    As I mentioned previously, these files are already in my computer and pass NOD32 scans regularly, so I feel safe with them. But since the copies that are being created in another directory and on another drive are "new" files, NOD32 scrutinizes them vigorously.

    Excluding SFFS doesn't help, of course, for it is the copied files that are being scanned, not the program file. I could exclude the receiving directory, but I would end up excluding far too much for my comfort.

    Is there any way to disable NOD32 from scanning copies of existing, already scanned files?

    Thanks for any help with this.

    Kind regards,

    Jim
     
  2. ASpace

    ASpace Guest

    Try this:

    1) Open Advanced Setup tree -> press the "Default" button (down-right) -> "Revert all settings to default" . Press OK to confirm the changes.

    2) Open Advanced Setup tree -> navigate to "Real time file system protection" -> press "Setup" -> goto "Extensions" and uncheck "Scan all files" . Press OK to confirm the changes.
     
  3. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    If the delay occurs when copying executable files, try disabling Advanced heuristics on file creation/modification. However, it'd be better to simply disable the real-time protection while copying than disabling AH.
     
Thread Status:
Not open for further replies.