Disappears from system tray

Discussion in 'Returnil releases' started by cyberdiva, Feb 6, 2010.

Thread Status:
Not open for further replies.
  1. cyberdiva

    cyberdiva Registered Member

    Joined:
    May 30, 2007
    Posts:
    71
    Today, I had Returnil 2010 (version 3.1.7779.5174-REL) operating. The red icon was in the system tray. I wanted to see the entire program interface, so I double-clicked on that red icon. In the past, that has brought the entire interface to the screen. This time, however, double-clicking made the red icon disappear. I had no idea whether Returnil was still working. I brought up Task Manager, and it listed rvsmon.exe among the processes, so I guess it was still working, but it was useless to me, since I couldn't do any of the things I wanted to do (access the features under Tools). Is there something I could have done to get access to the program's interface without starting a new session? Is this disappearance a known problem? I did a search of the forum's messages before writing, and I found one where someone claimed that his icon wouldn't stay in the system tray, but that wasn't exactly the problem I encountered. It did suggest, though, that perhaps there IS a problem with the icon and the system tray.

    I should note that this was the only time I've had this problem. Normally, when I double-click on the icon in the system tray, the interface comes to the screen. Is there a better/different way of summoning the interface that I should know about?

    Thanks for any help.
     
  2. philby

    philby Registered Member

    Joined:
    Jan 10, 2008
    Posts:
    940
    Hi Cyberdiva

    Start > All Programs > Returnil > RVS 2010

    or

    Win Key + R then type file path to rvsgui.exe

    Couldn't comment on why your icon went missing though...

    (I assume you have checked 'Show Tray Icon' under Preferences > User Interface)

    HTH

    philby
     
  3. Robin A.

    Robin A. Registered Member

    Joined:
    Feb 25, 2006
    Posts:
    2,279
    I also have an icon problem: the Returnil icon turns "blank" (white) in the system tray and also in the desktop, but remains functional.

    If I select the icon and right-click on Properties > Change icon, a message appears saying that the file
    %SystemRoot%\Installer\{8D154382-D968-4C79-A51D-5BE79C2E0100}\ArpIcon.ico
    was not found.

    I can restore the icon from All programs > select RVS 2010 > right click > Send to Desktop, but this "solution" is temporary.

    I have not noticed this problem with any other icon.

    Windows 7 x64, Returnil 2010 Version 3.1.7779.5174-REL
     
  4. cyberdiva

    cyberdiva Registered Member

    Joined:
    May 30, 2007
    Posts:
    71
    Hi, Philby. Thanks very much for your response. I was afraid that starting Returnil at this point via the Start menu would trigger a new version rather than just bringing the old one to the screen. I guess I was incorrect. For a change. :oops:

    And yes, I have checked 'Show Tray Icon'. Indeed, it was in the system tray until I double-clicked on it. That's when it disappeared. Oh well, another of Life's Little Mysteries, I guess. :)
     
  5. philby

    philby Registered Member

    Joined:
    Jan 10, 2008
    Posts:
    940
    Has that brought the icon back for good now?

    If not, I'd turn off System Safe and un/reinstall.

    philby
     
  6. cyberdiva

    cyberdiva Registered Member

    Joined:
    May 30, 2007
    Posts:
    71
    Thanks, Philby, for your followup message. Yes, I'm happy to report that so far, the problem has not recurred. The little red icon is sitting in my system tray and seems to be behaving itself, so I'm hoping that all is well (knock on wood :) )
     
Thread Status:
Not open for further replies.