Database gone blank

Discussion in 'SpywareBlaster & Other Forum' started by Ian Bartlett, Apr 8, 2003.

Thread Status:
Not open for further replies.
  1. Ian Bartlett

    Ian Bartlett Guest

    Help Please - I have v.2.5.3 on Win95. I checked for updates and when I clicked download I got a message saying something to the effect that server returned unusual response and no download. Since then my 333 item checked and protected SpywareBlaster database has disappeared and won't come back. I have a complete blank so I can't uncheck to uninstal. Info on how to get out of this would be appreciated.
     
  2. LowWaterMark

    LowWaterMark Administrator

    Joined:
    Aug 10, 2002
    Posts:
    17,874
    Location:
    New England
    If you delete these three files from the SpywareBlaster folder, they should redownload the next time you run the check for updates...

    ckdatabase.dtb
    sbdatabase.dtb
    sbinfo.dtb

    By default, these files should be in the normal install location:

    C:\Program Files\SpywareBlaster\

    These are the files that are actually released with the periodic updates. Manually deleting them to get them to be redownloaded is a good way to fix any problems with them.
     
  3. Ian Bartlett

    Ian Bartlett Guest

    Thanks, LowWaterMark. Unfortunately none of the three files you mention are in the SpywareBlaster folder. I tried a re-download of updates and that link window shows blank too now. Nothing happens. If I were to uninstall the program as it is with all the data previously checked - although now it's all disappeared and I have a complete blank without even scroll arrows- and then re-install, check and then uncheck and then uninstal again, do you think that would solve it and put my registry back to where it was before I ever installed SpyBlaster?
     
  4. Ian Bartlett

    Ian Bartlett Guest

    Further to above posting by me - a file called "spywareblasterversion" (I think it was called that) was in the SpywareBlaster folder before I posted that last message and that's disappeared now. I noticed it when I looked for the other three files mentioned - I wonder what's going on?
     
  5. LowWaterMark

    LowWaterMark Administrator

    Joined:
    Aug 10, 2002
    Posts:
    17,874
    Location:
    New England
    First of all, uninstalling the program with or without those items checked is not a problem and won't hurt anything. But, yes, if you uninstall it as it is right now, then reinstall it, you should be able to function fully with the program. If at that point you want to uncheck the items and remove the protection, you can do that, too, and yes, removing the protection within the program will basically put you back to where you were before ever installing the program.

    Although, in all this, I see no benefit to removing the protection of the items that you have already let SpywareBlaster protect you from.
     
  6. LowWaterMark

    LowWaterMark Administrator

    Joined:
    Aug 10, 2002
    Posts:
    17,874
    Location:
    New England
    I think that is the control file used by SpywareBlaster to let it know what version you have, although we'd need Javacool to tell us all the things that file is used for.

    I just ran a check for updates myself and also got an error about the update server being unavailable. My copy of "spyblasterversion.txt" blanked out as a result of this failure to update.

    I believe there is a temporary problem with the Javacool update server at this time, which is what caused the problem with losing your database in the first place. When it comes back up, you can probably get it to replace all the database files just as described above. But, as long as the server is down, it can't fix itself.
     

    Attached Files:

  7. Ian Bartlett

    Ian Bartlett Guest

    Thanks for your interest and prompt replies, LowWaterMark. I am beginning to feel a bit better about it already. I think it was fairly obviously all caused by a server problem. I got exactly the same message box that you show the first time I tried the update link but apart from that all seemed OK - the database was there. I just closed the program and tried again later. All was OK then too, and when I clicked the update link I got a response showing the new update files to download (three of them) in the window. It was when I clicked to download and instal that it seemed to go wrong. I got a different message telling me something about an unusual response from the server and no download. So I closed again and next time I opened the program the complete database was gone. With the database window showing blank and those files missing from the SpywareBlaster folder I am just wondering if the protection still remains.
     
  8. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    Yep the protection still remains even if the database somehow becomes corrupted or is deleted (one of the benefits ;)).

    Could you try going into the "Settings" area of SpywareBlaster and checking the option "Use Alternative Download Method" ? I'm going to hope this will fix your update problems. :)

    EDIT: I did notice some severe server slowness earlier, but it seems to have subsided now. I did a test with updating and I had no problems just a minute ago. :)

    Best regards,

    -Javacool
     
  9. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    Spyblasterversion.txt is the file that SpywareBlaster downloads to determine what updates are available, and if they are needed.

    The file is in plain text and is stored locally (once downloaded) so anyone curious as to exactly what SpywareBlaster downloads when it checks for updates can examine it.

    Best regards,

    -Javacool
     
  10. Ian Bartlett

    Ian Bartlett Guest

    Thanks, javacool. You got your message in before the "stop press" I was going to do. The server is up and running again and the updates downloaded fine this time filling my database again with 370 items. Files also back in folder including the "version" one. Thanks for all the expert advice from both your good self and LowWaterMark.
     
  11. aaalsi

    aaalsi Guest

    I'm getting something very similar to Ian. I'll try again tomorrow to see if it's a server problem. I've also noticed that, after the error, SpywareBlaster sometimes stays in the tasklist after I exit and eventually is listed as not responding.
     
  12. javacool

    javacool BrightFort Moderator

    Joined:
    Feb 10, 2002
    Posts:
    3,997
    This is indeed a server problem - the one update server is not responding to HTTP requests :rolleyes:

    I've changed the update information file temporarily - so it should work for now until the main updates server is fixed. :)

    Best regards,

    -Javacool
     
  13. aaalsi

    aaalsi Guest

    yeah, the update worked fine. I'm still noticing that it stays in the task list after quitting whenever I search for updates, though.
     
Thread Status:
Not open for further replies.