credit card problems with shadow vpn / xerobank ?

Discussion in 'privacy technology' started by scrty001, Feb 27, 2009.

Thread Status:
Not open for further replies.
  1. scrty001

    scrty001 Registered Member

    Joined:
    Aug 15, 2008
    Posts:
    82
    damn this is b.s., I've signed up with xerobank and shadow vpn in the past and not had problems like I am now.

    when I tried to sign up I may have been connected to a proxy and I disconnected and reboot and waited a couple days and they still aren't accepting my card, neither of them (they are both the same company as far as I know).

    I've tried visa gift cards with no billing address assigned, i've tried gift cards with billing address assigned, I went and bought a new one yesterday and it's not working. I've signed up with them using a gift card before. Finally, I tried my actual credit card (two different credit cards) with matching billing address and IP and nothing is working.

    i'm starting to get pissed off, I did contact stevetx told me to contact somebody that might be able to help on the xerobank side but, I would rather prefer shadow vpn since the cost is right for me

    damnit, has anybody else had these problems with them? I can't believe this frustration. I had to sign up with ****ing swiss vpn until then and I don't like using their damn service I need some realible quality service and the only people I trust is xerobank/shadow vpn.

    I doubt anybody can recommend me somebody else? I don't know what else to do, I'm going to try and purchase a virtual credit card and see if that will help but, I doubt it. I can't believe this, I never had issues like this with them before and in the past I've also tried to sign up with proxy on mistake but, after i disconnected it would go through ok. this is complete b.s.
     
  2. fuzzylogic

    fuzzylogic Registered Member

    Joined:
    Mar 12, 2008
    Posts:
    149
    this would rather be better in the xerobank support forums than in the privacy section. Mod please close this useless thread.
     
  3. scrty001

    scrty001 Registered Member

    Joined:
    Aug 15, 2008
    Posts:
    82
    Anybody have a link to their forum?

    Is this it: https://xerobank.com/forum/ ?

    If so, I'm getting this error when trying to access that url:


    Fatal error: Function name must be a string in /var/www/localhost/htdocs/forum/Sources/Load.php on line 144
     
  4. SteveTX

    SteveTX Registered Member

    Joined:
    Mar 27, 2007
    Posts:
    1,641
    Location:
    TX
    forum being modified. back in a few hours.
     
Loading...
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.