Creating a rule to allow me to connect to my phone on local network

Discussion in 'ESET Smart Security' started by steampunk, Nov 6, 2010.

Thread Status:
Not open for further replies.
  1. steampunk

    steampunk Registered Member

    Joined:
    Nov 6, 2010
    Posts:
    5
    I have an android phone with SwifTP that I use to connect to from my laptop (it makes the phone sort of an ftp server, or something like that). The computer's local IP is 192.168.0.2, and the phone's is 192.168.0.3. The connection is via port 2121. I have a network location set on Windows 7, and when I disable network filtering in eset, I can access the files fine, so it isn't a problem with any router settings. But when I have the firewall on, it won't access it. I've been messing around in the rules and zones, but I can't figure out how to make a working rule to allow me to connect. Anyone know what I need to do, exactly?

    Using current version of ESET Smart Security 4
     
  2. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    Place your network in Trusted zone?
     
  3. steampunk

    steampunk Registered Member

    Joined:
    Nov 6, 2010
    Posts:
    5
    I just did what I think is placing my network in the trusted zone, and it still isn't allowing the connection. Maybe I did it wrong though? what exactly should have been done?
     
  4. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
  5. steampunk

    steampunk Registered Member

    Joined:
    Nov 6, 2010
    Posts:
    5
    did both of those, still no good. And just to make sure I'm still connecting to the phone, I disabled the firewall and everything working fine. So I don't know whats wrong
     
  6. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
  7. steampunk

    steampunk Registered Member

    Joined:
    Nov 6, 2010
    Posts:
    5
    Still nothing from that or any of the other modes.

    If it makes any difference, the error I keep getting is "A connection could not be established."

    I think what I basically need is a rule that essentially says "always allow all incoming and outgoing connections with 192.168.0.3 through port 2121"
     
    Last edited: Nov 6, 2010
  8. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
  9. steampunk

    steampunk Registered Member

    Joined:
    Nov 6, 2010
    Posts:
    5
    okay that showed me a different way of doing it. I now have a rule that allows all communication through any port to 168.192.0.3.
    It works, but for some reason it only works in regular automatic mode. Automatic (user defined exceptions) still blocks, as does interactive (which is what I like to use). If I keep it on plain Automatic, will it be as secure as when using Interactive?
     
  10. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    To find out which of the rules is blocking communication, enable the "Log all blocked connections" option, reproduce the problem and then check the firewall log for details about the blocking rule. You can subsequently adjust it so that the desired communication is allowed.
     
Thread Status:
Not open for further replies.