Confusion about .NET Framework versions

Discussion in 'other software & services' started by Aaron Here, Sep 26, 2008.

Thread Status:
Not open for further replies.
  1. Aaron Here

    Aaron Here Registered Member

    Joined:
    Jun 4, 2006
    Posts:
    1,205
    Location:
    USA
    An application I'm interested in requires .NET Framework 2.0, so since I have .NET Framework 3.5 installed (but not v2.0) shouldn't this latest version suffice? :doubt:
     
  2. Defcon

    Defcon Registered Member

    Joined:
    Jul 5, 2006
    Posts:
    332
    Yes it should. .NET 3.5 includes 2.0.
     
  3. ambient_88

    ambient_88 Registered Member

    Joined:
    Jun 23, 2008
    Posts:
    854
    Applications written specifically for .NET Framework 2.0 will not work with .NET Framework 3.5, if I remember correctly. I'm not sure about the technical details behind this, but you can bet there are major differences between the two. Hence, the need for you to install v2.0.
     
  4. Jo Ann

    Jo Ann Registered Member

    Joined:
    Jan 6, 2007
    Posts:
    508
    Aaron, .NF 3.5 is backwards compatible with all .NF's back to and including v2.0, although not with v1.0 or 1.1. So you should be ok, but you will know for sure when you try to install that app. ;)
     
  5. silver0066

    silver0066 Registered Member

    Joined:
    Dec 31, 2004
    Posts:
    929
    Jo Ann,

    Does that mean I can uninstall .NF 2.0 Service Pack 1 and .NF 3.0 Service Pack 1 after having already installed .NF 3.5?

    Many thanks,

    Silver
     
  6. Jo Ann

    Jo Ann Registered Member

    Joined:
    Jan 6, 2007
    Posts:
    508
  7. bellgamin

    bellgamin Very Frequent Poster

    Joined:
    Aug 1, 2002
    Posts:
    5,650
    Location:
    Hawaii
    It would be off-topic for me to say that I will not use anything that requires dot net. So I won't say it. :ninja:
     
  8. Jo Ann

    Jo Ann Registered Member

    Joined:
    Jan 6, 2007
    Posts:
    508
    May I ask why?
     
  9. JRViejo

    JRViejo Global Moderator

    Joined:
    Jul 9, 2008
    Posts:
    20,981
    Location:
    U.S.A.
    Confusion is the word when it comes to .NET Framework versions and as I understand it (please do correct me if I'm wrong), you need to have all versions installed in order to use older software programs that were built using legacy .NET versions.

    This article: How to set an IIS Application or AppPool to use ASP.NET 3.5 rather than 2.0, although dealing with server software, gives an explanation of the different .NET versions (look under Marketing), that I'm still muddling through in trying to understand it all. You'll also see the different versions installed in this person's PC.

    Nevertheless, just in case someone wants to rebuild their .NET Framework versions, below you'll find all the MS links, including a .NET Cleanup tool, should Add/Remove won't clean up old remnants. Windows Update should also show the same versions, if installed incrementally from scratch:

    .NET Framework Version 1.1
    .NET Framework 1.1 Service Pack 1
    .NET Framework Version 2.0
    .NET Framework 2.0 Service Pack 1
    .NET Framework 3.0
    .NET Framework 3.0 Service Pack 1
    .NET Framework 3.5
    .NET Framework 3.5 Service Pack 1
    Removal tool to fix .NET Framework install failures
     
  10. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,787
    Just install your app and see what happens. If it needs something, it'll either tell you, or won't work.

    I have all of them installed on Vista all the way back to 1.0.
     
  11. Arup

    Arup Guest

    Love it or hate it, .Net allows devs to make one app for x32 or x64 due to its JIT feature, this makes it convenient for those looking for x64 apps and backewards compatible for x32 users as well.
     
Loading...
Thread Status:
Not open for further replies.