Compatibility problem with ZyWALL IPSec VPN Client

Discussion in 'ESET Smart Security' started by KevinHejn, Dec 23, 2009.

Thread Status:
Not open for further replies.
  1. KevinHejn

    KevinHejn Registered Member

    Joined:
    Dec 23, 2009
    Posts:
    3
    I have compatibility issues with SmartSecurity and ZyWALL IPSec VPN Client. When trying to install the VPN client while SmartSecurity is installed I get a BSOD with the IRQ_LESS_OR_EQUAL error. This seems directly related to the “TheGreenBow NDIS Filter Driver” installed by the VPN client. I found a workaround for this by allowing installers full rights over Windows\System32\drivers\NDIS.sys before installing the VPN client. If I try to install SmartSecurity after the VPN client has been installed I also get a BSOD. After a reboot, SmartSecurity reports that protection is not running and that the firewall installation is corrupted.

    When using the first approach, there is another problem. Each time Windows is booted, I get an error that ESET SmartSecurity Miniport #[some numer] could not be installed correctly. However I have only observed this when using a 64 bit Windows installation. A more significant problem is that the VPN client is unable to connect properly when SmartSecurity is installed. I have opened the required ports and allowed the program internet connection when asked. However, the client only connects 1 of 10 times and only completes the first phase of the tunnel setup. It doesn’t help to disable the firewall completely, but as soon as I uninstall SmartSecurity, there is no problem connecting.

    I am using the latest version (2.4.204.61.03) of the VPN client as well as a fully updated SmartSecurity.

    Thank you in advance for any hints.
     
  2. WayneP

    WayneP Support Specialist

    Joined:
    Apr 9, 2009
    Posts:
    339
    Hello,

    When you say "fully updated SmartSecurity" do you mean the latest build? If you are not using 4.0.474 then I would recommend downloading it from here.
     
  3. KevinHejn

    KevinHejn Registered Member

    Joined:
    Dec 23, 2009
    Posts:
    3
    It is the latest build I am using - I downloaded it today to be sure.
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
  5. KevinHejn

    KevinHejn Registered Member

    Joined:
    Dec 23, 2009
    Posts:
    3
    Sorry for the late reply. I tried installing the 4.2 beta on a fresh Windows 7 installation followed by the VPN client. The behaviour is exactly the same.

    I forgot to mention an important observation in the initial post. The problem seems to be Windows 7 related. Before migrating to Win 7, I ran XP where the VPN client and SmartSecurity worked flawlessly together.
     
Thread Status:
Not open for further replies.