comodo, firefox and incoming connection

Discussion in 'other firewalls' started by innerpeace, Apr 11, 2007.

Thread Status:
Not open for further replies.
  1. innerpeace

    innerpeace Registered Member

    Joined:
    Jan 15, 2007
    Posts:
    2,095
    Location:
    Mountaineer Country
    Comodo, shows connection with Google when using Fx.

    There is probably a simple explanation as to why there is communication between my computer and google. I included a pic. The connection only happens every now and then when online. Could it be the phishing filter? It is set to check suspected forgery by a downloaded list rather than asking google. I'm using comodo firewall 2.4, and firefox 2.0.0.3. When I use tcpview when not online (using firefox) the only thing that is normally listening is Avast's webshield.

    OT: Should I take google and googlesyndication out of NoScripts whitelist? Thanks in advance.
     

    Attached Files:

    Last edited: Apr 11, 2007
  2. KDNeese

    KDNeese Registered Member

    Joined:
    Dec 16, 2005
    Posts:
    236
    I don't believe it is directly connected with the phishing filter per se, but it does have something to do with Firefox's security features. When it first goes online, Firefox checks for the latest updates (bad websites, etc). Apparently Google keeps a database of all the bad boys which Firefox accesses. They claim no personal info is transferred in the process, but I'm always skeptical anytime any of my apps connects without me first starting the process. But, I guess in reality it's not a big deal, and actually something that helps protect us while online.
     
  3. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hello innerpeace,

    The title of your thread gave me serious cause for concern, as if Comodo was allowing inbound connections(with default network rules_ without allow rule) then this would be serious compromise.

    BUT
    Looking at the log entry, this is outbound via AV proxy, so maybe a need to change the title of your thread?
     
  4. innerpeace

    innerpeace Registered Member

    Joined:
    Jan 15, 2007
    Posts:
    2,095
    Location:
    Mountaineer Country
    @ Stem. I named the thread from what I was seeing. The connection only happens when I'm using firefox. I was seeing more incoming KB's than outgoing. All the times I have checked with TCPView, the Avast webshield/proxy/html filter is the only process listening. I have disabled many services with online guides including referring to a thread about your personal settings.

    I didn't intend to misinform anybody or discredit Comodo, after all I am using it. You can probably tell I don't that much about firewalls, that's why I was asking my question. I don't think the connection is malicious, but I have put off asking about it for at least a month. I'm not sure that I have the power to change or edit posts and titles. I guess a good generic one would be "Comodo, shows connection with Google when using Fx." If a mod can change the title that would be great. I can't find or have the authority to do so.

    Now that I look at the source ip (my computer) and the destination ip (google) would point to it being an outbound connection. I'm just stumped as the bytes coming in are clearly more than the bytes out. Unless that means bytes in would be going to google. inc. I'm sure someone can educate me on this.

    So, why is my computer talking with google when I'm online using firefox? Is KDNeeses' answer accurate? Thanks, innerpeace

    edited to add comment to mod.
     
    Last edited: Apr 11, 2007
  5. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hello innerpeace,

    I will install FF2 to look into this. I know from the version of FF I have installed of its continued attempts at connections to fxfeeds, which as no option to disable.

    edit

    There is an option in FF2: Tools / option / security / "Tell me if the site I`m visiting is a suspected forgery": /check using a downloaded list of suspected sites.

    It does, at first check, appear to be an update of this list (I still have to check my logs fully)
     
    Last edited: Apr 11, 2007
  6. innerpeace

    innerpeace Registered Member

    Joined:
    Jan 15, 2007
    Posts:
    2,095
    Location:
    Mountaineer Country
    Thanks Stem :)
    That is the option I have set rather than the check by asking google one.
     
  7. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    I have currently disabled this option, and checking on any comms made by FF2.
     
  8. innerpeace

    innerpeace Registered Member

    Joined:
    Jan 15, 2007
    Posts:
    2,095
    Location:
    Mountaineer Country
    Thanks for checking into this :)
     
  9. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Since I have disabled the option "Tell me if the site I`m visiting is a suspected forgery" there have been no attempts for outbound to google by FF2.

    So it does look like the outbound connection is just an update to the list of sites. (when this option is enabled)
     
  10. innerpeace

    innerpeace Registered Member

    Joined:
    Jan 15, 2007
    Posts:
    2,095
    Location:
    Mountaineer Country
    Thank you! I learned something new today. I'm surprised that this hasn't been mentioned before. That connection was bugging me because I knew I hadn't visited Google's site. Thanks again Stem.
     
  11. risl

    risl Registered Member

    Joined:
    Dec 8, 2006
    Posts:
    581
    Now that it's about comodo and incoming connections.. why does it block utorrent incoming connections even if I have added it to trusted applications and otherwise(popups)granted full access for it? I removed comodo because of this, but I might try again if there is some solution for this. :D
     
  12. Delgado

    Delgado Registered Member

    Joined:
    Apr 28, 2004
    Posts:
    131
    You have to make a rule in Network Connections to allow your Utorrent to have incoming connections. Add a rule to allow TCP/UDP connections. If you click on add its fairly straight forward to do-self explanatory.

    :D
     
  13. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    As mentioned by "Delgado", there is a need to add rules to the "Network Control".

    Basic info with example can be found here
     
Loading...
Thread Status:
Not open for further replies.