Command Line Scanner in Safe Mode

Discussion in 'ESET NOD32 Antivirus' started by Motown, Aug 9, 2008.

Thread Status:
Not open for further replies.
  1. Motown

    Motown Registered Member

    Joined:
    Aug 9, 2008
    Posts:
    3
    I am trying to run the command line scanner while in safe mode and keep getting "scanner initialization failed".

    I have read the parameters page at training.eset.com/kb. I have tried using the /auto switch, no joy.

    I also tried the parameters below pulled right from Blackspear's tutuorial, no joy.
    C:\ /adv-heur /adware /arch /auto /boots /files /mail /no-log-all /pattern /quarantine /rtp /sfx /subdir /unsafe /unwanted

    I am running version 3.0.667.0 on WinXP x64. Any help would be appreciated.
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    I think the problem is you're trying to run ecls from other than the installation folder. Try using --base-dir= parameter follwed by the path to the EAV installation folder.
     
  3. Motown

    Motown Registered Member

    Joined:
    Aug 9, 2008
    Posts:
    3
    Ok. I tried that but no luck. :(
    I made sure that I am pathed to the install directory (c:\program files\eset\eset nod32 antivirus) when I execute the command and I added the base-dir switch.

    ecls.exe C:\ /adv-heur /adware /arch /auto /boots /files /mail /no-log-all /pattern /quarantine /rtp /sfx /subdir /unsafe /unwanted /base-dir=c:\program files\eset\eset nod32 antivirus
     
  4. Motown

    Motown Registered Member

    Joined:
    Aug 9, 2008
    Posts:
    3
    Any ideas why the command line scanner doesn't work? I thought this would be a simple question.
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    I've copied/pasted your parameters on my computer (without the base-dir parameter which is not necessary when ecls is run from the installation folder with the engine and other modules) and a scan was run fine.

    Try this:
    - go to start - run and enter "command"
    - enter "cd C:\PROGRA~1\ESET\ESETNO~1"
    - enter "ecls.exe C:\ /adv-heur /adware /arch /auto /boots /files /mail /no-log-all /pattern /quarantine /rtp /sfx /subdir /unsafe /unwanted" (without speech marks

    Does this work for you? If so, then you either did not previously run ecls from the installation folder or the problem was with spaces in the path; try putting speech marks at the beginning and end of the path like:
    /base-dir="c:\program files\eset\eset nod32 antivirus"
     
Thread Status:
Not open for further replies.