"CheckHSRE" BetaFeature causes IE crashed...under Win2000

Discussion in 'LnS English Forum' started by kuroro, Feb 12, 2006.

Thread Status:
Not open for further replies.
  1. kuroro

    kuroro Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    8
    My OS is Win2000 pro with sp4 & rollup1 , and my IE frequently goes crashed when i set "CheckHSRE"=1...
    And it prompts that "wininet.dll" is wrong and IE must be restarted.
    The version of my "wininet.dll" is 6.00.2800.1525

    Details:
    AppName:iexplorer.exe AppVer:6.0.2800.1106 ModName:wininet.dll
    ModVer:6.00.2800.1525 Offest:00094f80

    I tryed to test all of the BetaFeatures one by one , and found the error I discribed before only happens when i set "CheckHSRE"=1 .

    And I remembered someone has reported that "f04_ok" only appears when the "wininet.dll" is in early version....
    Could anybody tell me why it happens ??
    Thanks a lot.
     
    Last edited: Feb 12, 2006
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    In the driver logs, do you have "FO4_OK" or "FO4_KOx" ?

    6.00.2800.1525 is normally the correct version for Win2000 SP4.

    Frederic
     
  3. kuroro

    kuroro Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    8
    Thanks for help

    in the driver logs, it shows "F04_ok"~
    when the "CheckHSRE" BetaFeature is actived
    and lns can detect and pass the pcaudit2 test
     
  4. kuroro

    kuroro Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    8
    BTW~
    Could you tell me each "F0x_ok" exactly mean??
    thanks for help~
     
  5. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    These are internal codes to monitor the activation of these beta features.

    Do you have a DrWatson log or the details of the crash when you encounter the problem ?
    Are you doing something special with Look 'n' Stop just before the problem occurs ? something like exiting/restarting Look 'n' Stop, disabling/enabling Watch Thread injection in the adv options...

    I don' remember someone else reporting the same kind of error.

    Frederic
     
  6. kuroro

    kuroro Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    8
    The answer is no.... I didn't do any setting before the crash happen, I just open my pc as usual, get into the Internet, use some IM software....At this time, IE often goes crashed, only when I use some advanced function just like MicroSoft Update or Upload files to some Netstorage or bbs
    I'm so sorry I forgot to mention this condition before....

    Now I set "CheckHSRE" =0(leave the other BetaFeatures on), so far, there is nothing wrong...


     
    Last edited: Feb 13, 2006
  7. kuroro

    kuroro Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    8
    So far, I know "f04_ok" is mean that "CheckHSRE" is ON
    "f05_ok" is mean "CheckVAEUDTF" is ON
    "f03_ok" is mean "CheckDNSQ" is ON

    Could you tell me the others mean? Thank you.
     
  8. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    FO_Ok is for "Watch DNS Calls" but this one should no longer be enabled when "CheckDNSQ" is ON
    FO2_Ok & FO2_2_Ok are for "Watch Thread injection"

    all xxx_KO! code are error codes (the feature was configured to be ON but could not be enabled).

    Frederic
     
  9. kuroro

    kuroro Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    8
    Thanks for answer.
    But the problems caused by "CheckHSRE" BetaFeature still exist....
     
Thread Status:
Not open for further replies.