cFosSpeed

Discussion in 'LnS English Forum' started by test4, Jun 22, 2006.

Thread Status:
Not open for further replies.
  1. test4

    test4 Registered Member

    Joined:
    Jun 21, 2006
    Posts:
    23
    How do you make cFosSpeed work normally with LnS?
    It regularly complains about ping packets that it can't send and\or receive (I'm not sure) and that it may not be able to function properly because of this.
    There is a constant stream of "ICMP type 11" and "ICMP type 11 code 0" messages in the log. The related address seems to be my ISP. When I allow these packets just for cFosSpeed it doesn't change a thing. So that's not the solution. Otherwise there doesn't seem to be anythingthe occures all the time.

    LnS doesn't ask anything (apart from originally asking\allowing internet access for cFosSpeed of course) and I don't know what to look for in the log.
    Any ideas what to do about this?

    (Btw, what do these IMCP messages refer to? It is a never ending stream that LnS blocks).
     
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    for my config, i think allowing both ICMP type 11 code 0 and type 8 code 0 is needed.

    im currently testing it tho.

    btw ICMP packets are pings.
     
  3. test4

    test4 Registered Member

    Joined:
    Jun 21, 2006
    Posts:
    23
    I have already allowed these packets for cFosSpeed only, but that doesn't change anything.
    Do you allow them for a specific or any application?
    Is allowing them for any application safe?
     
  4. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    i allowed them for any application. i probably should set them for cfosspeed only.

    i will test it some more later.

    edit: i posted at the cfos software forum, ill post back teh response (if any).
     
    Last edited: Jun 24, 2006
  5. papillonn

    papillonn Registered Member

    Joined:
    Oct 19, 2005
    Posts:
    117
    Location:
    TR
    i could say that LnS is the best firewall that i have tried with cfosspeed.

    i suggest you to follow these steps on cfos help page.
    http://www.cfos.de/speed/documentation/noping_e.htm
    It helped me much i hope it would help you too.

    little informations:

    for standart ruleset of LnS you dont have to add icmp 8 and icmp 0 rules because they are already in there

    look at
    ping other req-ping other resp (at the bottom of the ruleset)

    but for icmp 11 you should add icmp 11 rule like other rules.

    dont forget to disable xp built in firewall also check your router.it may block your packets...

    If you checked all and if you think you did everything there must be a problem with your ISP,because some of the ISPs dont let sent or recieve this kind of frequently packets.

    regards;
     
  6. test4

    test4 Registered Member

    Joined:
    Jun 21, 2006
    Posts:
    23
    Thank you both for taking the time to reply. :thumb:

    Combining your replies leads to this conclusion (I think :) ):
    The ICMP packets type 11 that LnS blocks are the send\needed by cFosSpeed in order to function normally. It is save to allow them for any application, because it is only outgoing traffic.

    Limiting them to cFosSpeed service, which is in the LnS programs list doesn't work (as I noticed). On the linked site that papillonn gave it is explained that SPD.exe sends these packets, but LnS never asked permision for that program (component) to access the internet. And apparently it doesn't recognize that SPD.exe is part of the cFosSpeed program.

    Anyway, I did the small "tracert command test" that is mentioned on that site and at first the result was "Request timed out". After allowing ICMP for any application in LnS, it worked fine. Finally! I've been trying to get this right for a long time.
    Thank you both again for helping.
     
  7. test4

    test4 Registered Member

    Joined:
    Jun 21, 2006
    Posts:
    23
    In order to make cfosspeed work with LnS I have to allow ICMP packets type 11 for any apllication.
    Is this safe? I mean, LnS blocks them by default, probably not without a good reason.
     
  8. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    yes its safe.
     
  9. BuzzStone

    BuzzStone Registered Member

    Joined:
    Nov 8, 2006
    Posts:
    163
    I just came across this thread today as I was experiencing the same problems. I did as was suggested and it worked. However, as a result of allowing all (ICMP : All ICMP types (nukes, ...), I now fail ShieldsUp because I have become pingable. Have I not used the correct method or is there another way to do this. I am unsure of type 11 because I can't see it anywhere.
     
  10. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    when u create a rule for ICMP, u have to specify the type and code. there should be space for "type" so just type in 11.
     
  11. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Hi all :)

    ICMP type 11 code 0 incomming only is used for Traceroute...

    (Used also by some application such as eMule with KAD...)

    :)
     
Thread Status:
Not open for further replies.