Cellular Broadband Modem - i need to keep re-installing drivers to get it to work

Discussion in 'hardware' started by jfd15, Jun 27, 2008.

Thread Status:
Not open for further replies.
  1. jfd15

    jfd15 Registered Member

    Joined:
    Oct 12, 2007
    Posts:
    234
    Location:
    Sacramento, CA
    Hi,
    i have USB Cellular Broadband modem thats apparently on the fritz and Windows often wont recognize it, says it has malfunctioned....if i uninstall the setup program and then re-install- about every five times i do that, Windows will recognize it and install the 7 different drivers to the device.....its a USB flash drive type of device....

    im guessing its readyto die on me but im just wondering if i can get another week out of it and is there a simpler way to reset this thing so i dont have
    to uninstall and reinstall and reboot 5 times to get it to work for one session....
    once it starts it often works for 2-3 without a problem.....if i have to send it back ill be without internet for about 5 days so i want to try anything i can to get by for another week....

    someone must have an idea on this, please help....
     
  2. markymoo

    markymoo Registered Member

    Joined:
    Sep 25, 2007
    Posts:
    1,212
    Location:
    England
    Can you not try it on another pc to ensure it's not your Windows at fault? I know of certain USB devices namely certain cheap USB scanners fail to be detected when you install the software again even if you uninstalled it before. Plugging the USB into another USB port than the one previously used can odd time cause problems or conflicts. Have you tried plugging the modem into another USB port as the port maybe faulty? Is the modem USB 2.0 compatible and have you got USB2 Enhanced Controller listed in Device Manager? Have you used another USB device in that same USB port? Is the motherboard VIA chipset? , if so install the motherboard cd drivers.
     
  3. jfd15

    jfd15 Registered Member

    Joined:
    Oct 12, 2007
    Posts:
    234
    Location:
    Sacramento, CA

    thanks Markymoo,

    its the only computer i have right now...ive tried all 4 USB ports,
    (all are 2.0)...yes, i have USB2 enhanced controller listed in Device Mgr...
    i have checked my Flash Drive in all 4 of those ports and they seem to
    work fine for that...its Intel 945 chipset....i get the modem working
    for an hour or so and then accidentally brush ever so slightly against the
    modem and i get knocked offline and have to re-install software...i think
    ill be returning the modem tomorrow, so my problem will hopefully
    be solved....
     
  4. markymoo

    markymoo Registered Member

    Joined:
    Sep 25, 2007
    Posts:
    1,212
    Location:
    England
    yes it sounds like an intermittent fault. we will concede its a faulty modem.
     
Loading...
Thread Status:
Not open for further replies.