Can't print with 4.2.35.0

Discussion in 'ESET Smart Security' started by devolic, Mar 23, 2010.

Thread Status:
Not open for further replies.
  1. devolic

    devolic Registered Member

    Joined:
    Jun 20, 2008
    Posts:
    40
    Location:
    Detroit, MI. (USA)
    I just installed 4.2.35.0 and now I can't print unless I disable the firewalls on both computers. I didn't have this problem with the previous version. I added the IP address of the computers to the trusted zone. What gives?
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    What message is logged in the firewall log if you enable logging of all blocked communication in the IDS setup and reproduce the problem?
    I've come across cases when a network printer produced a port scan attack which was subsequently blocked by ESS.
     
  3. devolic

    devolic Registered Member

    Joined:
    Jun 20, 2008
    Posts:
    40
    Location:
    Detroit, MI. (USA)
    The only thing that it says with the IP of the printer hooked to that computer is "Block incoming NETBIOS requests".
     
  4. Jenee

    Jenee Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    185
    I don't have any network issues with any of the 4.2 versions since I added a new rule which fully allows netbios in the trusted zone (local network).
    Under Advanced Options go to Personal Firewall and select to add a new rule under the heading "Rules with no application assigned".
    The direction should be both and Action should be allow. Go to the remote tab and click on zone and then add trusted zone.
    When you have ok'd the new rule it should look like this:
    Rule Name: Local Netbios
    General: Direction: Both Action: Allow Protocol: TCP UDP Profile: For Every
    Remote Side: Zone: Trusted Zone
    For every port
    Local side: For all

    I am assuming you have the firewall set to Interactive Mode.

    I had lots of issues with the local network until I added this rule. You should also tick all the boxes under IDS and Advanced Options (although Allowing incoming streams from the internet via the IGMP protocol is not necessary and I don't have this ticked).
     
  5. michelle911

    michelle911 Registered Member

    Joined:
    Aug 3, 2005
    Posts:
    4
    I had the same problem on my home network - I added the subnet to the trusted zone as it did not automatically put it in there and then added the above rule to allow tcp & udp on all ports for the trusted zone and it works now.
    But I have one desktop on my work domain that is not joined to the domain that will not connect to domain public shares or printers. I have added both of the above rules and can connect to other clients but not server shares.
     
  6. nonoise

    nonoise Registered Member

    Joined:
    Jun 6, 2008
    Posts:
    322
  7. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Does adding the IP address of the remote computer to the list of addresses excluded from active protection (IDS) in the zone setup make a difference?
     
  8. devolic

    devolic Registered Member

    Joined:
    Jun 20, 2008
    Posts:
    40
    Location:
    Detroit, MI. (USA)
    Thank-you,
    That worked Doug
     
Thread Status:
Not open for further replies.