Can't get update to work

Discussion in 'Ghost Security Suite (GSS)' started by finiteman, Apr 15, 2005.

Thread Status:
Not open for further replies.
  1. finiteman

    finiteman Registered Member

    Jan 4, 2003
    I am using RegDefend V1.2, but I have never been able to get the "Check for New Version of Regdefend" to work, even before V1.2. I get the error message "There was an error checking for a new version ..." etc. I have given Regdefend complete access and server rights in Zonealarm and in any other program that could be blocking. I can access the Ghost Security and RegDefend websites without any problems otherwise. Any suggestions would be appreciated.
    I'm running Windows XP SP2
    ZA pro
    Norton AV
    Giant Antispyware

  2. gottadoit

    gottadoit Security Expert

    Jul 12, 2004
    The update check works for me without any issues, and has in previous versions as well. I'm also using XP SP2

    I just tried it here and I got a firewall alert saying that RD was wanting to :
    • perform a DNS lookup on
    • make an outgoing connection to on port 80 (this is the ghost security webserver
    • then it fetches the content of /rdversion.txt from the webserver
    In this case the DNS was allowed by a global rule that I have (so I wasn't prompted for it). But the outbound request to the webserver gave me an alert box asking whether to allow the access. I allowed the alert to sit there while I started typing this and then I got the same error back from RD
    There was an error checking for a new version.
    Please make sure you are connected to the internet.
    RegDefend also needs write access to its directory to succeed.
    In my case RD had write access to its install directory and RD decided by itself to time out the connection due to no response (because my firewall had not yet allowed or denied the outbound access).

    In your case I am wondering if it is happening because RD either cannot perform a DNS lookup or make a direct connection. RD shouldn't need server privileges and it works for me without them.

    I also use ZA Pro 5.x here and from time to time have issues where it doesn't prompt me to allow programs access (even though it should according to the configuration). When this starts happening I either reboot or unplug the network/modem cable then stop and then restart ZAPro and then plug the network/modem cable back in again. I generally find that this behaviour only happens when the machine has been running for a fair while

    If you are experiencing the same sort of issue that I am then it is possible that ZAP is stopping the network access without showing or logging anything

    If that suggestion doesn't work then Jason might have some more ideas....
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.