Can't connect to internet

Discussion in 'ESET NOD32 Antivirus' started by Kuhpow, Mar 11, 2009.

Thread Status:
Not open for further replies.
  1. Kuhpow

    Kuhpow Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    6
    I've just installed NOD32 and it now won't let IE, Firefox, AIM, MSN etc access the internet. My computer is connect to my router and says it has a wireless connection. I am on a Toshiba Equium and am running Vista (32 bit) which is not yet SP1. I've gone to troubleshoot in msn and it's telling me that it could be due to improper proxy or firewall settings. Windows firewall isn't running right now so it probably has smething to do with NOD32. Any help would be apprieciated. Thanks

    Edit: It also won't let me update
     
  2. philby

    philby Registered Member

    Joined:
    Jan 10, 2008
    Posts:
    940
    Are you running any firewall at all?
    If you are, you'll need to allow ekrn.exe two way access.
    philby
     
  3. Kuhpow

    Kuhpow Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    6
    I'm 90% sure im not, f I am thought how to I allow two way access?
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Does disabling HTTP checking make a difference? Had v3 been working fine for you?
     
  5. Kuhpow

    Kuhpow Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    6
    Yes it does, thanks alot for your help
     
  6. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    This is certainly not a solution, web protection is an essential part that should remain enabled all the time. I'll ask our developers for further instructions and let you know then. If you can, please create 2 logs from Wireshark with the http communication on port 80 captured, one with web protection (WP) enabled and the other with WP disabled.
     
  7. Kuhpow

    Kuhpow Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    6
    Oh ok. Could you tell me how to do this please? This is my first time using NOD32. Thanks. Also, it still will not let me update.
     
  8. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Maybe this will help you:
    http://portforward.com/networking/wireshark.htm

    Basicly all you need to do is select the right network adapter that you use for Internet connection and set the capture filter to "HTTP TCP port 80" or simply "HTTP".
     
  9. Kuhpow

    Kuhpow Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    6
    Ok I've done this, do I need to keep this running constantly?
    Also, is there anything else I can do to get NOD32 to update?
     
  10. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    No. First, close as much network-aware applications as possible so that the log created is not flood with irrelevant data. Then start capturing the http communication with Wireshark, try to open an arbitrary website in your browser and, when you receive an error, stop creating the log. Finally send the log along with a log from SysInspector to support[at]eset.com and this thread's url enclosed.
     
  11. Kuhpow

    Kuhpow Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    6
    Is this with HTTP checking turned off or on? BEcause I didn't get any errors when it was turned off
     
Thread Status:
Not open for further replies.