Cannot get application to connect to internet

Discussion in 'other firewalls' started by aagfr, Dec 30, 2005.

Thread Status:
Not open for further replies.
  1. aagfr

    aagfr Registered Member

    Joined:
    Apr 15, 2004
    Posts:
    56
    My problem is that an application I just installed absolutely will not connect to the internet no matter what I've tried. When it is supposed to connect, I get a warning that the secure connection to the server has failed (and that the problem is probably the firewall). I use Look n Stop, but that seems to be all OK: the application is listed and permitted, and the log indicates that a connection has been made to the correct ip address, port 443. All connections that are unrelated to this software are fine.

    I completely disabled LnS to see if that was it, but still no connection. I tried using only Windows Firewall, again no connection. I also reverted all changes that had been made by Secure-it and Harden-it -- still nothing. I did a clean reinstall of the software, no help. :doubt:

    The techs at the software maker had no effective suggestions - they think it's the firewall - but it won't connect even with no firewall. The software is not some exotic adventure, it's just an internet-postage program called Dazzle that needs access to the internet to set up and use.

    While this might turn out to be a problem unrelated to firewalls, I hope someone in this forum might have an idea(s) that could help here. I trust a mod will redirect this if I've posted in the wrong forum.

    (I run winxpsp2 and use a cable connection.)

    Thanks and Happy New Year to all.
     
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    have u tried Dazzle on a clean reinstall of winxp, without installing teh firewall or anything else? maybe the server is just overloaded or unavailable.
     
  3. aagfr

    aagfr Registered Member

    Joined:
    Apr 15, 2004
    Posts:
    56
    WSFuser: Good point re the possibility of the server simply being unavailable, but I asked the tech about that and he said it was ok. Also, their site let's me check the "server status" and it says it's ok, too.

    As to a clean reinstall of winxp w/o a firewall, I don't have my system backed up by imaging software; so a windows reinstall is not an option I'm willing to exercise. I don't have an extra hard drive or other ability to try the software in another environment.

    Thank you. aagfr
     
  4. CrazyM

    CrazyM Firewall Expert

    Joined:
    Feb 9, 2002
    Posts:
    2,428
    Location:
    BC, Canada
    Anything else filtering/handling network traffic that could impact this connection?

    Regards,

    CrazyM
     
  5. aagfr

    aagfr Registered Member

    Joined:
    Apr 15, 2004
    Posts:
    56
    If you mean a router or external proxy, no. I do use Proxomitron to filter Opera, but that's it. I even shut that down in my efforts to get this straight.
    Also, I run Process Guard, but I installed Dazzle with its protection disabled.

    It's seems quite the mystery to me. I've never had a problem like this with any software/connection. I even looked at my HOSTS file to see if there was something there.

    Thank you CrazyM.

    aagfr
     
  6. CrazyM

    CrazyM Firewall Expert

    Joined:
    Feb 9, 2002
    Posts:
    2,428
    Location:
    BC, Canada
    Anything in the Process Guard logs that may indicate a permissions issue?

    Regards,

    CrazyM
     
  7. aagfr

    aagfr Registered Member

    Joined:
    Apr 15, 2004
    Posts:
    56
    I'm afraid not. The PG Alert dialog only shows that Dazzle is allowed to start, and no alerts re anything else. There must have been a request for permission to install Global Hooks which I granted at some point.

    The logfile shows nothing unusual, just that Dazzle was allowed to start. Curious though, the logfile shows that the Global Mouse Hook request was denied, but no entry that permission was then granted. Perhaps that is not a logged event?

    CrazyM: I really appreciate the efforts you and WSFuser are making to be of help.

    aagfr.
     
  8. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    two other solutions, the second being quite drastic:

    1.) uninstall the program and redownload/install latest version
    2.) run lspfix and/or winsock fix (make sure to read all documentation and any FAQ first)
     
  9. CrazyM

    CrazyM Firewall Expert

    Joined:
    Feb 9, 2002
    Posts:
    2,428
    Location:
    BC, Canada
    Does the program only use HTTPS?
    You could try something like Ethereal to monitor the connection and see what is happening.

    Regards,

    CrazyM
     
  10. aagfr

    aagfr Registered Member

    Joined:
    Apr 15, 2004
    Posts:
    56

    #1: Already tried that, but it didn't help.
    #2: I'll look into and try this suggestion and report back.

    Yes, only port 443. I'll check that out too.

    aagfr
     
  11. aagfr

    aagfr Registered Member

    Joined:
    Apr 15, 2004
    Posts:
    56
    Gentlemen,
    Thank you for all your help. The issue is resolved.

    First, I tried WSFuser's winsock fix suggestion: which quickly changed LooknStop into 'Stop n Stare'. After a number of reboots it magically got squared away. It seems from other posts in the LnS forum that LnS does respond poorly to that fix at first. Alas, Dazzle still didn't work.

    Then I installed Ethereal per CrazyM: I couldn't understand it; way too advanced for me - especially at 1:30am.

    Okay, now comes my confession of stupidity.:oops: I had failed to uninstall all of Outpost when I installed LnS. I think I did that to save time. :D Everything seemed to be working fine for some days ... I then forgot all about the Outpost remnants. Well, I just did a thorough cleanup of Outpost and voila! All is well. I'm positive that if I had even suggested that Outpost may be in the mix both of you would have immediately steered me right. Now I know.

    Dazzle connects just fine now. I appreciate your help and patience.

    All the best in the New Year.

    aagfr
     
Loading...
Thread Status:
Not open for further replies.