Cannot connect to UltraVNC Server with ESS firewall active

Discussion in 'ESET Smart Security' started by Teazle, Nov 8, 2009.

Thread Status:
Not open for further replies.
  1. Teazle

    Teazle Registered Member

    Joined:
    Apr 7, 2007
    Posts:
    42
    Hi there, have tried for a while now to connect from Computer A to Computer B with UltraVNC, to no avail.

    Computer A has ESS, with a rule created for UltraVNC Viewer to allow all communication (Inbound/Outbound) - yet it still fails unless I disable the firewall, then it's smooth sailing.

    Can anyone enlighten me as to WHY the rule for UltraVNC Viewer fails to allow connection?

    edit: updated to add: I'm using it in Interactive mode, under WinXP SP3, latest ESS which was supposed to fix some sort of issue with Interactive Mode, still nothing.

    I do however have a theory:

    I am currently using a switch to divide my internet connection to Computer A and Computer B.
    With ESS active, Computer A cannot reach Computer B's IP and vice versa, using any means at all (FTP, UltraVNC, Ping).
    It can however reach Computer B using \\<computer name> in Start -> Run... , leading me to believe I am not finding some setting that ESS enforces.
    I have already tried the "Allow file sharing" option, to no luck.

    Could anyone help me with this?




    Regards

    Teazle
     
    Last edited: Nov 8, 2009
  2. robis

    robis Registered Member

    Joined:
    Mar 21, 2009
    Posts:
    149
    I am using similar software but I have firewall in Interactive mode (try Interactive mode)
     
  3. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Perhaps switching the firewall to learning mode to create the necessary rules automatically would be the easiest solution.
     
  4. Teazle

    Teazle Registered Member

    Joined:
    Apr 7, 2007
    Posts:
    42
    to robis: I have the firewall in Interactive mode, I said so. Did you mean something else?

    to Marcos: No dice, still not able to connect, after a series of attempts, including after reboot and with/without VNCViewer rule created. Any other suggestions?..
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    I'd suggest enabling the "Log all blocked connections" option in the IDS section of the firewall setup and connecting via VNC. In the firewall log you'll see information about the rule that blocked the connection so that you can subseqently adjust or disable the rule.
     
  6. Teazle

    Teazle Registered Member

    Joined:
    Apr 7, 2007
    Posts:
    42
    Heh, why didn't I think of that...

    Anyway: that gave me the answer, apparently svchost.exe is blocked which is used to connect using VNC.

    After fixing that (making sure svchost.exe can correctly connect) I can finally connect, after IDS stopped temporarily blocking connection.

    Thank you.
     
Thread Status:
Not open for further replies.