Cannot assign drive letter - ATI8E logic is incorrect

Discussion in 'Acronis True Image Product Line' started by wdormann, Dec 1, 2005.

Thread Status:
Not open for further replies.
  1. wdormann

    wdormann Registered Member

    Joined:
    Jun 27, 2004
    Posts:
    480
    I've sent an email to support, but I figured I'd check with the forum to see if anybody else has experienced this problem and has a solution.

    My main Windows PC is running TrueImage 8.0 Enterprise build 1201.

    I have an image of a Linux system that has a ReiserFS filesystem. If I mount this image in Windows, it assigns a drive letter, but then the dialog indicates that it is still busy. After about 60 seconds, I get an error message saying that it could not assign a drive letter, and the image is unmounted.

    TrueImage is making an incorrect assumption that if Windows cannot understand the filesystem, then something failed with mounting the image. Even if Windows cannot read the filesystem, some third-party applications can, such as Yareg: http://yareg.akucom.de/

    In the past, I have been able to have ATI (not Enterprise version) mount a reiserfs image successfully in Windows. The drive letter is there, but Windows explorer cannot browse to it (obviously). However, using Yareg, I was able to explore the filesystem and restore files from it as needed.

    However, with ATI Enterprise I only have about 60 seconds to do the above. This is the time between when ATI mounts the image and assigns a drive letter and when it gives the error saying that it cannot assign a drive letter.

    The mounting logic needs to change back to the way that it was before. Even if windows doesn't understand the filesystem, ATI must *NOT* unmount the image automatically with an error. I am not sure when this regression took place.
     
  2. mustang

    mustang Developer

    Joined:
    Apr 12, 2005
    Posts:
    905
    Hello wdormann,

    You may be able to manually assign a drive letter to the mounted image during the 60 seconds TI is trying to assign the letter.

    Method 1:

    Open a command prompt and enter the following:

    diskpart
    list vol (Look for the number of the mounted image with no drive letter next to it.)
    select vol N (Where N equals number from above list.)
    assign letter=X (Where X equals letter you asked TI to assign.)

    Method 2:

    Go to Disk Management.
    Right click the mounted image and select Change Drive Letters and Paths
    Choose the Add button
    Select a drive letter and click OK


    Now just wait for TI to time out. You will still get the same error message, but your image should still be mounted. When you are done, you can use either diskpart or Disk Management to "remove" the drive letter. However, you will probably have to reboot to unmount the image. Both utilities will tell you the volume is write protected if you try to delete it. TI will, of course, have no luck with unpluging the image.

    Please let me know if this works for you.

    mustang
     
  3. wdormann

    wdormann Registered Member

    Joined:
    Jun 27, 2004
    Posts:
    480
    The thing is, ATI DOES assign a drive letter right at the beginning. So for 60 seconds I have a drive letter, and I can access the files via Yareg. It's that ATI is incorrectly reporting that it cannot assign a drive letter when the filesystem is not recognized. That's where the faulty logic is.

    It's the automatic unmounting when reporting that error that is the big problem.
     
  4. mustang

    mustang Developer

    Joined:
    Apr 12, 2005
    Posts:
    905
    Hello Wdormann,

    That is interesting. I wonder what would happen if you used diskpart to do the following:

    diskpart
    list vol (Look for the number of the mounted image with a drive letter next to it.)
    select vol N (Where N equals number from above list.)
    remove
    assign letter=X (Where X equals a different letter than you asked TI to assign.)

    It's a long shot, but it might just be crazy enough to work.

    mustang
     
  5. wdormann

    wdormann Registered Member

    Joined:
    Jun 27, 2004
    Posts:
    480
    Ok, I was not correct in my previous post. I thought that it did assign a drive letter for a short period of time and then it disappeared. But now that I'm at my computer, I see that this is not the case.

    From the time that I select to mount an image to when I get an error saying that it could not assign a drive letter, no new drive appears according to diskpart. However, if I have Computer Management -> Disk Management open, I can see that the drive there does exist during that time. I cannot assign a drive letter via Disk Management, though. Once the ATI error message comes up, the drive disappears from Disk Management.

    Unfortunately several things have changed with my system since I've performed the "Yareg" trick successfully. I've switched to the enterprise version of ATI, but I have also switched from Win2k to WinXP. So without a bit of testing, it's going to be hard to say who's at fault.
     
  6. tachyon42

    tachyon42 Registered Member

    Joined:
    Dec 26, 2004
    Posts:
    455
    Don't you love this kind of problem?
    Good luck!
     
  7. mustang

    mustang Developer

    Joined:
    Apr 12, 2005
    Posts:
    905
    Hello wdormann,

    I am using TI8 personal. I tried to explore a tib image of a Linux Ext2 partition running under WinXP Pro. I got the same exact results as you did in your last post. I coud hear the volume mount, but it did not show up under diskpart. It did show up in Disk Management, but the change drive letters and paths option was grayed out.

    Next, I tried to explore the same image running under Win2K. True Image was able to successfully assign a drive letter.

    These results seem to indicate it was the change from Win2K to WinXP, rather than the change from TI8 personal to TI8 corporate, that caused the problem.

    Sorry I do not have better news.

    mustang
     
  8. wdormann

    wdormann Registered Member

    Joined:
    Jun 27, 2004
    Posts:
    480
    Well I guess that settles it then. Thanks for posting your results! It was unlikely that I would have had the time or motivation to track down the cause. :)
     
Thread Status:
Not open for further replies.