cannot assign a drive letter to a partition from the image archive

Discussion in 'Acronis True Image Product Line' started by MarcelNetherlands, Oct 4, 2005.

Thread Status:
Not open for further replies.
  1. MarcelNetherlands

    MarcelNetherlands Registered Member

    Joined:
    Oct 4, 2005
    Posts:
    2
    Hello,

    We have a Iomega REV and it's works fine with Acronis True Image Server 8 on a Windows 2000 SBS server.

    Now I'm installing our new server with Windows 2003 SBS server, I checked the registry for Partmgr on the both entry's.

    But I still get the message:
    "cannot assign a drive letter to a partition from the image archive"

    The server has two SCSI disks Raid 1, but that cannot be the problem, I have a C and a D partition on de SCSI disk.

    I've checked the image and it is fine, but when I try to explore it with Acronis the message keeps coming.

    I tried it on our 2000 server and it works fine.

    What can I do about it, or do we need another version or patch of Acronis?

    I tried also explore a image made from the C drive stored on the D drive. But I got the same message, so it must be something with the combination windows 2003 SBS and Acronis True Image Server 8 (version 774)

    Please help.
     
    Last edited: Oct 4, 2005
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello MarcelNetherlands,

    Thank you for choosing Acronis Server Disk Backup Software.

    First of all, please download and install the latest build (937) of Acronis True Image 8.0 Server for Windows which is available at: http://www.acronis.com/enterprise/support/updates/

    To get access to updates you should create an account at:
    http://www.acronis.com/enterprise/my/
    then log in and use your serial number to register your software.

    If the problem still persists with the latest build (937) of Acronis True Image 8.0 Server for Windows then please create Acronis Report and Windows System Information as it is described in Acronis Help Post.

    Please also collect the following information:

    - Make a screen shot of the latest screen of the Explore Image wizard which contains the operation scenario;

    - Run "regedit" command and write down the data lines of the below registry keys:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318} -> UpperFilters

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F} -> UpperFilters

    Please also do the following:

    - Download SetupApiLog.zip, unpack it and run in order to add the information to the Windows registry;

    - Delete \Windows\setupapi.log and reboot the computer;

    - Reproduce the mounting problem and provide setupapi.log;

    - Let us know whether there is a delay after hitting Proceed and getting the error message.

    Send all the collected files and information to support@acronis.com along with the step-by-step description of the actions taken before the problem appears and the link to this thread. We will investigate the problem and try to provide you with the solution.

    Thank you.
    --
    Alexey Popov
     
  3. jeremyotten

    jeremyotten Registered Member

    Joined:
    Feb 9, 2005
    Posts:
    684
    also try this.

    select and deselect the drives. Select 1 drive and make dure you guve it a letter that aint in use.

    try again it should work.
     
  4. mustang

    mustang Developer

    Joined:
    Apr 12, 2005
    Posts:
    905
    Hello MarcelNetherlands,

    Here is something you can try. It works for me in my modified BartPE plugin for asigning a drive letter to a mounted image where True Image gives the same error message you are getting.

    I see a box that True Image is trying to assign a drive letter. There is a delay of about one minute before the error message appears. In my case, the image has been mounted succesfully but True Image can not assign a drive letter.

    Method 1:

    During that minute delay, open a command prompt and enter the following lines:

    diskpart
    list vol (look for a volume with no drive letter and the volume label of your image)
    select vol X (Where X=number from above list of you image volume)
    assign letter=N (Where N=letter you asked True Image to assign to you image)

    You will need to do all this before the error message appears. After the error message, the image is no longer mounted. If you get a message that a drive letter has been successfully asigned, you should be all set. If Windows Explorer can not see the newly assined drive letter, you may have to use a third party file manement utility. In BartPE the A43 File Management utility works.

    If True Image can not unplug the image, open a command prompt and enter the following:

    diskpart
    list vol
    select vol X
    remove


    In BartPE this removes the drive letter but does not unmount the volume. Do another "list vol" to see if the image is still there without a drive letter. Upon the next reboot, the volume is unmounted and the image is still intact.

    Please keep in mind I do not have access to a Windows 2003 Server to test this. Test carefully when you can afford a reboot.

    Method 2:

    You can also try this during the one minute delay:

    1. Open Windows Disk Management.

    2. Look for the mounted image with no drive letter.

    3. Right click the volume and select Change Drive Letter and Paths.......

    4. Click the Add button.

    5. Enter the drive letter you asked True Image to assign to your image.

    6. Click OK

    See if you get a drive letter.

    You can remove the drive letter with the same procedure but using the Remove button instead of the Add button. Under BartPE the drive letter is removed. If I then try to unmount the volume by using Delete Partition, I am told that it is write protected. A reboot is the only way to unmount it.


    Good luck,
    mustang
     
Thread Status:
Not open for further replies.