Cache cleared but search keyword always there.

Discussion in 'privacy problems' started by Ocky, Mar 13, 2013.

Thread Status:
Not open for further replies.
  1. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    This I can't remember happening to me before. A few days ago I entered a search keyword on a site and was surprised to see it still shown despite always religiously logging off properly and clearing browsing history incl. cache.
    Only that particular search keyword is shown over and over again. I can enter another one but on reset/deleting it, the other one is back again. Occurs in all browsers.
    Why ? I hope all is OK.
    cache cleared but.png
     
  2. Taliscicero

    Taliscicero Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    1,439
    Form Auto-Fill, or Bookmarks. It's one or the other.
     
  3. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Nope, I am aware of those settings. Sure, one would think it is due to that but then all similar forums would also be affected. Clearing the cache (eg. in Google Chrome with 'Clear Auto-fill form data' ticked) has no effect.
     
  4. TheWindBringeth

    TheWindBringeth Registered Member

    Joined:
    Feb 29, 2012
    Posts:
    2,088
    The fact that it happens in all browsers seems important (assuming you didn't use all of those browsers to search for that particular term at that particular site). Assuming the above, several possibilities come to mind:

    1) You are entering the site/page via a URL that passes that search term in somehow. Check that.
    2) You searched for that term while you were logged in and it was associated with your account. You only see that term show up when you are logged in. If there is a search term reset/delete function at the website, perhaps there is a bug in that function. Verify it happens when you aren't logged in. I would suggest clearing cookies, LSOs, and storage. At least those associated with the site.
    3) The search term has been associated with your IP Address and the latter hasn't changed. Make it change or try via proxy.
    4) The behavior is not specific to you and the site is serving the form that way to others. Due to a coding mistake, bug, hack, whatever. Have someone else check the form and/or try via proxy.

    Edit: If the site is http, you could try bypassing browser issues by using telnet.
     
    Last edited: Mar 13, 2013
  5. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Thanks TheWindBringeth, useful pointers there, but it's all explained now.
    I must have clicked by mistake 'save search preferences' so your possible cause number 2 was the relevant one.
    I will need to get my IQ checked sometime soon. :D
     
Thread Status:
Not open for further replies.