Bug Filtrage UDP

Discussion in 'LnS French Forum' started by Debugger, Aug 20, 2004.

Thread Status:
Not open for further replies.
  1. Debugger

    Debugger Registered Member

    Joined:
    Aug 20, 2004
    Posts:
    5
    Tout d'abord un grand bravo à toute l'équipe de look'n'stop !! ;)
    Continuez comme ça !!


    j'utilise un programme qui nécessite l'accès au port 8289 UDP du serveur (Gunbound).
    en quelques clics je crée cette règle :


    UDP : Autoriser Port 8289

    Direction : paquets entrants et sortants
    Ethernet type : IP
    Protocole : UDP frag offset : tous frag flags : tous
    ethernet adresses : toutes toutes
    Source ... :
    IP adress: toutes tcp/udp port : tous
    Destination ...:
    IP adress: toutes tcp/udp port : egale 8289 0


    la règle autorise le passage des paquets.
    la règle est au plus haut niveau donc avant UDP : Bloque le reste.

    le problème est que lns ignore cette règle et utilise la règle UDP : bloque le reste


    le journal indique :

    nom de la règle : UDP : bloque le reste
    direction : pc >> internet
    type : Ip
    protocole : udp
    adresse source : la mienne
    adresse destination : le serveur
    port source : 1467
    port destination : 8289



    a bientot pour de nouveaux bugs ;)
     
  2. Debugger

    Debugger Registered Member

    Joined:
    Aug 20, 2004
    Posts:
    5
    Voila des petites captures d'écran pour mieux cerner le problème :D

    en voici une :
     

    Attached Files:

    • lns1.jpg
      lns1.jpg
      File size:
      36.2 KB
      Views:
      119
  3. Debugger

    Debugger Registered Member

    Joined:
    Aug 20, 2004
    Posts:
    5
    mon os : Windows xp sp2
    le port du serveur à changer mais cela n'explique pas le bug

    et voila l'autre :
     

    Attached Files:

    • lns2.jpg
      lns2.jpg
      File size:
      27.8 KB
      Views:
      118
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    Etes vous sûr du port utilisé par le serveur ? ou en fait avez-vous récupéré ce n° de port en lisant le journal de Look 'n' Stop ?

    Pour des petits paquets, il y a en effet un bug qui provoque un affichage incorrect des N° de port (dans le cas de petits paquets, ce qui est votre cas), et donc en se basant sur le journal, dans ce genre de cas, on crée des règles avec un numéro de port incorrect, le filtrage lui faisant bien son boulot.

    Contactez-nous par email à lnssupport@soft4ever.com si vous voulez tester une mise à jour du driver qui corrige ce problème.

    Frédéric
     
  5. Debugger

    Debugger Registered Member

    Joined:
    Aug 20, 2004
    Posts:
    5
    Bonjour Frederic,

    Effectivement, je me suis basé sur le journal afin de définir cette règle et apparemment c'est bien ce petit bug qui pose problème.
    J’accepte volontiers de tester ce nouveau driver, le mail est déjà envoyé.

    a bientot

    :cool: :cool: :cool:
     
Thread Status:
Not open for further replies.