[BUG] File Restore unable to restore the C:\Windows\Assembly folder.

Discussion in 'Acronis True Image Product Line' started by Vorenus, Aug 31, 2008.

Thread Status:
Not open for further replies.
  1. Vorenus

    Vorenus Registered Member

    Mar 25, 2008

    When I do a file restore of the folder C:\Windows\Assembly (which contains .Net assemblies), TrueImageService.exe crashes with the following message.

    Application popup: TrueImageService.exe - Application Error : The instruction at "0x00790d25" referenced memory at "0x00000004". The memory could not be "read".

    I also tried with the BartPE plugin and TrueImage.exe crashes as well.
    I tried this on different archives including some freshly made and it always happen. I also validated the archives and they aren't corrupt. Recovery from the official Linux-based boot CD works fine. Disk-based recovery works fine, but for various reasons, I need this to work from the CD and file-based recovery.

    I'm using Acronis TrueImage Echo Enterprise Server 9.5.8115 but it also happens in the previous version.

    I'm not sure, but it seems the C:\Windows\Assembly folder is a particular folder containing a desktop.ini customization and apparently having particular ACL permissions. Maybe that's the problem ?

    Step to reproduce.

    Under Windows, open TrueImage
    Select Restore
    Select an archive containing a Windows partition
    Use File Recovery
    Untick the C: root to deselect all the files and tick only C:\Windows\Assembly (note that it doesn't work either if you leave everything ticked... but it is just quicker this way to reproduce the bug)
    Wait for it to crash.

    Thank you to please fix this bug as it is really annoying.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.