Broken Task Scheduler and Paragon Exact-Image

Discussion in 'backup, imaging & disk mgmt' started by The Usual Suspect, Dec 15, 2005.

Thread Status:
Not open for further replies.
  1. Task Sched is broken... won't start
    starting the service from Services.mmc, I get
    Task Scheduler failed to start
    error 87: Incorrect parameter
    I noticed this after I tried to try out making a schedule for a backup in Paragon Exact Image, which is quite similar to TI, except that it has....
    > Apparently more features
    > Absence of compression <TI 8 rocks there ;)>
    > NO startups were installed ! (I'm guessing it uses the task scheduler ?)

    It says at the end of the Scheduling wizard about a failure to create tasks.


    it may be that this installer was broken, but my guess is task scheduler was broke before that. Any help on how to fix this ?
  2. Global Force

    Global Force Guest

    Howdy Usual Suspect,

    Which OS are you on? If XP, 1 or 2?

  3. XP Pro Sp1a

    I hated SP2... couldn't play some games :)

    Also, this computer ("inherited" about 4 months back...) carries a local install of V-COM SystemSuite.... I think I'll send that to the junk bin... it's the only entry listed in Scheduled tasks... and it's NEVER actually run ! It could be the problem.
  4. STOP the freakin Presses !!!

    it's "TuneUP Utilities" in there in the scheduled tasks...

    I didn't even know it was installed! (it was in H:\, and start menu entires deleted x-( )

    Apparently, my uncle is fond of purchasing licenses he'll never use (and I think he installed things AFTER giving me this box... talk about invasion of privacy :p )
  5. Global Force

    Global Force Guest

    Saw your last reply before posting. Just in case ....

    Try stopping, then setting the HID Service (Human Interface Device Access) to manual startup.
    You may have to modify Task Scheduler to run without passwords.

    Maybe some joy.

  6. HID was disabled... set it to manual, tried to run it.... "Error 2: System Cannot Find the file specified"

    Tried to run the TuneUp 1-click maintenance, "task scheduler is not running"... I think I'll learn some new curse words, and rturn in 8 hours :) .

    Also, it could be registry thing? I noticed jv16 power tools installed here too without any startup folder... I'm scared :(
  7. Global Force

    Global Force Guest

    Did you disable "Limit local account use of blank passwords to console logon only"
    and try to start the Task Scheduler service?

  8. Nope... didn't work
    This needs a reinstall, don't it?

    The Usual Suspect
  9. Global Force

    Global Force Guest

    Usual Suspect,

    The only other thing I can think of aside from your thought which, under the circumstances wouldn't be such a bad idea, is check Task Scheduler's logon .... it should be set *Local System account* with desktop interaction allowed. If that's a go set it as Automatic startup and re-boot.

    For s's and g's I'd also dbl check that the following registry key's value for limitblankpassworduse is set to (0) ....


  10. Checked all that... no use... everything is set to these settings.

    Nice little trick some people have pulled on me.

    well what do you think woulda caused this?

    File corruption by a bad mannered app?
    registry mucking by one of the 30 trillion registry cleaning tools everyone with admin privileges insists on using?

    Is reg cleaning worth it anyway? I think i's just hoo-haa... doesn't serve much purpose... at least no visible performance jump for me, whilst every cleaner "finds" some new things the previous one missed, and surprise surprise... they number in the 500's everytime.
  11. Global Force

    Global Force Guest

    Couple of thing's US,

    Create a new administrative account and try it. You'll have to logoff and back on at least once, stop and start TS with those new credential's, you may also need to re-boot. The other thing you can check is in your Window's folder, find the logfile (SchedLgU.txt), then look if there were ever any successful run's. Re-installing IE might also work, but I'd prefer to know which version first.

    Please tell me if these files are present w/version number's .... Mstask.dll, Mstinit.exe, Schedsvc.dll

    You have the disc?

  12. Global Force

    Global Force Guest

    "Is reg cleaning worth it anyway?"

    Some say yes, some say no. I like RegSeeker for quickly finding what I'm after,
    but any and all cleaning done on my part is both manual and selective.

  13. Global Force

    Global Force Guest

    Just remembered *if* you have the disc, run sfc /scannow. ;)

  14. Scheduler's log is apparently rewritten for today.. donno why... no successful runs

    mstask.dll 5.1.2600.1564
    Mstinit.exe 5.1.2600.1564
    chedsvc.dll 5.1.2600.1564

    The thing is... task scheduler will NOT start.. no matter what account... I suppose I'll create a new admin account and try.

    disc? Windows installer? yes. I have. why?
  15. what? from recovery console?

    tried it from DOS, and damn it I had left out the SP1a CD when I came back in the cupboard at the *other* place ... arrgghh...

    this may take a while... close to 15-16 hours I think. *sigh*
  16. Global Force

    Global Force Guest

    "what? from recovery console?" .... Not so fast :D though an excellent utility to have onboard.

    You may not need the cd if there's an I386 folder copied somewhere on the hard-drive. Inside there would be compressed files denoted by an underline extension (ex: SCHEDSVC.DL_) .... somehow that's probably not the case.

    If there's no rush for the cd, have whomever mail it.

  17. nope it din work ...

    windows reinstall, here I come (once I find the 20 hours I need... AFTER i decide on a backup solution :D )
  18. Global Force

    Global Force Guest


    Considering you've come to own this pre-installed pc not knowing it's current state, I would try method II before re-installing the whole enchilada (in case of error though there shouldn't be, edit the registry). The M$ page here cover's some potential unknown's which may not be so obvious with TS's inability to start ....
    • There is a registry problem that cannot be solved by using other tools such as System Restore.

    • You must apply default (file and registry) permissions to your Windows XP installation.

    • You must register Component Object Model (COM) components and Windows File Protection (WFP) files.

    • You must use the Windows Setup program to enumerate Plug and Play devices again, including the hardware abstraction layer (HAL).

    If you'd prefer re-installing IE fresh, look here. The choice's are up to you. :)

  19. UA ?? wha? how? I mean....

    also, it'd appear that you think that this is an IE based problem. Care to explain WHY you think so?

    and finally... should I install sp2? I don't want to... it's broken many a software before, and nearly everyone I know has thrown it back out a week after they installed. There doesn't seem to be any advantage... just more nuisances (unless I get IE7 in somehow... looking forward to that)
  20. Global Force

    Global Force Guest


    After carefully reviewing our thread my thought's have shifted back to a permission's issue (barring any unusual deletion's from the registry or damaged system files). I would offer you take a detailed read of Passwords and user accounts under Security and administration, then Scheduling tasks under Performance and maintenance.

    Still finding hidden program's four month's after ownership strongly suggest's you direct your focus toward's a backup solution. If deciding an In Place Re-install is worth your time, you should be able to do it without losing your data.

    As for sp2 .... depend's on priorities. You know what you want! ;)

  21. Well they're very well hidden... no way to actually see what's going on unless I fire up the control panel (add/remove) or go hunting in all of the 7 partitions for installed programs, cross referencing the registry.
    So rather than enjoy a thrill ride like this (even though I have an urge to do something stupid this festive season...), I think I'll just do a simple re-install... I can always ask for all the licenses/installers, that much I've been assuerd. Which means better control ... If I find out I hate V-VOM Sys Suite and like TuneUP... I can uninstall VCOM anytime with the firm knowledge that the answer to Life, The Universe and Everything Else, is sorted out, and that I can uninstall without fear of loss, reinstall when I need to, and generally, be an Admin in the truest sense!
  22. iceni60

    iceni60 ( ^o^)

    Jun 29, 2004
    Usual Suspect, what do you think of Paragon Exact-Image? i've got a copy i might use to image my HDD to a new HDD. do you know if it will image the whole HDD with ntfs and Linux filesystems? i have 5 partitions altogether.
  23. umm...
    I never got to use it properly... BBBBBBUT
    * It's nearly a clone of Acronis' TrueImage 9 [the secure zone is called some 'capsule' here, so nearly very similar features etc.]
    * Feels lighter
    * Hence, My guess is that scheduled tasks NEED the task scheduler, and I couldn't do scheduled tasks. [And I didn't try a restore because of this only. Can't use a backup program which has a component disabled on my system]
    * Increasing compression to high/medium etc. has NO EFFECT. The archives will be of the same size.

    CNet, I believe has a good review of the product, which enumerates WHY you should consider it over Acronis' TI, and except for the useless compression, it gives a solid punching to TI 9 [interestingly, TI 8 had better compression :) ]

    NTFS = YES
    Linux = Most probably YEAH!! ... you really should check out the manual/website :D

    By all means, do give it a shot! If I didn't give it a shot, i'd never have found TI 8 :D
  24. iceni60

    iceni60 ( ^o^)

    Jun 29, 2004
    thanks, Usual Suspect. i think it should be able to cope with Linux filesystems as all their other stuff seems to. i don't think i'll use the scheduled tasks as i really just want to transfer from one HDD to another. i'll have alook for the review at CNet too.

    i've used afew other programs by Paragon and they've all worked perfectly, all HDD programs too, so i hope this one works as well. thanks for the help.
  25. Post reinstall thoughts

    1. I think I had a critical service disabled, one that is NOT report in dependencies, but is actually needed.

    2. I don't know what autopatcher from Neowin did, but I like it!

    3. I swear I'll never use a reg cleaner for it';s dfault 'auto clean' things... just a post install, keyword search and delete please.

    4. Waiter, pass the check please! Or... just bring me another glass filled with this wunder-coke... amazing what a bottle of donkey meat-juice won't fix! :)
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.