Bootmgr and update issue.

Discussion in 'other software & services' started by falconsito, Mar 19, 2011.

Thread Status:
Not open for further replies.
  1. falconsito

    falconsito Registered Member

    Mar 19, 2011
    Hello everybody.i am new on the forums and really newbie on windows 7 and advanced geek stuffs, but first of all,
    i want to salute you and excuse my self for my bad enlish.
    after the poor introduction i will try to accurately explain my issue.
    i was working on w7 ultimate x64 (i had xp 32 before, but due a hardware upgrade i wanted to try an x64 os) when an automatic upgrade from windows poped up
    (i was pretty sure i disabled the option before, but.. whatever). The thing is the upgrade never completed ( 2 hours freezed on the final step) and i had to reboot
    (i know, my mistake).
    from here, i tryed to boot but i did not sucess. the first issue apeared when i turned on the pc, and the boot recovery windows poped up, to check if there was
    errors on the HDD. but wont never ever complete (6 or 7 hours running)
    i started to search on the web for a solution and i found a bunch of similar cases (a failed update and a failed boot recovery) but no clear solutions.
    never the less, the moest of the cases pointed at the same spot: "the bootmgr file" and i started to try a few steps posted on forums.

    first of all, i put the w7 dvd instalation and accesed to the console prompt.
    i followed these steps to delete and reinstall the bootmgr, or at least, that was what the post told me :p

    that was that article:

    x:\sources\cd.. <enter>


    you wirte

    cd windows/system32/boot/



    you write:

    bootsect /nt60 c: /force <enter>

    bootcode was succesfully updated on all targeted volumes
    the boot is installed on c: ( that is what we looked for)

    from x:\windows\system32\boot\

    we tip c: <enter>


    now we write

    expand bootmgr inicio <enter>
    attrib bootmgr -s -r -h <enter>
    del bootmgr <enter>

    ren temp bootmgr <enter>
    attrib bootmgr -a +s +r +h

    Bootrec /fixmbr

    and then

    bootrec /fixboot

    but, suddenly i realized that i dont have installed my W7 on C:, it is on D: !!! (what an a**hole). so, i repeat the same procedure, that did before, but this time
    on D:
    once i did it, i tiped exit and tryed to run the boot recovery once again (as the post told me) and i had some diferent results than before:
    a dos window poped up with a repeatedly message, instead of a never ending loading bar of the recovery boot:

    the repeatedly message was:

    " BFsvc: Bfspcopyfile<D:\windows\boot\pcat\bootmgr, \\?\GLOBALROOT\Device\harddisk
    volume5\bootmgr> failed! <attempt 41 of 60> last error =0x5 "

    (60 times with the 60 attempts). after this, windows told me that the boot recovery system will not automatically repair itself, and i need to check if a
    new incompatible hardware was installed at this time (no new hardware installed)
    i reboot the pc and as i expected, the "missing bootmgr file. ctrl+alt+del to reboot" message poped up.
    did it, and accesed once again to the command prompt from w7 dvd to repeat the noted steps on the post, but this time got a diferent issue while i was doing the steps:

    when i was doing the "expand bootmgr inicio t(note "inicio" is start in spanish. I have a spanish w7 dvd, and the post with the tutorial is in spanish, intended to
    solve this issue in a w7 ultimate spanish instalation, so, i suposse its fine ) i got this msg on the system: "No se puede abrir el acrhivo de entrada: Bootmgr"
    in english, would be something like: "the Bootmgr input/ini file cannot be opened)"
    Actually, i am not sure if i got this message the fist time i followed these steps, or not. but now, everytime i got this message.

    i tryed to run the boot recovery once again, and i got the message that i got before, but with 2 new lines:

    BFsvc: Bfspcopyfile<D:\windows\boot\pcat\bootmgr, \\?\GLOBALROOT\Device\harddisk
    volume5\bootmgr> failed! <attempt 41 of 60> last error =0x5

    bfsvc: No process found ussing D:\windows\boot\pcat\bootmgr file
    bfsvc: No process found ussing \\?\GLOBALROOT\Device\harddisk
    volume5\bootmgr file"

    actually, what i get from this, is basically the system is not letting me to recover the bootmgr file or copy the file from the w7 dvd to the D: system location.
    but i dont know why or what else to do.
    I know here are a lot of experimented and wise ppl who, maybe will enlight my way to solve this issue. may be a solution is formating D: and reinstalling windows,
    but this is the last thing i want to try, be cause i am an audio producer and composser and i work with 2 terabytes of softs and audio stuffs, which in the best case,
    the 60 % will need to be reinstalled (due the keys and licenses, etc) and it is a pain in the ass. really. There is any posible solution that doesnt involve to formating
    and reinstalling windows from 0 ?

    There are some things i want to add, that my help:

    *i dont have any system recovery points or recovery images.
    * i never formated D when i upgraded to win 7. i Didnt erased the Win Xp instalation from the system (i have one on the same partition of the w7 and one in a diferent
    partition) may be the dvd is atemtping to solve the bootmgr in the win xp files. i dont know, just guessing :p
    *when i installed w7 the first time, i changed the letters of the drives. I mean, there was a time no long time ago when my actual D: drive
    (with the w7 installation on it) was the C: drive.
    *i have 3 hdds: A PRIMARY IDE MASTER with no OS on it.
    A Sata where i have the W7 and a Win Xp instalations.
    A sata with an old xp installation (corrupted, but never erased it because of some useful regs)

    well, i am about of exploding or jumping from a roof... seriously, i have some unfinished works to deliver in the begining of the week and i will not succes if i
    need to blow up my D: and reinstall.

    Please, any sugestion, any little help, will be super usefull guys. i really need to solve this issue, or at least, dieing trying for :p

    Again, i really apreciate your time uncoding my horrible english (i am for argentina) and for trying to help me.

  2. Cudni

    Cudni Global Moderator

    May 24, 2009
    can you connect that drive in slave configuration and access files on whatever partition? If you can then make a backup because from what you are saying it sounds like there are hardware issues/problems with that drive
  3. falconsito

    falconsito Registered Member

    Mar 19, 2011
    Hi guys. Thank you for you kind answers.

    I solved the issue. Actually, its kind of weird for my level of knolewdge about these stuff.
    the error was that somehow, the windows 7 dvd wasn't recognizing the W7 installation properly, or at least, not the boot sector, and was troubling and messing things up with the other SATA, with a previous xp installation-.
    i just unplugged the other sata hdd and the recovery boot fix tool worked sweetly, and i have my W7 back without problems.

    So, if you have the same issue and you have another sata with or without a windows installation, try to unplug the thing.

    Thank you for the responses that helped me to figure this out-.

Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.