BHO's not installing, at least not whilst ESS is installed..?

Discussion in 'ESET Smart Security' started by Trapster, Feb 24, 2008.

Thread Status:
Not open for further replies.
  1. Trapster

    Trapster Registered Member

    Joined:
    Dec 4, 2007
    Posts:
    13
    Location:
    Liverpool UK
    I recently got a message saying an update was available for Adobe 8 reader so hit the update button and waited. First the old version of Adobe reader was automatically uninstalled and then it proceeded to install the new version however the new 8.1.2 version would not install; it stopped at about 92% into the installation with error 1406. the message said i might not have administrator permission (which i do), detailed a BHO registry key it couldnt write and I had to abort the installation to avoid further problems; this annoyingly has left me without a PDF reader for almost a whole month now!

    I did some research on error 1406 but never got around to fixing it. I then decided to install Spybot S&D as I'd had problems running scans with ESS (3.0.621); it never seemed able to complete a scan without crashing my system. I had figured Spybot might find a nasty lurking somewhere; but I got another error message trying to install Spybot - Code 6. The error message detailed the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\Explorer\Browser Helper Objects key it was trying but failing to write; it was in exactly the same part of the registry that had Adobe 8 had failed to write to! Through my reasearch I knew Adobe was having problems writing keys to browser helper objects in the registry so i customized the spybot installation to avoid anything that could be construed as a browser helper object and it installed ok even if i was a bit miffed at having to settle for a watered down version of Spybot. Incudentally Spybot found no nasties, neither did ESS when I finally got it to finish a scan in safe mode.

    Tonight I think I may have discovered the underlying problem and wonder if anyone else has experienced similar problems as what worked for me doesn't really make sense to me but it appears to be ESS was causing the problem?


    Today I noticed on ESET's website the new version of ESS (3.0.642) so i uninstalled ESS, rebooted, deleted ESET folders in program files and hidden ESET folders in documents and settings etc etc etc and rebooted again. On the off chance I decided to try re-installing Adobe reader 8.1.2 whilst my machine did not have ESS installed and what do you know - it installed first time - no problems at all!

    I then installed ESS version 642; I have never had any problems installing ESS and the new version was true to the others and installed with no hitches. After installing ESS I remembered the problem i had experienced with Spybot - D'oh! I uninstalled Spybot and after another reboot, with ESS 642 installed I tried reinstalling Spybot S&D with the omitted browser helper object I had previously had to omit. Sadly I met with the exact same error code 6 again so I aborted the installation.

    Because of my success with Adobe I decided to uninstall ESS 642 repeating the process of removing hidden files etc then try re-installing Spybot again whilst effectively running without any virus protection or software firewall on my machine and voila - Spybot, all of it this time, installed with no problems at all.

    I have since re-installed ESET 642 but am now worried that if I want to install any software that contains BHO's i will end up having to uninstall ESS each time just to be able to do it.

    I hope this helps someone who is experiencing something similar to what I have experienced; compared to some of the fixes I have read on overcoming error 1406 like manually editing the registry for example then uninstalling ESS a few times to be able to install something else really doesn't sound too bad though not ideal - manually editing the registry makes brain surgery sound like a doddle after all - needless to say I didn't go there....!
     
  2. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    strange... and good find.... I have Acrobat Pro with its BHO installed along with ESS 3.0.642.0 ... no problems.. matter of fact I just rebuilt my machine for other reasons and ESS was the first thing I installed after office 2007 and all the MS patches....I have had no errors with my remaining app installs but I do have the fw in Interactive mode so it will learn everything.....I also have everything checked per the max protection guide w/i this forum for realtime protection, av and antispam.....

    I am rebuilding a second machine with pretty much the same process...will post again with those results.
     
Thread Status:
Not open for further replies.