Bad company 2

Discussion in 'ESET Smart Security' started by Stev0, Dec 16, 2010.

Thread Status:
Not open for further replies.
  1. Stev0

    Stev0 Registered Member

    Joined:
    Jul 27, 2006
    Posts:
    7
    Ever since Ive had this game esset firewall seems to block the pings from showing and so all come up as 999 which is starting to drive me a bit loopy because you dont know till you get in the game.
    Can anyone please explain a way that I can allow this to work without turning off the firewall.
    Firewall logs are coming up with the blocked ip address but doesnt give me enough info to put it in as a manual entry,just the ip and that its udp.
    Please help.
     
  2. TyeF

    TyeF Former Eset Moderator

    Joined:
    Feb 19, 2010
    Posts:
    78
  3. Stev0

    Stev0 Registered Member

    Joined:
    Jul 27, 2006
    Posts:
    7
    I did read through this but A-its not like my version of esset smart security4 as it appears you tut is showing a different version and B-when I tried excluding it in the excluded applications bit it seemed to do nothing towards fixing the problem.
    Maybe its just late and Im reading it wrong but both tuts for esset 3 and 4 appear to be identical and dont match my own menu layout.
     
  4. MinDokan

    MinDokan Registered Member

    Joined:
    Sep 16, 2010
    Posts:
    44
    Are you using the Steam version of the game?
     
  5. tony_m

    tony_m Eset Staff Account

    Joined:
    Nov 22, 2010
    Posts:
    239
    What version of ESS are you currently running?

    Is the same IP always blocked in the firewall log? Please copy that part of the log showing what's being blocked.
     
  6. Stev0

    Stev0 Registered Member

    Joined:
    Jul 27, 2006
    Posts:
    7
    I'm using the retail version.

    17/12/2010 13:37:40 Detected covert channel exploit in ICMP packet 82.32.123.149 62.104.17.141 ICMP

    this is what comes up in the firewall log.

    the version Im using is 4.2.67.10
     
  7. Nick0

    Nick0 Registered Member

    Joined:
    Feb 18, 2010
    Posts:
    32
    In ESET Smart Security, go into Setup> Personal Firewall> Advanced Personal Firewall Setup> IDS and advanced options> ICMP protocol attack detection: disable
    This will not make your machine vulnerable to viruses, it only means that someone can crash your computer remotely using an ICMP-based Denial-Of-Service attack (which is a very unlikely event).

    Source : http://forum.ea.com/eaforum/posts/list/1669038.page
     
  8. Stev0

    Stev0 Registered Member

    Joined:
    Jul 27, 2006
    Posts:
    7
    thanks alot m8,you are a gem :D
     
Thread Status:
Not open for further replies.