Automatic Mode: Let me get this straight

Discussion in 'ESET Smart Security' started by pcoombes, Sep 30, 2008.

Thread Status:
Not open for further replies.
  1. pcoombes

    pcoombes Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3
    I am running a 5 licence business edition of SS, version 672, though it's mostly on various computers at my home. I have been using it for a few years now but frustration is starting to kick in and I am starting to fall out of love with it :'( Although I have several ekrn.exe crashes per day on my laptop the problem that I'm really struggling with is on a family PC.

    On it I have SS currently in Automatic mode. However that doesn't let me get in using VNC or another remote access application I have to keep an eye on the kids. If I change to Interactive or Policy mode I can get in, so it's Automatic mode that blocking me. As it's the kids PC I have password protected SS so I can't run it in Interactive mode permanently (apart from the confusion all the popups cause the kids) and if I run it in Policy mode then various Messenger type things stop working, presumably as they connect to different hosts all the time and it needs a lot more rules.

    So I'm stuck with Automatic mode, which breaks things. I have read on these very forums that if you configure rules in Policy or Interactive mode and then switch to Automatic mode they should be preserved but I just cannot get that to work. In Pol or Int mode, I can get in, in Auto mode I can't.

    Can someone confirm or deny whether the above is true. And if that isn't the case how I can I just override Automatic mode in a nice and simple way to let a couple of applications listen, or even just let one host from the trusted network have unconditional access. It's not a unusual scenario I'm sure.

    Am I just missing something? What is the simplest way of allowing everything out and initiated connections in plus a couple of exceptions?
     
  2. Xtermy

    Xtermy Registered Member

    Joined:
    Sep 29, 2008
    Posts:
    3
    Hello.

    Strange, I also use Messenger and similar applications under Automatic Mode, and have no problems, and even uTorrent, which some people have said they have a problem running with ESS.

    As for remote access applications - try checking the Advanced Setup options. Scroll to personal firewall, then to IDS and advanced options, and then make sure that under Allowed Services all the services are marked (specifically Allow UPNP in the trusted zone, Allow remote desktop in the Trusted zone, and Allow incoming streams from the Internet via the IGMP protocol).
     
  3. pcoombes

    pcoombes Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3
    Thanks for your reply.

    I obviously didn't explain things very well. When SS is in Automatic mode then messenger etc work fine. What doesn't work is incoming VNC and my other remote admin programs. Whereas in Policy mode the opposite is true and I get kids phoning or moaning at me because things are working.

    I am just looking for a way to basically run in 'automatic mode with exceptions'. I can't imagine it is too complicated, in iptables it's about four lines, but I just can't figure out how to do it with SS.

    I looked at the IDS options but as I'm not using uPNP, IGMP or Remote Desktop I don't see that they would help all that much. The apps I want to use just use good old UDP and TCP to certain well defined ports.

    Cheers
     
Thread Status:
Not open for further replies.