Auto update hanging

Discussion in 'NOD32 version 2 Forum' started by jskorval, Aug 25, 2004.

Thread Status:
Not open for further replies.
  1. jskorval

    jskorval Registered Member

    Joined:
    Aug 25, 2004
    Posts:
    3
    I'm a long-time NAV and VirusScan user, currently evaluating NOD32 using the trial version.

    I've been very happy with the scans themselves, and the performance. But I'm having some strange problems with updates, and I need some expert assistance.

    PROBLEM SUMMARY
    ----------------------------------
    - I'm using the NOD32 Trial version 2.000.9, installed exactly
    two weeks ago.

    - I have an automatic update task enabled in the scheduler,
    configured to check every few hours, to retry ASAP if a time is
    missed, and to automatically choose a server.

    - After creating this task, it works correctly (launched at the
    proper times and apparently connecting to the ESET servers),
    UNTIL an update is actually available!

    - IF the update task is triggered AND an update is available, the
    download process is started. HOWEVER, it ALWAYS hangs after
    downloading only a fraction of the package.

    Note that this is NOT a "server connection failure". The server
    is reached, and the download begins -- it simply never completes.
    I'm connected through DSL, and normally have no trouble
    downloading large files.

    This has occured on EVERY automatic update performed (IIRC, at
    least 5 since installation). It does NOT matter which update
    is being downloaded (see below). The amount downloaded before
    hanging, as displayed in the Update screen, has varied from
    7%-20% (about 60KB to 380KB), as best I can remember.

    - WORSE... At this point, the entire update process is frozen.
    There is NO further attempt to complete or retry the current
    download, even after rebooting the system. The scheduled
    auto-update task is NEVER triggered again. I've waited as long
    as 2 days. I've rebooted the system. Nothing changes.
    Apparently, once "wedged", it remains wedged until I intervene
    manually (see below).

    - WORST OF ALL... There is no indication that anything is wrong.
    If I don't manually (and regularly) check the Update display,
    I would never know the updates were not succeeding.

    At first, I thought this was a problem with one specific update.

    I went to the Update screen, clicked the "Abort" button. This cancels the download, and the button changes to "Manual update". I click this, and the download starts over AND SUCCEEDS!

    However, all is STILL not well:

    - The scheduled auto-update task, which is still showing as enabled
    in the Scheduler, IS NEVER TRIGGERED AGAIN. Again, I know
    this because I have waited up to 2 days, reboots, etc., checking it
    periodically to see if it is listed as triggered. The date
    remains fixed at the time when the last auto-update hung.

    - The only fix is to delete the existing task, and re-enter a new
    (identical) task. At that point, we start the whole dance all
    over again.


    So, for anyone still reading...
    MY QUESTIONS:
    ------------------------------------------------------------
    My *hope* is that this is an artifact of running the TRIAL verson.
    Various reports in this forum indicate that the trial version will
    only update signature files, and not program updates.

    However... I can't find any documentation anywhere that describes
    the symptoms I've described above.

    - Has anyone else seen this specific behavior?

    - Can anyone *reliably confirm* that this is the normal, expected
    behavior for the trial version, and that the problem goes away in
    the paid version?

    - Alternatively, can anyone point out something I've done wrong in
    the configuration or use of NOD32?

    As much as I like what I've read about NOD32, and however good the actual scanning is, if I can't get automatic update to work RELIABLY, and if it doesn't ACTIVELY ALERT ME WHEN THE UPDATE FAILS, then its useless.

    Thanks for any help you can give -- this is proving very frustrating.


    MY SYSTEM INFO (relevant subset)
    -----------------------------------------
    - ENOD32 2.000.9 trial version, installed Aug 11
    - Virus signature database build 4774, version 1.850
    (but the problem has occured on EVERY update tried
    since installing)
    - WinXP ver 5.1.2600 Service Pack 1
    - ZoneAlarm (not Pro), with ENOD32 permitted full access and
    server permissions to both Trusted and Internet Zones. I've even
    given it "pass-lock" ability, to allow the updates to proceed even if
    I've locked out all other activity.

    I don't believe I have any conflicts with previous antivirus
    software. I completely uninstalled all portions of NAV, including
    the hidden ones, and ran a registry cleaner.
     
  2. Arin

    Arin Registered Member

    Joined:
    May 1, 2004
    Posts:
    997
    Location:
    India
    dear jskorval, the automatic update works in both versions. but i don't have a DSL connection :( so i set it up to update after it has detected a connection to the Internet. the trial version only updates the definations not the core components. the paid version on the other hand has the luxury of small incremental updates. regarding your update problems there several servers to choose from.

    http://sun.uid0.sk/~eset/eval
    http://www.eset.sk/eval
    http://www.nod32.com/eval
    http://u4.eset.com/eval
    http://u3.eset.com/eval
     
  3. jskorval

    jskorval Registered Member

    Joined:
    Aug 25, 2004
    Posts:
    3
    AMRX, thanks for replying, but I don't think this is really addressing the problem.

    I understand that the trial version only downloads the signature definitions, and not the component updates. However, does this mean that the trial version is supposed to LOCK UP while attempting an automatic update? And then NEVER attempt another update again?

    If I can confirm that this is the NORMAL behavior of the trial version, then I would be willing to gamble that the paid version will work correctly for me, and go ahead and buy it.

    If I can't confirm this, and if no-one else is seeing this strange behavior, then I have to assume there is some peculiar interaction with something I have installed on my machine. Without any clues as to cause, my best option is to try some other AV tool.

    In the meantime, until someone can give me some guidance, I'll try experimenting, by configuring the auto update to use a specific server rather than letting it automatically select a server.
     
  4. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    This is not usual, it should update for 30 days.

    Have you tried uninstalling Nod32

    Removing the Eset Folder from C> Program Files.

    Cleaning the registry of the last remaining Eset file.

    Reinstalling Nod32.


    I think it will go onto your system without a problem, with installing over 500 copies I have only ever come across 2 problems, both were easily fixed…

    Hope this helps…

    Cheers :D
     
  5. jskorval

    jskorval Registered Member

    Joined:
    Aug 25, 2004
    Posts:
    3
    Thanks Blackspear, that was the confirmation I needed.

    I uninstalled, scrubbed the registry, and just to be safe downloaded a fresh copy of the trial version. Reinstalled, but then had to wait for a new update to check that the problem was fixed. Everything's fine now.
     
Thread Status:
Not open for further replies.