At Wits End with SpywareBlaster_is1

Discussion in 'SpywareBlaster & Other Forum' started by bugslovertoo, Jul 29, 2008.

Thread Status:
Not open for further replies.
  1. bugslovertoo

    bugslovertoo Registered Member

    Jul 29, 2008
    [RESOLVED!]At Wits End with SpywareBlaster_is1

    Greetings. This is my first post in a forum, ever. I have an issue that I have not been able to resolve at all. I hope someone can help.

    I am running a WinXP Pro 2002 SP2 machine.
    I use SPYBOT S&D, AVAST antivirus, SPYWAREBLASTER, and AdAware and run them weekly, or there abouts.
    I am the administrator of this machine although there are 4 other non-admin users.

    I recently tried to update Spywareblaster to Ver. 4.1 (no, I didn't use the add/remove feature first) but the installation failed. I got the follwoing message:

    Error creating registry key:

    RegCreateKeyEx failed, Code 5.
    Access denied.

    It rolled back changes, but the program itself no longer works.

    Code 5 means I don't have permission to delete this key, but I am the administrator and should have full permissions.

    I went to Add/Remove Programs but there was no entry for Spywareblaster. I went into programs and opened the Spywareblaster folder and double clicked the uninstall icon. The message I got was that the program doesn't exist.
    So, I went into the registry and located the key. I am unable to change its permissions, rename it, delete it, etc. When I click on the key I get the message:
    Cannot open Spywareblaster_is1: Error while opening key.

    I downloaded Vilma registry editor free version and met the same fate, except that in Vilma the key is shown as locked.

    I exported a copy of the registry. I created a batch file (according to information I got somewhere out there) to delete the registry key and then merged that with the registry. Restart the machine and that erroneous key is still there.

    I have run CCleaner, Eusing Registry cleaner, and SpyBot S&D without any problems arising, but the key still remains.

    I cannot install this program. I cannot get rid of that key.

    I also started up in SAFE MODE as the system administrator and was still unable to delete the key from the registry with exactly the same error messages and results.

    I did not think to do all these things myself, they were all part of the research I have done to resolve this problem, and I am wondering if I need to open the registry backup in notepad to edit it there and then install that reg file, but that gives me the willies! Maybe a command line entry to delete that key, but I don't know how to do that although my research shows that it is very much like the commandline in the batch file. Any ideas out there? This is driving me batty.

    Thanks in advance.

    Last edited: Jul 30, 2008
  2. javacool

    javacool BrightFort Moderator

    Feb 10, 2002

    That key is used by the installer (we use InnoSetup) to write the uninstall information (that's used both by the installer/uninstaller and Add/Remove Programs in Windows).

    It almost sounds like the permissions for that registry key somehow got corrupted. I'm not sure what caused it, but there is a step we can try to fix things enough so you may be able to delete the key (and then reinstall SpywareBlaster).

    1.) Log-in to an administrator account.
    2.) Open regedit.
    3.) Browse to the affected key.
    4.) Left-click on it once. You should receive the "Cannot open Spywareblaster_is1: Error while opening key." message, but it should now be selected.
    5.) Right-click on the "Spywareblaster_is1" key, and choose "Permissions...". You'll likely receive an error that says "You do not have permission to view the current permissions settings...". Click OK. You should now see a "Permissions for Spywareblaster_is1" window.
    6.) Click on the "Advanced" button.
    7.) In the Advanced Security Settings window, click on the "Owner" tab.
    8.) Under "Change owner to:", select the username of your administrator account.
    9.) Check the box marked "Replace owner on subcontainers and objects."
    10.) Then click "OK".

    You may receive another error message, but it should actually reset the owner properly.

    Now try right-clicking on the "Spywareblaster_is1" key and choosing "Delete".

    If it works, you're done! :) Please do not proceed with the remaining steps below - you should be able to install the latest version of SpywareBlaster without any further trouble.

    If it still fails to delete the key, we'll need to recreate a Permissions entry so the Administrator account has full control of the key.

    To do so:

    1.) Right-click on the "Spywareblaster_is1" key again, and choose "Permissions...".
    2.) Click the "Add..." button.
    3.) Under "Enter the object names to select (examples):", type "Administrators" (without the quotes).
    4.) Click "OK". There should now be a line on the Security tab (selected by default) named "Administrators".
    5.) Under "Permissions for Administrators" in the bottom half of the window, check the "Allow" box for "Full Control".
    6.) Click "OK".

    Now you should be able to delete the key and reinstall SpywareBlaster.

    Best regards,

  3. bugslovertoo

    bugslovertoo Registered Member

    Jul 29, 2008
    Thank you for your response. The first suggestion was met with failure and I was unable to delete this key. I had previously tried to take control of the key using the second method, but I used a user name, not Administrators. Using Administrators worked!

    Thank you so much for your time and effort! I really appreciate it.


    Last edited: Jul 30, 2008
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.