Application filter IP blocking function not working if NOD32 installed

Discussion in 'LnS English Forum' started by vince100, Jul 9, 2009.

Thread Status:
Not open for further replies.
  1. vince100

    vince100 Registered Member

    Joined:
    Dec 9, 2007
    Posts:
    5
    [Solved] IP blocking does not work at application level if NOD32 installed

    Hi,

    First, thank you for this great firewall!

    I have a question about application filtering:

    When an IP blocking rule (e.g. @IP !0.0.0.0-128.255.255.255) was set for an application (e.g. iexplorer.exe) using application filtering, the rule would not work if NOD32 v3 or v4 were installed: the application simply ignored the blocking rule and could connect to any IP. (When a complete blocking rule was set using application filtering, the rule did work and the application could not connect to the internet.)

    The problem was caused by a conflict with NOD32 Antivirus. If NOD32 was not installed, the IP blocking function did work for an individual application.

    The problem can be reproduced on 2.05p2, 2.06, 2.06p1-p4 with either NOD32 v3 or v4 installed (XP SP3).

    I understand it's possible to set IP rules at Internet filtering level. But AFAIK those rules would affect all applications once activated, so that would not be an ideal solution in my case.

    Is there any way around this problem so I can use IP blocking at application filtering level?

    Thank you.
     
    Last edited: Jul 9, 2009
  2. valmont

    valmont Registered Member

    Joined:
    Oct 31, 2008
    Posts:
    1
    yes, i confirm that.
    i also have this problem :(
     
  3. vince100

    vince100 Registered Member

    Joined:
    Dec 9, 2007
    Posts:
    5
Thread Status:
Not open for further replies.