Antivirus Protection Disabled.

Discussion in 'ESET NOD32 Antivirus' started by mossie, Apr 14, 2009.

Thread Status:
Not open for further replies.
  1. mossie

    mossie Registered Member

    Joined:
    Mar 1, 2007
    Posts:
    17
    I have a problem with EAV on my laptop. I install it, it works for a while, then I get a message that:

    "Maximum Protection is not ensured

    Antivirus Protection Disabled.

    A serious error occurred while starting realtime file protection. The computer is not protected against threats. the program needs to be reinstalled!"

    I reinstall and the same thing happens. Basically it works for one or two days, then the same error.

    I am running Vista Home Premium, Outpost Firewall. Same setup on another PC no problems.
    #
    Mossie
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Do you have other security software installed which might prevent some drivers from being installed / loaded?
     
  3. mossie

    mossie Registered Member

    Joined:
    Mar 1, 2007
    Posts:
    17
    No, nothing else.
     
  4. bradtech

    bradtech Guest

    Did you happen to install the newest Service Pack 2 beta? You may disable UAC then reboot.. Install while UAC is off, bring it back on.. See how that works.. I don't recommend leaving UAC off, this is just to see if this is the issue.


     
  5. mossie

    mossie Registered Member

    Joined:
    Mar 1, 2007
    Posts:
    17
    I do have the Service Pack beta installed. I have tried before with UAC off but no luck. Thanks.
     
  6. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Does the file C:\Windows\System32\drivers\eamon.sys actually exist? Could you check in Device manager if eamon.sys is listed among Non-plug and play drivers and is actually loaded?
     
  7. mossie

    mossie Registered Member

    Joined:
    Mar 1, 2007
    Posts:
    17
    That is not listed in device manager and doesn't appear to be in C:\Windows\System32\drivers\
     
  8. Philippe_FR22

    Philippe_FR22 Registered Member

    Joined:
    Sep 6, 2007
    Posts:
    249
    Hello,
    Same problem here, on an old PC, since release 3.0...

    Neither support nor solution since a long time now...
     
  9. agoretsky

    agoretsky Eset Staff Account

    Joined:
    Apr 4, 2006
    Posts:
    4,032
    Location:
    California
    Hello,

    I just did some testing with the release candidate for the service pack and was not able to reproduce this. Could you send me an ESET SysInspector log from your computer via PM to look through?

    Regards,

    Aryeh Goretsky

     
  10. Philippe_FR22

    Philippe_FR22 Registered Member

    Joined:
    Sep 6, 2007
    Posts:
    249
    Hello,

    Just to maintain "up to date" this post...
    I' continuing to encounter this problem, regularly just during virus database update, when antivirus engine re initialize. This can occure at startup (daily initial virus database check and update) or during the day, when update available. At this moment, no solution, no idea and no support. Somtime, every thing can be OK for one or two weeks, then can occure again....

    - french support was contacted but nothing interesting. They just said please upgrade to the last release. That is what I did (from 4.0.x to 4.0.417), after a deep uninstall process and a complete PC cleaning... But problem still occured a few days after, during an update...

    - I contacted, once again, french support to explain that EAV upgrade did not change anything, and they told me that I must downgrade to v2.7...


    Surely, my PC is old (Win XP SP3, Athlon 800MHz, 1GB RAM, Abit KT7) but he is very safe and regularly cleaned. EAV should support such a platform, so what could be the reason for this problem ?

    One more question : why EAV does not try to initialize antivirus engine until it succeeds ? Why EAV does not downgrade to the last previous virus database with which every thing was OK ? I don't know ! What is sure is that regularly, this PC is not protected by ESET...


    So, thank you in advance if some ESET support can hear me and can give me some usefull informations...

    Regards


    PS : sorry I'm french !
     
  11. Philippe_FR22

    Philippe_FR22 Registered Member

    Joined:
    Sep 6, 2007
    Posts:
    249

    Hello,
    I just checked at home, on my two PC, under windows XP SP3.

    The eamon.sys file exists in the mentionned location (under drivers) however, I listed all the non plug and play drivers and did not see anything related to eset. What should be the name in the list of non plug and ply drivers ? The same name, e.g. eamon.sys ?

    Regards
     
  12. mossie

    mossie Registered Member

    Joined:
    Mar 1, 2007
    Posts:
    17
    I have the logfile but cannot see an option to attach a file in a PM.

    Mossie
     
  13. trjam

    trjam Registered Member

    Joined:
    Aug 18, 2006
    Posts:
    9,057
    Location:
    North Carolina
    drag that mouse.:)

    copy and paste it to notepad and save it then send it as an attachment to him. Same thing. Or copy and paste in PM.
     
  14. agoretsky

    agoretsky Eset Staff Account

    Joined:
    Apr 4, 2006
    Posts:
    4,032
    Location:
    California
    Hello,

    Private Message sent.

    Regards,

    Aryeh Goretsky

     
Thread Status:
Not open for further replies.