An error occurred while saving the configuration...

Discussion in 'ESET NOD32 Antivirus' started by virkelie, Jul 18, 2009.

Thread Status:
Not open for further replies.
  1. virkelie

    virkelie Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    77
    "An error occurred while saving the configuration. Please make sure that you have permissions to change settings."

    I took the plunge, and upgraded from Nod32 2.7, to version 4.

    When I try and make changes to any of the setup options, I get the above error message.

    I am the only account on my computer.
    I log-on to Windows XP using a password.

    How do I get the necessary "permissions" to change settings?

    Thanks.
     
  2. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,772
    Location:
    Texas
    Hello virkelie,

    I would make sure I downloaded the correct version. You might want to double check which version you downloaded. Just in case. :)
     
  3. virkelie

    virkelie Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    77
    I downloaded "ESET NOD32 Antivirus 4" - Version 4.0.437.0

    Which is the incorrect version? I am not sure what you mean?

    I put in the same username and password that I had for nod32 - version 2.7


    virkelie
     
  4. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,772
    Location:
    Texas
  5. ASpace

    ASpace Guest

    @virkelie

    You mention upgrade ...

    Have you tried rebooting the machine and see what happens afterwards ?
    Have you tried performing uninstallation followed by a clean install ?
     
  6. virkelie

    virkelie Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    77
    I checked my installation file - I installed the home version, WinXP, 32 bit.

    I also checked the validity of my ESET license under the "Help Menu" - my license is valid.

    I also checked the properties of the name I use to logon to my computer (I checked that in "User Acounts").

    The "User Acounts" says my "Group Membership" is "Administrator" - with "complete and unrestricted access to the computer".

    So I don't know why ESET doesn't allow me to make changes in the setup.
     
  7. virkelie

    virkelie Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    77
    Yes, I have rebooted a number of times.
    Yes, I uninstalled Nod32 version 2.7 before installing version 4.
    I also uninstalled, and then reinstalled version 4.

    Any clues?
     
    Last edited: Jul 19, 2009
  8. pegr

    pegr Registered Member

    Joined:
    Apr 8, 2008
    Posts:
    2,279
    Location:
    UK
    A friend of mine recently had exactly the same problem and was unable to save any NOD32 configuration changes, even though he was logged onto Windows XP using an Adminstrator account. In his case, restoring Windows XP security settings to the default settings did the trick. Here is the link if you want to try it: -

    http://support.microsoft.com/kb/313222

    Just follow the instructions in the "Fix it for me" section and see if it solves the problem. Make sure you're in a position to be able to restore your system though before applying the fix - either using System Restore or from an image backup - just in case something goes wrong.
     
  9. virkelie

    virkelie Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    77
    Thanks for your suggestion.
    But I am a bit "chicken" to apply that fix.

    To me it doesn't make sense to lower security, in order to have a security program.

    There is something wrong with nod32.
     
  10. pegr

    pegr Registered Member

    Joined:
    Apr 8, 2008
    Posts:
    2,279
    Location:
    UK
    You're not lowering your security and the blame for this does not lie with NOD32. NOD32 is simply honouring the Windows XP security settings that are in force on your system.

    What may have happened is that, at some point, another program has corrupted your Windows XP security settings so that you longer have full admin rights, even though logged on using an administrator account. What the fix does it to restore the security settings to what they should be.

    It's obviously up to you whether or not you try the fix, but I've seen this situation before and, if corrupt Windows XP security settings are the cause, then I don't know another solution. Unless you try the fix, you'll never know whether or not it would have solved the problem. Even if it doesn't work, you will have eliminated a known possible cause of this problem, which is still a step forwards to finding a solution.
     
  11. virkelie

    virkelie Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    77
    Well, I figured how to fix this...

    The fix is based on this thread:

    https://www.wilderssecurity.com/showthread.php?t=219968

    The problem seems to be in how ESET handles the registry upon installation of Nod32 Version 4.
    ESET does not automatically add your logon name to its permissions in the registry.

    So here is the solution (at least it worked for me):

    1. Run regedit
    2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\ESET\ESET Security
    3. Right click the "ESET Security" registry key, and click "Permissions".
    4. Go to "Advanced" settings; Add "logon name" (ie the name you logon with on your computer); and give yourself "Full Control" to "this key and subkeys".


    And Voila! I (and you too - hopefully) can now change the settings in Nod32 version 4!

    And thanks to everyone who responded to my posts!
     
  12. pegr

    pegr Registered Member

    Joined:
    Apr 8, 2008
    Posts:
    2,279
    Location:
    UK
    Glad you found the solution. :)

    Regards
     
Thread Status:
Not open for further replies.