An error has occurred while updating transport agent status (12)

Discussion in 'Other ESET Business Products' started by enod_1701_D, Jan 17, 2012.

Thread Status:
Not open for further replies.
  1. enod_1701_D

    enod_1701_D Registered Member

    Joined:
    Aug 12, 2011
    Posts:
    15
    1/17/2012 8:42:01 AM - During execution of Mail server protection for Microsoft Exchange Server on the computer S10487, the following warning occurred: An error has occurred while updating transport agent status (12)

    The counters were not increasing for AV or spam, even though things in spam were being loged. Rebooted Exchange 2007 and now we get this error message. VSAPI does not seem to be communicating with ESET. For example the SETUP button under VSAPI 2.6 -->Transport Agent does not do anything when clicked. The custom Rules appear to be the only thing operating at this time.
    2007 Exchange has latest SP and updates. ESET is version 4 latest.

    Any ideas?
    thanks!
    John
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Please check the system event log for possible errors. Are there any that might be related to this issue?

    If you run "Get-TransportAgent", is ESET listed among the transport agents? Have you already restarted the server to see if it cures the problem?
     
  3. enod_1701_D

    enod_1701_D Registered Member

    Joined:
    Aug 12, 2011
    Posts:
    15
    Yes
    ESET Filtering AV Agent
    ESET Filtering Agent
    Transport Rule Agent
    Journaling Agent

    I've restarted the Exchange Transport, Information Store, and Hosts Service and it made no difference.

    I enabled ESET debugging and can see that it is using VSAPI sometimes.
     
  4. enod_1701_D

    enod_1701_D Registered Member

    Joined:
    Aug 12, 2011
    Posts:
    15
    I shut the server down and turned it back on instead of doing a "restart" and it solved the problem, however I am not sure the spam protection is working. Nothing has logged in about 30 minutes and we usually get spam all day long.
    Well, no errors, so I will wait a while and check it again. Usually it lists everything and if it was rejected or retained, so I will have to say that it is not working at all.
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Please enable synchronious diagnostic logging under Computer protection -> Tools -> Log files and Server protection -> Tools -> Log files (Sync. writing without using cache & Log diagnostic information), receive some emails and then check the ESET Event and Antispam logs for more information. If there are some relevant entries, post them here.
     
  6. enod_1701_D

    enod_1701_D Registered Member

    Joined:
    Aug 12, 2011
    Posts:
    15
    Thanks, they had me upgrade to the latest version 10016.0 to 10023.0, so this issue has been resolved. Too bad the new version doesn't allow filtering the anti-spam log without freezing everything up...
     
  7. enod_1701_D

    enod_1701_D Registered Member

    Joined:
    Aug 12, 2011
    Posts:
    15
    Another odd thing, in both versions - nothing would happen when I tried to reset to defaults, not in any menu and not the whole system...
     
Thread Status:
Not open for further replies.