"Access is denied" message when exploring image

Discussion in 'Acronis True Image Product Line' started by ?GotJazz?, Jun 24, 2006.

Thread Status:
Not open for further replies.
  1. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    Hello -

    I have a problem that is causing me serious issues, and my research has come up empty so far.

    I have a laptop with a corrupted MFT. While my C:\ drive generally works, I am having occasional problems that are slowly getting worse over time. So, I need wipe out the partition and reinstall WinXP Pro on it.

    So, my first step was to run True Image to store my drive's data onto another hard disk on another computer. (This is a key point of the problem).

    So, to make sure that I could recover my files to a new partition, I started to explore the image on the other PC. When trying to access my personal folder, I get an "Access is denied" message.

    This is a big problem - once I reformat my laptop drive and reinstall WinXP, I'm sure my laptop will look like a different PC to the backup image as well, and be unable to access the files, either.

    Does anyone know how to fix this problem? Is there a way to turn off the "hide my folders from other users" feature of WinXP/NTFS once it has been enabled?

    TIA!

    ¿GotJazz?
     
  2. JARd1st

    JARd1st Registered Member

    Joined:
    Sep 30, 2005
    Posts:
    49
    see if the same happens if you copy that folder onto the drive.

    When I explore an image, some folders don't even show as visible, but if I copy all of Documents and Settings, or even just the folder with my user name, everything is accessable.

    Good Luck!
     
  3. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    Trying to copy the desired folder (or the Documents and Settings folder) didn't work. I got a "Cannot create or replace ... Access is denied" message.
     
  4. beckygb

    beckygb Registered Member

    Joined:
    Aug 4, 2005
    Posts:
    103
  5. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    beckgb - Thanks for the suggestion!

    However, I don't think that changing the owner will make a difference here, unless I can change the owner to my desktop PC.

    I have two PCs here: One has a computer name of "MyLaptop", and the other has a computer name of "MyDesktop".

    The True Image 8.0 backup is of the C: drive of MyLaptop, and it is currently stored on the MyDesktop computer.

    When I looked on the MyLaptop PC, the owner of the directory that I want to have access to is already owned by "MyLaptop\Administrators". I couldn't find any way to assign ownership of the directory to "MyDesktop\Administrators", even when the two PCs were connected on the same network. If there is a way to assign ownership to the MyDesktop PC when it is connected on the network, that may fix my problem - but I don't know if that is possible.

    Again, another option would also be to turn off the "hide folders from other users" option of NTFS, but I don't know if that is possible, either.

    I'm really struggling here ... I'm eager to find out if there is a solution. Until I can get the directory in the image to be readable from a different PC, I don't think I can fix my laptop.

    Sigh ... Maybe I'm missing something? Any advise is appreciated!
     
  6. jmk94903

    jmk94903 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    3,329
    Location:
    San Rafael, CA
    Just to be absolutely clear, is the Desktop running Windows XP Pro or Home?

    When you tried to explore the image of the laptop, were you working on the Desktop computer with it's copy of TrueImage and exploring the image of the laptop that was stored on the Desktop computer?

    Were you successful in assigning a drive letter to the image of the laptop?

    Could you access some of the folders in the image and copy the files to the Desktop computer?

    Was the only folder that gave you an "Access Denied" message the folder in Documents and Settings with your logon name for the laptop? Could you open the My Documents folder under that folder?

    Sorry to be so detailed, but this is a very odd situation.

    I thought that if you followed the instructions in the MS KB article that beckygb supplied and at the Desktop PC took ownership of the folder or backup file, you could open it on the Desktop PC without a problem.
     
    Last edited: Jun 24, 2006
  7. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    Hi, jmk94903 -

    Just to be absolutely clear, is the Desktop running Windows XP Pro or Home?

    The Desktop is running WinXP Pro, SP2.

    When you tried to explore the image of the laptop, were you working on the Desktop computer with it's copy of TrueImage and exploring the image of the laptop that was stored on the Desktop computer?

    Yes, that is correct.

    Were you successful in assigning a drive letter to the image of the laptop?

    Yes, it was successfully assigned to my K: drive.

    Could you access some of the folders in the image and copy the files to the Desktop computer?

    I was able to explore other directories, just not able to explore "Documents" directory that contains my personal information. I could get to the "All Users" Documents directory just fine, and copy files without any problems.

    Was the only folder that gave you an "Access Denied" message the folder in Documents and Settings with your logon name for the laptop? Could you open the My Documents folder under that folder?

    That is correct. The directory I could not get into was the one assigned to my login name. I was not able to get to the "My Documents" folder under the user name, though. When I clicked on the user name folder under "Documents and Settings", that's where I got the "Access is denied" message - so I was denied access at a higher level.

    Sorry to be so detailed, but this is a very odd situation.

    Not a problem! Thanks for helping me out! :)

    I thought that if you followed the instructions in the MS KB article that beckygb supplied and at the Desktop PC took ownership of the folder or backup file, you could open it on the Desktop PC without a problem.

    I tried it, but I don't have any rights to that directory on the Desktop PC, so apparently I don't have the rights to change ownership.

    ¿GotJazz?
     
    Last edited: Jun 25, 2006
  8. jmk94903

    jmk94903 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    3,329
    Location:
    San Rafael, CA
    Well, since you can access the files in All Users and other folders in the image, this is a specific Permissions issue with the folder with your logon name (and everything in that folder).

    I just mounted a backup from my wife's computer on my computer. I was able to open all the folders and files in the image of her computer. So, this is not normally a problem. However, I believe you said that on your notebook, you had set the option on the laptop in User Accounts to "not allow access by other users." This must be what is causing the problem.

    My first thought would be to simply go to the laptop, undo that choice in the User accounts and make a new image to the Desktop. If you can now access all the files and folders, you are done.

    However, my guess is that you have already tried that, and it didn't work. Am I right?

    This confuses me. Did you follow the instructions in the article on taking ownership and disable Simple File Sharing on the Desktop computer as a first step? Here's the link to the KB ariticle: http://support.microsoft.com/kb/307874.

    Then, on the Desktop, did you Right Click on the folder in the image with your logon name and select "Properties"? What do you see? Is there a Security tab as well as the General, Sharing and Customize tabs? If so can you follow steps 2 through 6 to take ownership of the folder as described in KB 308421?

    This is a very interesting problem that I'm sure happens fairly often since that option to not let others access your files is easy to find in Users Accounts.
     
    Last edited: Jun 25, 2006
  9. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    Hi, John -

    Yes, I did that, and saw the new options available under the Security tab.

    I tried, but was denied. I wasn't allowed to change the ownership of the folder, probably because I didn't have the proper permissions to do it.

    But ... You mentioned something that caught my attention:

    How do I do this? This sounds perfect. However, I can't find anything on the Control Panel's "User Accounts" settings to do this. Can you direct me on what to do?

    Thanks!
     
    Last edited: Jun 25, 2006
  10. jmk94903

    jmk94903 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    3,329
    Location:
    San Rafael, CA
    That really doesn't make sense if you are logged onto the Desktop as an Administrator (member of the Administrators Group). Administrators have permission to do anything they want on the local system including taking ownership of files or folders.

    This is dumb, but did you confirm in the User Accounts that your account has administrator privileges? If you do, then perhaps the problem is related to the virtual disk mounting since it isn't a physical hard disk but an image made to appear as a drive.

    Did you try to copy the entire Documents and Settings folder from the image to your hard disk on the Desktop machine?

    I'm embarassed. I can't find where I saw this and am beginning to think that I've been halucinating. As you discovered, it's not in the options for User Accounts, and I can't find where I saw that option - if I actually did. I'll keep looking.
     
  11. jmk94903

    jmk94903 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    3,329
    Location:
    San Rafael, CA
    I just had another idea.

    When you were working on the Desktop with the mounted image, you can click on the Documents and Settings folder and open it since you were able to see the contents of the All Users folder.

    If you right click on the Documents and Settings folder, select Properties and go to the Security tab, who is listed as the owner of that folder?

    Ownership normally includes all subfolders, so if you can take ownership of Documents and Settings and be sure that the box is checked for all subfolders, that might do it.
     
  12. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    No, not dumb! :) I checked again, and yes, my Desktop account has Admin priviledges. I think that you may be correct about there being a problem with the virtual disk mounting (I have begun to suspect the same thing).

    Since a picture is worth a thousand words, it may help if I add "6,000 words" to my posting ... ;)

    If I go to any of the other directories in my True Image 8.0 backup file that I do have access to (such as \Documents and Settings\All Users), I see this for the properties:

    http://members.cox.net/mytrashcan/TrueImageImage1.JPG

    Clicking the "Advanced" button, I see:

    http://members.cox.net/mytrashcan/TrueImageImage2.JPG

    Then (and this is interesting) when I press the "Owner" tab, I see:

    http://members.cox.net/mytrashcan/TrueImageImage3.JPG

    After I hit "OK", I get this screen, which is different from what I would see for a "native" hard drive:

    http://members.cox.net/mytrashcan/TrueImageImage4.JPG

    But, I can still see into that folder OK, even if I can't change ownership.

    Now, for the directory that I'm having problems with ...

    When I try to access the directory, I first get an "Access is denied" message. Then, when I do a "Properties..." on the directory, I see:

    http://members.cox.net/mytrashcan/TrueImageImage5.JPG

    ... which looks a bit different from the "All Users" directory that I do have access to.

    Finally, when I try to change the owner of the directory by selecting the "Owner" tab, I see:

    http://members.cox.net/mytrashcan/TrueImageImage6.JPG

    ... which again, looks different from the directory that I do have access to.

    Does this help?

    ¿GotJazz?
     
  13. jmk94903

    jmk94903 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    3,329
    Location:
    San Rafael, CA
    This is really odd. I wish I had a file to test with, but none of mine have Access Denied folders. Of course, I'm glad about that also. :)

    That really helps clarify the problem. Unfortunately, it doesn't clarify an answer.
    But the owner is Administrators on Desktop which is what you want and what it should be which is interesting since you can access this folder.

    Look at that odd user name! And the Add button is greyed out so you can't add Administrators. How odd.

    If you do the same thing on the Notebook (the computer not the image), who are the owners for those two folders? On the Notebook, the owners should be Administrators-Notebook for both and also the Logon name for the Logon name folder. If it is anything else, perhaps that will allow a change in owners.

    Did you ever use any special encryption on the folders on the laptop or any security utilities? Windows encryption for a folder is shown on the Properties screen, General tab under the Advanced button. Compression is also selected there. Is any box checked?
     
    Last edited: Jun 27, 2006
  14. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    :D

    Yes, but I think the fact that this is a mounted image is messing things up a little bit here. It doesn't appear that I have real "ownership" to the "All Users" directory, and I can't make any real changes to the ownership. I don't mind for this particular directory, since I can read it - which is all that matters.

    But, this got me thinking ... so I just did a quick test, and got the results I expected.

    I mounted an old True Image backup that I didn't care about anymore. Again, I have access to the "All Users" directory, but not the personal directory that I want - so I have a similar situation with the older image.

    Now ... the test: I tried to copy a small text file into the "All Users" folder, which I am supposed to have ownership. As I guessed, it failed - becaue the image is write-protected, even though the permissions say otherwise. This makes sense, though - a backup image probably shouldn't be easily modifiable.

    I'm betting that's why we're seeing the weird ownership stuff on the directories that I can read.

    The directory I can't read is probably a different issue, though. That "Prevent other users from seeing my files" option thingy is probably screwing things up there.

    Hmmmm ... I've seen that name somewhere before ...

    [ ... time passes, and ¿GotJazz? goes to check something on his laptop computer ... ]

    Found it! I've seen that exact same name when I turn ON the "Tools >> Folder Options ... >> View >>> Show hidden files and folders" option and turn OFF the "Hide protected operating system files" option. Then, in the hidden "RECYCLER" directory, the Recycle Bin for my user on the laptop has that exact same name.

    I suspect that this "S-1-5-21-..." weird name is actually an indicator of what is blocking my access. I think that the "S-1-5-21-..." name is a random, totally unique identifier that Windows generates every time a new user is created on a PC. And, I think that unique identifier is the real thing that Windows uses behind the scenes to keep track of a user, not the user's login name. And, if my desktop PC's identifier is different from my laptop PC's (which it is), Windows will block my access if I have the "Prevent other users from seeing my files" option enabled.

    That's just my guess, though.

    On a slightly humourous side note, I can dive right in to any Windows folder (protected or not) if I run Linux with my Windows drives mounted. This doesn't help with accessing a True Image backup, of course - The TI backup can only be mounted under Windows, as far as I know.

    When looking on my laptop, the owners for both those folders are "MyLaptop/Administrators".

    I haven't been able to figure out how to change the owner from "MyLaptop/Administrators" to "MyDesktop/Administrators", even though both computers are connected on the same network. When I try to add a "MyDesktop/Administrators" user on my laptop, I select the "Locations ..." button, but I can't see the MyDesktop computer. I wonder if I would see it if both PCs were registered on the same domain, instead of being connected just by the same workgroup?

    As a result, I don't see an option to select "MyDesktop/Administrators" in the owner list when I'm on my laptop.

    No, I never used the encryption option - that always scared the heck out of me. I tried to recover files that my boss once encrypted after he forgot his password, and I couldn't figure out how to get them back. I'm not that paranoid on my own PCs, I guess. :)

    I don't use any other security utilities, either.

    ¿GotJazz?
     
    Last edited: Jun 27, 2006
  15. jmk94903

    jmk94903 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    3,329
    Location:
    San Rafael, CA
    OK, so this problem is not new but has existed for a while. And, it's not a problem with just this one backup, but it's consistent.

    That's correct in TI Version 8. There's no way to modify the image only to copy files or folders out of it.
    I really wish you could remember how you set that feature. I havne't been able to recall where I've seen it.

    Oh weird. The Recycle Bin owns your files. :)
    You would have to have an account set up on the notebook to assign ownership to that account. You can't add the Desktop administrators since that's an account on a different computer. However, Administrators should be enough since that is a logon group on both systems.

    On the laptop, what name do you logon with? If it's Jazz, then do you log onto the Desktop with the same name, Jazz, or a different name? If it's different, you could create a new account on the Desktop with that name and log onto it. Then try again to mount the image with TI and see if the results are different. I doubt this will work, but it's all I can think of at the moment.

    Something is very odd with the notebook, and we haven't gotten to the bottom of what that is. Anything that you can remember about what you did to set "Prevent other users from seeing my files" option would be helpful.
    Well, that's good. The problem is then somehow within Windows, but not encryption, and not due to some unknown software.
     
  16. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    Yeeee-ha! I figured it out! :D

    John -

    Here's the deal: Our suspicion that the problem revolved around the "hide folders from other users" option was correct.

    The difficulty was trying to find out how to disable it after the privacy option was enabled.

    Part of the problem was that I had to find out how to ask the question properly in Google. When I finally did ask the right query in Google (ie, "folder private" "Windows XP"), it led me to this website.

    However, to get this to work, I had to remove the effects of the advanced file sharing stuff that we did over the last few days.

    So, these were all the steps I went through (all on my laptop computer):

    1. First, I had to go back to "simple file sharing" in Windows Explorer (Tools >> Folder Options ... >> View >> Select "Use simple file sharing").
    2. Then, I went to the personal directory that needed to be changed under the "Documents and Settings" directory.
    3. I selected the "Properties" option for the directory that needed changing.
    4. Next, selected the "Sharing" tab, and then enabled the "Make this folder private" option. Then I selected the "Apply" button. (This forces the folder and all its sub-items to be reassigned back to the original owner)
    5. In the same window, I then disable the "Make this folder private" option. Then, I select the "OK" button. (This frees up the directory and all the sub-items so that anyone can view them)

    (Note that you may be able to skip step (4) if the "Make this folder private" option is already selected at that point.)

    After that, I rebuilt a TI backup image, and was able to explore the previously off-limits directory without any problems on my desktop computer.

    The odd thing is, I know that WinXP prompted me with a pop-up dialog at some point to make the folder private in the first place. I can't remember when it did that, but I think it may have been when I added my first new user after the initial XP installation. I'm sure that I never noticed the "Make this folder private" checkbox before.

    I can't believe that it was this difficult to find the answer to what should be such a simple thing.

    John - Thanks again for your help (and your patience!)

    Cheers!

    ¿GotJazz?
     
    Last edited: Jun 28, 2006
  17. jmk94903

    jmk94903 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    3,329
    Location:
    San Rafael, CA
    Oh yes, a big YeeHa! That was where I was going wrong. I kept using Hide instead of Private in searches. With computers, you can't be wrong with the terms and find the right answer.

    I have seen that Make private box many times, but I've never used it and just was blind to it during this exercise. I congratulate you on figuring this one out.

    My guess is that if you had just wanted to restore the image, you would never have realized that there was a problem. In the restored image everything would have worked fine. The problem only arises when you need to Plug the image and copy data files out of it on another computer or after a clean install of the operating system.

    Well, that's intuitively obvious. :)

    Well done!

    I know I've seen that also, but I can't figure out where. I made a new user on one machine, but I didn't get that notice. Oh well, if I ever see this problem again, I won't have the trouble we've had.

    It's all in the choice of words. For example, try to find out how to ERASE something in MS Word. It can't be done. You have to search for DELETE.

    And thank you for finding the answer and testing it to confirm that it worked.

    This really is a valuable piece of information about Windows and about TrueImage images.

    Now, I can enjoy the Fourth of July without any nagging thoughts about this.
     
  18. ?GotJazz?

    ?GotJazz? Registered Member

    Joined:
    Oct 8, 2004
    Posts:
    22
    Hey, John (and anyone else interested in reading this) -

    I found out when you see the "Hide your files" popup with WinXP.

    If add a new user on the PC, you will get a pop-up asking if you want to hide the user's files the first time you add a password for the user's account.

    I knew I saw it somewhere before!

    :cool:

    ¿GotJazz?
     
Thread Status:
Not open for further replies.