Absolutely will not install.

Discussion in 'NOD32 version 2 Forum' started by Carl Farrington, May 15, 2007.

Thread Status:
Not open for further replies.
  1. Carl Farrington

    Carl Farrington Registered Member

    Joined:
    Jun 25, 2004
    Posts:
    57
    Location:
    Manchester, England, U.K.
    I am having a nightmare here.

    The license expired March 2007, so I purchased on behalf of this client and went to update.

    The update froze at "updating" (after downloading). Task manager showed a process "NU733.tmp" at 99% CPU, doing nothing.

    I removed the application and tried to reinstall from new download, now the setup procedure ends at the final part "Please wait.." message-box in the middle of the screen.

    Running setup /test seems to show the logfile stopping at "ps_emon.dll".
    I have done an Expert setup, and de-selected *everything* (imon, dmon, emon), so then why is it trying to install emon?

    I have manually removed all remnance of the application from all directories, registry, "sc delete amon; sc delete nod32krnl; sc delete nod32drv", etc.

    I have cleared %userprofile%\temp and \windows\temp.

    Still it fails in exactly the same way.

    I have checked/rebuild Winsock LSPs using both WinsockXPFix, netsh int ip reset resetlog.txt, LSPFix.exe etc, still no good.

    The logfile looks like this:

    Code:
    [2007-05-15 14:30:23.705] CmdLine: /test
    [2007-05-15 14:30:23.705] Resource: main.dll
    [2007-05-15 14:30:23.705] Is program installed?
    [2007-05-15 14:30:23.705] XML_ACCESS: C:\Program Files\ESET\Install - C:\Program Files\ESET\Install\setup.xml
    [2007-05-15 14:30:23.705] Registry: old settings read
    [2007-05-15 14:30:23.725] global.xml created
    [2007-05-15 14:30:23.725] XML_ACCESS: C:\Program Files\ESET\Install - C:\DOCUME~1\User\LOCALS~1\Temp\global.xml
    [2007-05-15 14:30:23.725] XML_ACCESS: C:\Program Files\ESET\Install - C:\Program Files\ESET\Install\setup.xml
    [2007-05-15 14:30:23.725] Main settings added
    [2007-05-15 14:30:23.725] Engines nups
    [2007-05-15 14:30:23.725] InstallPath added
    [2007-05-15 14:30:23.725] LogPath added
    [2007-05-15 14:30:24.056] EngineFile extracted
    [2007-05-15 14:30:24.206] EngineFile extracted
    [2007-05-15 14:30:24.246] EngineFile extracted
    [2007-05-15 14:30:24.276] EngineFile extracted
    [2007-05-15 14:30:24.306] EngineFile extracted
    [2007-05-15 14:30:24.316] EngineFile extracted
    [2007-05-15 14:30:25.107] XML_ACCESS: C:\Program Files\ESET\Install - C:\DOCUME~1\User\LOCALS~1\Temp\nodtmpa\setupc.xml
    [2007-05-15 14:30:25.137] SetupAddComponentDescToGlobal
    [2007-05-15 14:30:25.137] Component added
    [2007-05-15 14:30:25.137] Componet libraries
    [2007-05-15 14:30:25.808] XML_ACCESS: C:\Program Files\ESET\Install - C:\DOCUME~1\User\LOCALS~1\Temp\nodtmpb\setupc.xml
    [2007-05-15 14:30:25.808] SetupAddComponentDescToGlobal
    [2007-05-15 14:30:25.808] Component added
    [2007-05-15 14:30:25.808] Componet libraries
    [2007-05-15 14:30:26.229] XML_ACCESS: C:\Program Files\ESET\Install - C:\DOCUME~1\User\LOCALS~1\Temp\nodtmpc\setupc.xml
    [2007-05-15 14:30:26.229] SetupAddComponentDescToGlobal
    [2007-05-15 14:30:26.229] Component added
    [2007-05-15 14:30:26.229] Componet libraries
    [2007-05-15 14:30:26.309] XML_ACCESS: C:\Program Files\ESET\Install - C:\DOCUME~1\User\LOCALS~1\Temp\global.xml
    [2007-05-15 14:30:26.329] Cmd:  0 Exelib: NOD32MOD_WINNT_ENGLISH_BASE
    [2007-05-15 14:30:26.329] - krnstp.dll
    [2007-05-15 14:30:26.339] - ps_upd.dll
    [2007-05-15 14:30:26.339] Cmd:  0 Exelib: NOD32MOD_WINNT_ENGLISH_STANDARD
    [2007-05-15 14:30:26.339] - ps_amon.dll
    [2007-05-15 14:30:26.349] - ps_nod32.dll
    [2007-05-15 14:30:26.349] - ps_dmon.dll
    [2007-05-15 14:30:26.359] Cmd:  0 Exelib: NOD32MOD_WINNT_ENGLISH_INET
    [2007-05-15 14:30:26.359] - imon.dll
    [2007-05-15 14:30:26.359] - ps_emon.dll
    [2007-05-15 14:30:26.359] ExeLibs: Init
    [2007-05-15 14:30:26.359] Cmd:  2 Exelib: NOD32MOD_WINNT_ENGLISH_BASE
    [2007-05-15 14:30:26.359] - krnstp.dll
    [2007-05-15 14:30:26.369] - ps_upd.dll
    [2007-05-15 14:30:26.369] Cmd:  2 Exelib: NOD32MOD_WINNT_ENGLISH_STANDARD
    [2007-05-15 14:30:26.369] - ps_amon.dll
    [2007-05-15 14:30:26.379] - ps_nod32.dll
    [2007-05-15 14:30:26.379] - ps_dmon.dll
    [2007-05-15 14:30:26.389] Cmd:  2 Exelib: NOD32MOD_WINNT_ENGLISH_INET
    [2007-05-15 14:30:26.389] - imon.dll
    [2007-05-15 14:30:26.399] - ps_emon.dll
    [2007-05-15 14:30:26.409] ExeLibs: Load Current State
    [2007-05-15 14:30:26.409] Error: Couldn't open Administrator's XML : nod32.xml
    [2007-05-15 14:30:32.598] Registry: root written
    [2007-05-15 14:30:32.598] XML_ACCESS: C:\Program Files\ESET\Install - C:\DOCUME~1\User\LOCALS~1\Temp\global.xml
    [2007-05-15 14:30:32.948] SetupCopyFiles
    [2007-05-15 14:30:32.958] Cmd:  3 Exelib: NOD32MOD_WINNT_ENGLISH_BASE
    [2007-05-15 14:30:32.958] - krnstp.dll
    [2007-05-15 14:30:33.419] - ps_upd.dll
    [2007-05-15 14:30:33.459] Cmd:  3 Exelib: NOD32MOD_WINNT_ENGLISH_STANDARD
    [2007-05-15 14:30:33.459] - ps_amon.dll
    [2007-05-15 14:30:33.469] AMONPLG Status: Install case begin
    [2007-05-15 14:30:34.761] AMONPLG Status: Install case end
    [2007-05-15 14:30:34.771] - ps_nod32.dll
    [2007-05-15 14:30:34.771] NOD32PLG Status: Install case begin
    [2007-05-15 14:30:34.871] NOD32PLG Status: Install case end
    [2007-05-15 14:30:34.881] - ps_dmon.dll
    [2007-05-15 14:30:34.911] Cmd:  3 Exelib: NOD32MOD_WINNT_ENGLISH_INET
    [2007-05-15 14:30:34.911] - imon.dll
    [2007-05-15 14:30:34.921] - ps_emon.dll
    
    This machine previously had "PC Tools anti-spyware" installed, which I removed. I suspect this may be the root cause of the problem.

    Any ideas?
     
  2. Carl Farrington

    Carl Farrington Registered Member

    Joined:
    Jun 25, 2004
    Posts:
    57
    Location:
    Manchester, England, U.K.
    I forgot to say, I have tried installing in Safe Mode. Still the same problem.
     
  3. Carl Farrington

    Carl Farrington Registered Member

    Joined:
    Jun 25, 2004
    Posts:
    57
    Location:
    Manchester, England, U.K.
    I forgot to say, I also tried with another user profile (I logged in as Administrator under Safe Mode, rather than the typical user).

    I gave up, and installed AVG. It was awkward to explain why I left him with AVG having explained the benefits of NOD32 in the first place, but this is a single home user (a client director's father), and I wasn't charging for my time but I had been there for four hours in total.

    Why can't we have a proper setup logfile, for example, saying what process was happening (regsvr32 /i amon.dll; copy file amon.dll to %systemroot%\system32\drivers; create regkey HKLM\System\CurrentControlSet\Services\Amon\whatever). Blah blah, then at least one could see exactly what was failing, and could try to manually complete that step, and see why it was failing.

    Also, with full instructions as to the setup procedure, one could install manually, creating all the required registry keys etc.

    This would be useful.
     
  4. teampump88

    teampump88 Registered Member

    Joined:
    Dec 19, 2006
    Posts:
    13
    Try contacting ESET Technical Support. There have been a lot of similarly described cases lately, and I believe they are trying to track these scenarios.

    http://www.eset.com/support/contact.php
     
  5. Carl Farrington

    Carl Farrington Registered Member

    Joined:
    Jun 25, 2004
    Posts:
    57
    Location:
    Manchester, England, U.K.
    Can anybody explain this part : ?
    I said NO to emon/imon so why is it trying to do Exelib: NOD32MOD_WINNT_ENGLISH_INET
     
  6. ASpace

    ASpace Guest

    Hi !

    See this from your test installation :
    Check this https://www.wilderssecurity.com/showpost.php?p=863309 and also empty the TEMP/TMP folders , there might be something conflicting with NOD installation .

    Also , keeping the telephone numbers of your local UK NOD32 Support guys might be handy next time ;)
     
  7. Carl Farrington

    Carl Farrington Registered Member

    Joined:
    Jun 25, 2004
    Posts:
    57
    Location:
    Manchester, England, U.K.
    I read (ok, noticed in passing) another thread which states that the nod32.xml message is normal.

    Also you will note that I already cleared user and system %TEMP% and %TMP%.

    Telephone wise, I figured this forum was as good as it got, being the official forum, but I suppose I should have tried phoning. I'll bear that in mind ;) cheers.
     
  8. ASpace

    ASpace Guest

    I noticed this just now . What I did was to just look at your log .

    It is more than good but forums (all) are not for speedy answers .
    When you call them you are already discusing possible solutions , you can send them the log and get an answer in a minute . :cool:

    Cheers and nice evening! :p
     
  9. mrnathan

    mrnathan Registered Member

    Joined:
    Dec 13, 2004
    Posts:
    5
    I am experiencing the same problem on a client's computer. Did you ever get a resolution?
     
  10. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Please fill in this link and request a version of NOD32 without EMON.

    Cheers :D
     
  11. mrnathan

    mrnathan Registered Member

    Joined:
    Dec 13, 2004
    Posts:
    5
    OK. I have done so. What causes this problem?
     
  12. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    It can be corruption in MS Office MAPI.

    Cheers :D
     
  13. Graphic Equaliser

    Graphic Equaliser Registered Member

    Joined:
    Nov 5, 2004
    Posts:
    411
    Location:
    London England UK
    Doesn't people asking for special versions because of some 3rd party software on their PCs, tell you that you've coded something too system-specific into NOD32, and you shouldn't really be concerned with the state of, say, MS Office MAPI, for example?
     
  14. mrnathan

    mrnathan Registered Member

    Joined:
    Dec 13, 2004
    Posts:
    5
    I obtained the (NOD32 minus EMON) and was able to install it successfully.

    However, the on-demand scan will not work. If I click ‘Threat Protection Modules’ > NOD32 > ‘Run NOD32’ nothing appears. In task manager I can see that the process nod32.exe has opened and is using ≈ 100% processor time. Even allowing this to run for 15 minutes, the NOD32 on-demand scan windows never appears and the nod32.exe process continues to use all available processor time.
     
  15. flyrfan111

    flyrfan111 Registered Member

    Joined:
    Jun 1, 2004
    Posts:
    1,224
    Not sure Office is still your problem, it may be though, I would try a repair of Office, depending on your version it should be under Help or Tools, you may also need to have the install disks handy.
     
  16. mrnathan

    mrnathan Registered Member

    Joined:
    Dec 13, 2004
    Posts:
    5
    Did the repair on Word 2002 (installed as part of Works Suite 2002).

    Unfortunately, the client also has Office 2000 standard (Pre-SR1a) on his computer, but can not find the installation discs, so I can't do a repair on that, or even install the updates.

    I would uninstall it, but he is using Excel and Outlook and does not have them as part of another Office suite.
     
  17. flyrfan111

    flyrfan111 Registered Member

    Joined:
    Jun 1, 2004
    Posts:
    1,224
    Not sure how to fix it then, I think the problem is the on demand scanner is still trying to use the corrupted MAPI, not using EMON lets you get around it on install, but until you can get to the on demand scanner screen to update the profiles to not use MAPI I don't see a way around it. Try contacting support, again.
     
  18. teampump88

    teampump88 Registered Member

    Joined:
    Dec 19, 2006
    Posts:
    13
    I had this problem before... I sent a case to support and they had me do some registry patch....

    I can on demand scan with the no emon version :D
     
  19. mrnathan

    mrnathan Registered Member

    Joined:
    Dec 13, 2004
    Posts:
    5
    I just received the registry patch from tech support as well and it worked. If anyone else is having this problem and knows how to use notepad to make a *.reg file, the text of the file is everything between (not including) the lines:

    -----------------------------------------------------------------
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config000\Settings]
    "mapi_enable"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config001\Settings]
    "mapi_enable"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config002\Settings]
    "mapi_enable"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config003\Settings]
    "mapi_enable"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config004\Settings]
    "mapi_enable"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config005\Settings]
    "mapi_enable"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config006\Settings]
    "mapi_enable"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config007\Settings]
    "mapi_enable"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Eset\Nod\CurrentVersion\Modules\NOD32\Settings\Config008\Settings]
    "mapi_enable"=dword:00000000
    -----------------------------------------------------------------

    Thanks to everyone for their kind assistance.
     
  20. flyrfan111

    flyrfan111 Registered Member

    Joined:
    Jun 1, 2004
    Posts:
    1,224
    That would do it, glad you got it straightened out.
     
Thread Status:
Not open for further replies.