A problem...

Discussion in 'other software & services' started by curious george, Jul 16, 2008.

Thread Status:
Not open for further replies.
  1. curious george

    curious george Registered Member

    Joined:
    Jun 24, 2007
    Posts:
    218
    I didn't know where else to post this, and if its in the wrong place I apologize ahead of time. Recently i've been getting random errors stating that my computer is out of virtual memory. Thing is, im not running anything in order for it to run out. I've disabled some services just to test it and see if its a correct problem, but it still seems to come out. I run an average of 5-20% cpu and I have 512mb of ram with a 2.4ghz processor. So...any ideas?
     
  2. LoneWolf

    LoneWolf Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    3,408
    If I'm not mistaken, those are the error's I had a while back.
    Adding more memory sloved my problem.
    Even though you are not running anything at the time I think there is plenty running in memory most of the time. (I could be wrong though)
     
  3. curious george

    curious george Registered Member

    Joined:
    Jun 24, 2007
    Posts:
    218
    Besides the normal services and such, I run ESET smart security and SAS and usually aim. But in any case, i think im going to upgrade the memory on this anyway.
     
  4. ccsito

    ccsito Registered Member

    Joined:
    Jul 27, 2006
    Posts:
    1,579
    Location:
    Nation's Capital
    From what I understand, virtual memory is memory taken from the hard drive that is addition to what is on your motherboard. Is it possible that your virtual memory setting was decreased for some reason? Check the Control Panel setting for System icon --> Advanced Tab --> Performance Setting icon and see what is the amount of the virtual memory setting.
     
  5. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
  6. curious george

    curious george Registered Member

    Joined:
    Jun 24, 2007
    Posts:
    218
    I have only used about 8gb of Hard drive space out of 145. I have ccleaner and winxp as well. I check them out often. Turns out my virtual memory was set to 0 as ccsito stated. Now, what is the regular setting for this?
     
  7. Dark Shadow

    Dark Shadow Registered Member

    Joined:
    Oct 11, 2007
    Posts:
    4,553
    Location:
    USA
    O MB paging file? I maybe mistaken here but does not paging file have to do with how virtual memory is used and In general is 2.5 times the size of ram.
     
    Last edited: Jul 17, 2008
  8. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
  9. twl845

    twl845 Registered Member

    Joined:
    Apr 12, 2005
    Posts:
    4,186
    Location:
    USA
    If you look in Process Explorer, you will see SAS cranking constantly.
     
  10. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
    PS - Make sure you're viewing stat's for the active partition. Allow the system to manage it or choose custom. Provided we're referring to XP and you've chosen the latter, start with an initial value x 1.5 physical ram, max x 3. The alternative short of more ram is toying with that monitoring utility mentioned in my previous link's and making use of the information provided by post eight.

    Steve
     
    Last edited: Jul 17, 2008
  11. ccsito

    ccsito Registered Member

    Joined:
    Jul 27, 2006
    Posts:
    1,579
    Location:
    Nation's Capital
    It depends on the size of your hard drive. My system has virtual memory set to 2GB (or 2047 MB) which is the same amount of RAM that I have. If you click on the change icon that is available for the virtual memory page, it will show what is the minimum and maximum setting for virtual memory for your Operating System. You can set it between the specified range.
     
Loading...
Thread Status:
Not open for further replies.