Windows 7 Firewall + wrong tray icon

Discussion in 'other firewalls' started by Arcanez, Oct 11, 2011.

Thread Status:
Not open for further replies.
  1. Arcanez

    Arcanez Registered Member

    Oct 5, 2011
    Event Horizon
    hey there,

    I noticed since I configured my windows 7 firewall with advanced settings that my tray icon that indicates the connection status to the internet shows that I am not connected although I am...It has a yellow warning sign telling me that there's no connection to the internet.

    However the icon turns to "connected" as soon there is internet traffic in any way. Opening a browser and going to a webpage will make the icon turn to connected immediately. Also sending pings to certain webpages. In fact I am already connected to the internet right after the windows boot but it seems windows can't recognize it due to the firewall.

    When I turn the firewall off the connection tray icon shows up correctly right at at the start.

    I configured the Windows Firewall like so:

    Allow all inbound connections ( reason is a have a router also)

    Deny all outbound connections (created rules for every application that's allowed)

    I kinda want to keep the firewall like this in case I do have something on my comp wanting to call home, in that case the malware wouldn't be able to...

    So what do I have to do to make the connection tray icon show up correctly right after the windows boot? Or is that just normal that the icon does not recognize that there's an internet connection right from the start?
  2. EboO

    EboO Registered Member

    Mar 12, 2011
    I've got the same problem, if it's a problem.
  3. Kees1958

    Kees1958 Registered Member

    Jul 8, 2006
    Some options depending on OS

    Option one (most likely)
    Go to Control Panel > Network Connections > Local Area Connection

    Then tick on Show connection status icon on taskbar

    Then press OK

    Option two
    Go to run/or enter directly at the tick box at menu start

    Then type "services.msc" hit OK

    Search for a service that is called

    Wireless zero configuration and/or WLAN autoconfig

    click on it the hit >>> start the service on the top left.

    change it to automatic

    then go back to your wireless connection windows and hit the icon "view wireless network"

    Third option

    Ignore title, this remedy also applies to most WMI related problems

    Good luck
  4. Yash Khan

    Yash Khan Registered Member

    Apr 4, 2011
    I am with the default Windows FW, no settings changed.

    Same thing here. Once I open a browser or do any kind of traffic activity it changes to connected.

    But few things here.

    This happens when I use my broadband connection which is a PPPoe connection for which I have to provide username & password & conect. It connects but the windows connection icon shows yellow icon till I do any traffic connectivity.

    This doesn't happens when I use my broadband connection wirelessly through router. The wireless connects automatically & windows connection shows connected. No need of any traffic activity.

    Win 7 64

Thread Status:
Not open for further replies.