TrueImage 9 reliability

Discussion in 'Acronis True Image Product Line' started by PaulSiu, Sep 30, 2005.

Thread Status:
Not open for further replies.
  1. PaulSiu

    PaulSiu Guest

    I posted about the speed recently. In the past, I find that TrueImage had been reliable, but not speedy. However, there are now numerous post about lack of reliability. Backup is only good if it works. My questions are:

    1. What sort of problems are you having in general.
    2. Has Acronis been responsive to getting the issues fixed.
    3. Has most of these problem have been fixed?

  2. foghorne

    foghorne Registered Member

    Sep 27, 2005
    Leeds, Great Britain
    There will always be exceptions but my own perception on where TI V9 is at the moment is that there seem to be 4 classes of problem :

    1. Failure to manage expectations on the file backup. It not possible to plug in a backup if it is a file backup. It seems that Acronis have failed to communicate this, leaving the reasonable implication wide open that it should be possible to do so. It is never nice to buy a product and then find out that it does not do what you believed it would. There is nothing in the documentation to say that this feature is not available as far as I can see. Nevertheless it is intentionally unsupported.

    2. Small bugs seem to have been reported with file level backups and restore (e.g from the boot disk)

    3. Hardware teething problems. With this type of product this is inevitable and Acronis normally get on top of this (eventually)

    4. Miscellaneous user interface bugs. Whilst this does not affect the generally robustness of the product, it is perhaps indicative that V9 is still relatively immature and untested in places.

    In summary it would seem that the disk/partition imaging is reliable, but the new features are still bedding in. If this is a true analysis it begs the question why we are not all using V8 :)
  3. tonyangelo

    tonyangelo Registered Member

    Aug 1, 2005
    1. Imaging data to securezone gives Message - "Completed with errors, see log"
    2. Techsupport responsive (currently in vain)
    3. No successful resolution yet
  4. Technic

    Technic Registered Member

    Aug 31, 2005
    1. many
    2. no
    3. no
Thread Status:
Not open for further replies.