TrueCrypt Won't Recognize my non-system Drive anymore! Help?

Discussion in 'encryption problems' started by bmracerx, Oct 18, 2010.

Thread Status:
Not open for further replies.
  1. bmracerx
    Offline

    bmracerx Registered Member

    [have tried posting this in tc forums, no response]

    Basically, i have a 2TB hd encrypted as a whole disk encryption (so the entire hd is encrypted, no seperate virtual volume files or anything)... and when i go to the "Select Device" button on the main TrueCrypt dialog (you can't miss it) the 2TB volume is not there at all!!!

    i've tried this (accessing it) on another computer, nothing! i've purchased a sata case so i can run my 2TB HD as an external drive and try accessing it this way in case it made a difference, but it doesn't!

    When i installed the external hd case, everything went fine, and in Computer Management it recognized a drive that needs to be initialized (which i presume would be the 2TB drive) so from this i deduce that windows does recognize the device but can't make sense of it since it's encrypted. of course, it doesn't show up with a drive letter or anything if you go to your "My Computer" link... so im assuming TrueCrypt is having problems with this and ain't recognizing this. Since it is not a system-boot partition, i didn't try the rescue disk since its probably not related to this volume.

    any ideas guys? i've got 600 GBs of space, astronomy, universe related documentaries (largest collection in the world) collected over years, that i was about to publish on a good torrent site to share with everyone, and then this happened!!! i beg for your advice and guidance....

    ps: just to add, i did not 'initialize' the disk since i don't know exactly what it means or will do, there are varying opinions on the internet claiming that it will or won't format the hard drive. any suggestions as to weather initializing it would help or not would be appreciated.
  2. MerleOne
    Offline

    MerleOne Registered Member

    Just in case, you should probably buy a replica of your HDD and clone it with a tools such as HDClone so that if you mess up with the original, you'll have a backup, or leave the original in a closet and work on the clone.

    On your issue with TC, sorry, can't help here.
  3. Cutting_Edgetech
    Offline

    Cutting_Edgetech Registered Member

    Does the drive show to be online or offline under under disk management?
  4. katio
    Online

    katio Guest

    "initialize" will write a MBR to the drive, overwriting the Truecrypt header. It's not the end of the world though because TC can restore it from an embedded backup header - IIRC...
    Try repairing the drive with Truecrypt, there's an option for what I just described above.

    Did it work at some point and then suddenly stopped?
    Have you done this with other drives as well? Could be TC has a problem with discs larger than 1.5 TB or something like that.

    and where is your Backup? :ouch:
  5. bmracerx
    Offline

    bmracerx Registered Member

    @Marle, thank you, that is a great idea!

    @CuttingEdgeTech, in disk management area in computer management, the device isn't shown, however, as soon as i load the disk management area, it asks me if i want to initialize "Disk 2" with the message: "You must initialize a disk before logical disk manager can access it"... should i do this?

    also, i can see that "Disk 2" is labeled as "Unknown" as opposed to online or offline - what do you think?

    @katio, this is exactly what happened, it just suddenly stopped working one day. also, i looked at tc's menu options and i cannot find a repair option. would the tc repair option be able to recognize the hd if its main interface is unable to recognize it? either way, i would still love to give it a shot if you could let me know how to find this option.

    TO ALL:

    thanks for your replies once again, i've tried this on two different instances of truecrypt, one on my desktop and one on my laptop, this device is not recognized in either of them. you know when you click "Select Device..." on main programs page? it isn't listed there as all the other hard drives are, so i'm really worried if its a HD issue or a truecrypt issue, what do you guys think based on what we know?

    either way, i will still investigate and execute all leads anyone provides.
  6. jhngc
    Offline

    jhngc Registered Member

    I know this is an ancient post but I've had this problem with partitions before though not entire drives. I had to use partition software(starts with an E but any should work). It would see the drive but have asterisk where the drive letter should be. I went to advanced and set a drive letter. Hope this helps someone with the same problem.
  7. DavidXanatos
    Offline

    DavidXanatos Registered Member

    does it head a driveletter befoure?
    Have you encrpted the entire drive or only the one partition on it?
  8. wutheringheights
    Offline

    wutheringheights Registered Member

    I had a similar problem. I deleted two TrueCrypt partitions without having backed up the data completely. Irreplaceable data.

    Under no circumstances do anything to the original HDD like 'initialize' or 'format'. Don't write anything to it without guidance.

    I contacted M. Christophe Grenier of http://www.cgsecurity.org/ He is the author of TestDisk, a utility that can deal with such problems, although you really have to have expert knowledge to use it properly. M. Grenier walked me through an analysis of the HDD in English (he is French). This involved looking for TrueCrypt partition headers (sometimes guessing) and then rebuilding the MBR.

    Shorter Grenier: I got my data back free. I highly recommend him.

    Wuthering
    Last edited: Dec 19, 2010
  9. wutheringheights
    Offline

    wutheringheights Registered Member

    Just to be clear, this was not a matter of having lost the TrueCrypt password. I am unaware of any solution to a lost-TrueCrypt-password problem. It was a matter of reconstituting the MBR to point to the two deleted TrueCrypt partitions which were otherwise undamaged. The TrueCrypt partition headers were intact (or at least could be rebuilt automatically by TrueCrypt from the embedded backup headers). The problem was to rebuild the MBR on the whole HDD so that TrueCrypt found the EXACT starting point of the partitions. As someone pointed out in another thread, TrueCrypt has to have the EXACT starting point of the partition in order to work.

    The basic method was to use TestDisk, including a version under development, to scan the HDD for TrueCrypt headers.

    In the particular case of bmracerx's problem, it appears that there is only one partition and that the MBR is damaged. I hope that similar techniques will allow it to be rebuilt.

    As for what I did, the only things I did were: 1) not write anything to the HDD and 2) follow M. Grenier's instructions.

    In addition I now take the precaution of making off-HDD TrueCrypt-header backups, using the corresponding TrueCrypt function.

    Wuthering
    Last edited: Dec 19, 2010
Thread Status:
Not open for further replies.