System Preferences opens on boot

Discussion in 'NTFS for Mac & ExtFS for Mac' started by paulsuk, Nov 16, 2011.

Thread Status:
Not open for further replies.
  1. paulsuk

    paulsuk Registered Member

    Joined:
    Nov 16, 2011
    Posts:
    1
    Location:
    UK
    Hi,
    Every time I start up the Mac, System Prefs opens to the Paragon NTFS for Mac page, regardless of the settings on that page (AFAICT) or whether there's any NTFS drive attached.
    Any ideas how to prevent this?
    OS X Lion
    NTFS for Mac 9.5.0 (registered).
    Thanks.
     
  2. GeHoGo

    GeHoGo Registered Member

    Joined:
    Feb 2, 2012
    Posts:
    2
    Workaround for reappearing Paragon NTFS preference pane

    I had the exact same problem myself with Paragon NTFS 9.5.2.

    I thinks it's clearly a bug in the software, but I managed to come up with a workaround:

    The reason for the reappearing preference pane at startup/boot is that Paragon NTFS checks for a specific file at a specific (hardcoded) location:
    Code:
    /Users/[I][COLOR="Sienna"]<<your_username>>[/COLOR][/I]/Library/Application Support/Paragon NTFS for Mac OS X/.notfirsttime
    In case you move the folder of a user (for example with the normal system user preference) to a different location, let's say to
    Code:
    /Volumes/<<second_harddrive>>/Users/
    Paragon NTFS creates the .notfirsttime-file correctly in the folder
    Code:
    /Volumes/<<second_harddrive>>/Users/[I][COLOR="Sienna"]<<your_username>>[/COLOR][/I]/Library/Application Support/Paragon NTFS for Mac OS X/
    but on next startup it checks within
    Code:
    /Users/[I][COLOR="Sienna"]<<your_username>>[/COLOR][/I]/Library/Application Support/Paragon NTFS for Mac OS X/
    where it can't find the file and thus showing the "first time" preference pane again.

    You can solve this misbehaviour with two workarounds:
    1. just create a soft link for the relevant users in /Users/ to the new location with
      Code:
      ln -s /Volumes/<<second_harddrive>>/Users/[I][COLOR="Sienna"]<<your_username>>[/COLOR][/I] /Users/[I][COLOR="Sienna"]<<your_username>>[/COLOR][/I]
    2. create the according folder and the appropriate file yourself with
      Code:
      mkdir /Users/[I][COLOR="Sienna"]<<your_username>>[/COLOR][/I]; cd /Users/[I][COLOR="Sienna"]<<your_username>>[/COLOR][/I]; mkdir Library; cd Library; mkdir "Application Support"; cd "Application Support"; mkdir "Paragon NTFS for Mac OS X"; cd "Paragon NTFS for Mac OS X"; touch .notfirsttime

    Maybe this workaround can help you.

    Best regards


    Gerhard
     
  3. redvivi

    redvivi Registered Member

    Joined:
    Mar 31, 2012
    Posts:
    1
    Hello,

    I have the same issue despite the fact that the .notfirsttime file exists in
    Code:
    /Users/myusername/Library/Application Support/Paragon NTFS for Mac OS X/
    Also, it seems that the Paragon's Preferences Pane module doesn't save the update notifications preference.

    Each time I open the Paragon's Preferences Pane, the option is always unchecked.

    What can I do ?

    Regards,
    redvivi
     
  4. ChipMcK

    ChipMcK Registered Member

    Joined:
    Feb 11, 2012
    Posts:
    6
    Location:
    U S of A
  5. Paragon_MA

    Paragon_MA Paragon Moderator

    Joined:
    Aug 17, 2009
    Posts:
    142
    To resolve the issue you need to delete the service which is starting Preferences Panel with NTFS for Mac OS X.

    1. Go to Applications - Utilities
    2. Open Terminal
    3. Type in

    sudo rm /System/Library/LaunchAgents/com.paragon.NTFS.notify.plist

    4. Press Enter and provide Administrator password
    5. Press Enter again

    Preferences pane will not pop up again.
     
Thread Status:
Not open for further replies.