Puzzler

Discussion in 'FirstDefense-ISR Forum' started by mrfargoreed, Aug 28, 2007.

Thread Status:
Not open for further replies.
  1. mrfargoreed
    Offline

    mrfargoreed Registered Member

    I've discovered a problem that I can only relate to FDISR and I wondered if anyone else had similar.

    I've got about 8 snapshots on my hard drive. I have one hard drive for my operating system only and another for data.

    On most of my snapshots I can transfer files just fine - an example if a 3GB folder. In most snapshots this takes about 2 minutes. BUT if I boot into another snapshot, the same operation can take about 18 minutes!

    There doesn't seem to be any pattern to this - I have my primary with all security software and this file transfer takes 2 minutes. I have an almost identical snapshot (same security setup but I am the only user) and the transfer takes 18 minutes. I haven't installed any different software or anything. It can be infuriating as the entire snapshot seems to come to a complete crawl - as though the processor is on it's last legs. Yet I boot into a different snapshot and everything is fine again.

    I wondered if anyone has experienced anything like this before? If it was happening on all snapshots then I would obviously think a reformat was needed, or my processor/mother board was on its way out, but it seems fairly random. I've tried booting from within FDISR to snapshots, rebooting and selecting snapshots from the boot screen, turning the pc on and off again, but nothing seems to be working.

    Many thanks in advance.
  2. Long View
    Offline

    Long View Registered Member

    Have you Crtl-Alt-Del to see what is running in the slow snap shot compared to
    a faster snapshot ?
  3. mrfargoreed
    Offline

    mrfargoreed Registered Member

    Yes Long View, I have checked the Task Manager and there's nothing different - nothing ever hogging the resources.

    An example is: using a perfectly good snapshot where file transfers are normal, fast speeds. Copying the folder mentioned takes 2 minutes. I archive the snapshot, checking that the speed of transferring the file is ok.

    Today I boot into a few snapshots and use my browser, email client, etc. I don't install any new software. The whole system comes to a grind and I can't seem to do anything. The only thing that I notice is that the traffic on my firewall (Comodo) is very slow - as though it's draining all my resources. Strange thing is that I'll reboot and everything seems fine again, but I can't transfer folders on my machine (well, I can but they take an age - and it's not just file transfers - it's unraring files, opening browsers - anything).
  4. ErikAlbert
    Offline

    ErikAlbert Registered Member

    mrfargoreed,
    Do you defragment regularly ?
  5. Peter2150
    Offline

    Peter2150 Global Moderator

    Where is the delay. During the actual copy or is it during the preparing to copy.
  6. mrfargoreed
    Offline

    mrfargoreed Registered Member

    Yes ErikAlbert - I use PerfectDisk every couple of weeks on the whole system. Also, if it was a defrag problem, wouldn't the slowdown be on all snapshots? It only appears to be on some snapshots - I just haven't worked out what is causing the problem.

    I have fresh XP snapshots where everything is fine. I also have a full snapshot with all software, settings, etc - my Primary - that is also ok. However, yesterday I installed CloneCD on a fresh XP snapshot and the problem appeared again - after installing only one piece of software. There doesn't seem to be any pattern at all.

    I originally thought that it might be Comodo firewall, but I have this on my Primary Snapshot and it works fine - so slowdowns whatsoever.
  7. mrfargoreed
    Offline

    mrfargoreed Registered Member

    During the actual copy, Peter2150. If I copy in a 'good' snapshot, the whole folder copy takes about 2 minutes. In 'bad' snapshots, the copy just doesn't seem to even start (it does start, just very slowly). The time left is instantly 17-18 minutes of the same folder. If I copy a full DVD folder (6-7GB), this goes up to 45 minutes! Surely this isn't right.
  8. Peter2150
    Offline

    Peter2150 Global Moderator

    Absolutely not. I discovered that Anti-Executable, although disabled was the cause of my problem, so it may be something slightly diffferent, in that snapshot.

    Pete
  9. mrfargoreed
    Offline

    mrfargoreed Registered Member

    Thanks Peter2150 - I think it may be time for a reformat anyway, so I'm going to wipe the lot and start again, and then see if I get the same problems from a totally clean installation of Windows and FDISR.
  10. ErikAlbert
    Offline

    ErikAlbert Registered Member

    mrfargoreed,
    Do you use 4 work snapshots and 4 rollback snapshots or all of them 8 work snapshots ?
  11. pandlouk
    Offline

    pandlouk Registered Member

    Have you run chkdsk to check the intengrity of the partition?
  12. mrfargoreed
    Offline

    mrfargoreed Registered Member

    I use 4 for work and 4 for rollback.

    I have tried chkdsk - it doesn't make a difference.

    Could it be anything to do with using SATA drives? I'm scraping the barrel here I know, but is FDISR ok with two SATA drives? I've never read anything to say it won't work with them, but I just can't figure this out.
  13. Huupi
    Offline

    Huupi Registered Member

    FDISR is on a SATA rig for a year now.never problems SATA related.
  14. ErikAlbert
    Offline

    ErikAlbert Registered Member

    mrfargoreed,
    It shouldn't be a problem to have 4 work and 4 rollback snapshots, but you have alot of snapshots this way.
    Maybe you can consider 4 work snapshots and 4 rollback archives.

    If you have 4 rollback archives based on the actual up-to-date 4 work snapshots, then you have the possibility to do this :
    1. Create first 4 archives of all 4 up-to-date work snapshots.
    (You can also use your 4 rollback snapshots to create these archives, if they are good enough).
    2. Boot in the work or rollback snapshot, you want to keep after uninstalling FDISR completely.
    3. Uninstall FDISR completely, including all snapshots.
    4. You might do some cleaning, defragging, run "chkdsk c: /f " or "chkdsk c: /f /r" (= takes much longer) first.
    5. Re-install FDISR
    6. Restore all 4 archives in the primary, secondary and two new snapshots.
    7. No need to create 4 rollback snapshots, because your 4 archives are now your rollback "snapshots".

    This is quite easy to do, not much work, except waiting and waiting ... until it's done.
    Hopefully there is some improvement. Hard to tell in advance, if this will solve your actual problem or not.

    Since the problem occured suddenly, try to remember what you did, this might help too.
    Last edited: Aug 29, 2007
  15. twl845
    Online

    twl845 Registered Member

    Assuming all your snapshots are almost the same, I would update the slow snapshots from a fast snapshot. That should clear what ever is slowing the slow snapshots down.
  16. mrfargoreed
    Offline

    mrfargoreed Registered Member

    I'm thinking the same because otherwise I would get the problem on ALL snapshots ALL the time.

    My mistake ErikAlbert - I meant to say I have backup archives on my Data drive, not snapshots.

    A good idea ErikAlbert. I've just reformatted and reinstalled everything, and at the moment everything is going ok - no slowdowns so far, but I've still got a little more to do before my machine is totally how I want it to be. If I'm still getting problems, I will try exactly what you have said. Time is no problem for me - I just want this little problem to be sorted.

    I'll certaily give it a try if ErikAlbert's suggestion doesn't work and if my reinstall/reformat solves the problem. :thumb:
  17. ErikAlbert
    Offline

    ErikAlbert Registered Member

    Yes, I would certainly try twl's suggestion too.
    If the problem is caused by something inside in one or more snapshots, my proposal might not work, because the restoring of archives won't solve the problem then.
    If you copy the normal working snapshots to a new snapshot and you change the new snapshot to its original contents, it might solve the problem also.

    It's only a pity, that we don't know the REAL CAUSE, but twl's or my solution, might tell us more.
  18. mrfargoreed
    Offline

    mrfargoreed Registered Member

    Well I'm not going to lose sleep just yet, but I just booted into my 'Editing' snapshot to backup a DVD. The ripping process took the usual time - about 15 minutes. I thne went to shrink the disc, which normally takes about 20 minutes. This time it came up as 58 minutes! Unwilling to wait this long (knowing that it shouldn't take so long) I rebooted into the 'Editing' snapshot and tried again to shrink the disc - 18 minutes!

    Could it be booting from/to snapshots? Is there a difference booting to snapshots from within the FDISR console and booting at the machine start pressing the F1 key? I find it strange that there could be any difference (and I'm sure I never used to have this problem), but it seems strange that a simple reboot and my machine appears to be back to normal.

    I think I will continue setting up my Primary Snapshot and then run chkdsk on my whole system (again).
  19. ErikAlbert
    Offline

    ErikAlbert Registered Member

    mrfargoreed,
    I also do video-editing and shrinking and it happened sometimes that my video-editing took 33 minuts instead of 10 minuts for the same volume, but this happens only occassionally.
    I blame my video-editor for this because I didn't notice any slowdown in my copy/update function yet.

    I do my video stuff in my off-line snapshot, which has
    - no internet connection (disabled in Windows)
    - no security softwares (not needed)
    - no internet-related softwares, like browser, email, ... (I can't use them).
    So this should be the best environment to do video stuff without any possible disturbance, nevertheless it takes sometimes longer to do the same job and I don't know what the reason is.

    I hope you do some cleaning after video-editing, because these softwares use sometimes temporary files, that need to be cleaned.
    If you don't do it this might influence the speed of your copy/update.
    Last edited: Aug 30, 2007
  20. mrfargoreed
    Offline

    mrfargoreed Registered Member

    Hey ErikAlbert!

    My Editing Snapshot is a very minimal Windows with a couple of DVD editing programs, Photoshop and SnadboxIE in case I need to do some surfing. That's about it. I also use CCleaner to keep all my snapshots clean and as free from junk and temp files as possible.

    It's strange that you also get the problem of tasks taking much longer than usual - do you think it could be something to do with FDISR? I've no idea what, but just odd it happens on some snapshots and not others.

    I'll never stop using FDISR anyway - it's just an annoyance that I thought might be connected to FDISR. It's still the best piece of software on my system no question and there's no way I'll ever get rid of it.
  21. ErikAlbert
    Offline

    ErikAlbert Registered Member

    I don't think it is FDISR, but it happens regularly. Most of my video-editing is normal and as I said so many times : I don't know much about computers and certainly not the technical stuff. I'm just a good observer and know when something isn't properly.

    Since I do video-editing, I keep an eye on the volume of my system partition and data partition, because video requires alot of space.
    In the beginning, my volume increased significantly, because my video-editing created temporary files to do the final job and those files remained on my harddisk and this caused longer copy/updates and image backup.
    So I clean the mess first before I do my backups.
Thread Status:
Not open for further replies.