Problems with Personal Firewall & Web Access Protection

Discussion in 'ESET Smart Security' started by CPN, Jul 11, 2009.

Thread Status:
Not open for further replies.
  1. CPN
    Offline

    CPN Registered Member

    Hi all,

    I just purchased ESET Smart Security (Version 4) and am having problems with the following:

    1. Personal Firewall - In 'Protection Status', it states that the Personal Firewall is not working properly and 'Personal Firewall rules could not be converted for an unknown reason'. Under 'Setup' it also says 'No filtering mode defined. The personal firewall is malfunctioning. A computer restart may be required.' (I did do a restart but it did not fix the problem). The Personal Firewall Module is 1050 (20090625).

    2. Web Access Protection - In the 'Setup' and then under 'Antivirus and antispyware protection' it has Web Access Protection as 'Non-functional'.

    I have changed the Firewall setting to interactive mode and read about the patches in the FAQ section on the ESET website (but these do not seem to apply to the Module number I have).

    When I enter the 'entire advanced setup tree' and go to the Web Access Protection section, the check box beside 'Enable web access protection' can not be clicked, and the 'Setup' button beside 'Threatsense engine parameter setup' also can not be clicked. (They appear in grey).

    Can anyone help?

    Thanks in advance.
  2. Marcos
    Offline

    Marcos Eset Staff Account

    Does ESS 3.0.684 work fine?
  3. CPN
    Offline

    CPN Registered Member

    Hi Marcos,

    I had the trial version (Antivirus only) installed for the last month and that worked fine. But I'm not sure what version that was.

    Any ideas on how I can get this version of ESS to work?

    Regards.
  4. ASpace
    Offline

    ASpace Guest

    What about performing uninstall , manual clean-up and then install the product again - just to ensure it is not something in the installation that got messed-up.

    I suggest you first try to uninstall from Start → Programs → ESET → (ESET product name) → Uninstall

    Then , read this article and follow steps 2-9

    Make sure that when you download the new version you use the very latest build taken from ESET site/servers - 3.0.684 or 4.0.437


    N.b! If the problems with the firewall and/or the web scanner continue even after reinstallation , follow these instructions from Aryeh + install v 3.0.684
  5. sgp
    Offline

    sgp Registered Member

    ASpace,

    I am having identical problems to those posted by CPN and can confirm that uninstalling ESET using the method outlined in KB Solution ID: SOLN558 and then re-installing ESET v4.0.437.0 *does not* work.

    I have not tried installing v 3.0.684

    Regards
  6. ASpace
    Offline

    ASpace Guest

    Hello !

    Perhaps you mean that uninstalling + reinstalling actually works but what doesn't work is ESS afterwards ... and the fact it reportd errors or disables internet connectivity ?

    Have you also followed Aryeh Goretsky's instructions I posted a link to ?

  7. The PIT
    Offline

    The PIT Registered Member

    I had the same problem due to borked uninstall of version 3.0

    As SGP says the instructions don't work.

    Anyway after a lot editing in the registry I manged to get version 3.0 backup and running and left it on since version four is flakey anyway.

    Maybe worthwhile if the mods sent the others the uninstaller and see if that fixes the problem.

    Interestingly if you look at the location where the firewall rules are stored there isn't any. I even tried copying them across from another pc but still had the same problem.
  8. sgp
    Offline

    sgp Registered Member

    Hi ASpace,

    You are right - the uninstall and the reinstall worked as described but ESS doesn't. I followed yours and Aryeh Goretsky's instructions ad verbatum but the firewall module continues to give problems.

    I decided to do an uninstall followed by a custom reinstall (selected interactive filtering on the firewall module) and amazingly managed to get ESS working.... Until I rebooted the system and then ESS did not work.

    I have tried numerous (helpful) suggestions posted on this forum including safe booting and scanning for malware/viruses. I can only conclude the problem rests solely with the firewall module and Vista (since I have ESS 4 installed on other XP machines with no issues).
  9. The PIT
    Offline

    The PIT Registered Member


    Err no I have the problem on an XP machine.
    Somewhere oh somewhere will be a rogue registry entry that needs removing but what it is I don't know because I thought I got them all after 20 minutes or so of registry editing.
  10. CPN
    Offline

    CPN Registered Member

    Thanks for your posts everyone.

    I still need to try to do the uninstall and reinstall that has been suggested; but I seem to have a rogue anti-spyware virus/trojan that keeps reappearing (Antiawarepro.com hijacker) despite removing it repeatedly through the Ad-Aware program (ESS doesn't pick it up for some reason).

    I'm thinking maybe I need to sort this out first in case that this is the cause of the firewall problem rather than ESS.

    BTW, my PC runs on XP too.

    I'll post again with an update as soon as I can.

    Cheers.
  11. Marcos
    Offline

    Marcos Eset Staff Account

    I'd suggest submitting a log from SysInspector to customer care for perusal.
  12. CPN
    Offline

    CPN Registered Member

    Hi Marcos,

    Thanks for your reply. I'm running SysInspector now. Will advise outcome.

    Cheers,
    CPN.
  13. CPN
    Offline

    CPN Registered Member

    Marcos,

    I've run SysInspector - how/what part do I need to send to ESET? I'm not familiar on how to work with SysInspector logs.

    Thanks,
    CPN.
  14. sgp
    Offline

    sgp Registered Member

    Hi CPN,

    After you've run the SysInspector, right click on the file you created and choose to export. It will save the file as an XML which can then be attached to an email.
  15. Indy11
    Offline

    Indy11 Registered Member

    I am using XP - SP3

    I just had this problem myself, new to ESET. My error was that I had forgotten that I was running a free anti-malware application (it was hidden). When I first installed ESS. So I uninstalled it and I attempted ESS repairs and reinstalls but got the same "not converted for some reason" message.

    Finally I used a total uninstall app (used Revo) to remove ESS and rebooted and then reinstalled ESS, same version as yours. And it now is working fine.
Thread Status:
Not open for further replies.