Personal Firewall and LAN

Discussion in 'ESET Smart Security' started by cmacandrew, Mar 28, 2008.

Thread Status:
Not open for further replies.
  1. cmacandrew

    cmacandrew Registered Member

    Mar 28, 2008
    I have a small network of two computer. One is a desktop and one is a laptop. The computers are in the same workgroup but cannot see each other. If I uninstall Eset Smart Security the network works ok. I have made the changes it says to do on the website. I set the mode to interactive and checked sharing. It did not change a thing. One computer is running xp home and the other vista home premium. The computer with Eset on it, if you click on view workgroup computer, the page is blank.
  2. shansmi

    shansmi Registered Member

    Feb 19, 2008
    I know nothing of ESS on XP but I have the same network with 2 Vista Machines that are both running ESS with everything working fine (file sharing and media sharing between the 2 and an Xbox). After install you will need to ensure to allow file sharing (there is a prompt that comes up immidately after install about file sharing that adds in all the basic rules for the truest zone) and if you do a custom/advanced install you can set the firewall to interactive mode - it should then ask you for permission as all the SVCHOST.EXE's start up whether to allow the traffic (be sure to save your choice).

    Now lets talk about your install. Maybe you could totally remove ESS and do the custom/advanced install in order to immediately set the firewall to interactive remove it do the following on the vista machine but some of the directories will not be there in XP like ProgramData....but do everything else...

    This is all from other posts that has worked for me every time...

    after uninstall delete these folders before the reboot
    C OR D:\Documents and Settings\All Users\Application Data\ESET
    C OR D:\Documents and Settings\USERNAME\Application Data\ESET
    C OR D:\Program Files\ESET <--- will be deleted by the reboot
    AND registry keys

    reboot your PC

    go back and look for all the directories and registry keys noted above as well as:

    Open Control Panel -> 'Network Connections', right-click ‘Local Area Connection’
    and click ‘Properties’. Under ‘This connection uses the following items’ make
    sure you don’t see ‘Eset Personal firewall’ listed. If so, select it and click
    the ‘Uninstall’ button.
  3. scottb2

    scottb2 Registered Member

    Apr 9, 2008
    I have the same problem with 3 x WinXP SP2 computers in a Workgroup.

    Have already changed to Interactive mode and set for File Sharing but the PCs still cannot see each other.

    Are there any other settings which can be changed apart from the uninstall/reinstall mentioned previously ?
  4. Jenee

    Jenee Registered Member

    Dec 27, 2007
    Firstly, do you have the latest version of ESS as earlier versions caused network problems. If you do have the latest version, rather than uninstalling, I would suggest setting up your workgroup again on each pc and then restarting. When you restart, you should see an ESS box appear asking if you want to turn on sharing which you should do.
    If you still have problems, have a look at your system rules to see if a rule has been created that is blocking the network.
Thread Status:
Not open for further replies.